Ardour 8.4 Calf plugins [ERROR]: failed to instantiate LV2 GUI


After installing Ardour 8.4 all Calf plugins work but for some reason it fails to initiate GUI.

Any idea why this happens?


1 Like

They are known to be problematic duet to Gtk GUI. Also they are old and no longer developed. Anyway, They have always worked well for me with Ardour compiled for openSUSE but since 8.4 there some issues. For example with Calf vintage delay, slider are missing.
Same error with the official build.
Try to avoid them as much as possible.

Was very happy with the vintage delay.
Any alternative plugin which is somehow equivalent?
Would it help to recompile them myself? Like I did for some other old ones.

Note that Calf will likely soon vanish from many GNU/Linux distributions as well.

A bit of background:

Various GNU/Linux distros are dropping GTK2. This means that all software that still depends on it can no longer be packaged. Notably Debian is finally doing this, which affects all debian based distributions (Ubuntu, UbuntuStudio, AVLinux, KXstudio, …)

Ardour was affected by this, which is which is Ardour 8.4 internalized the toolkit. This in turn breaks plugins that still rely on GTK2+. We’ve been telling plugin developers since over a decade to move away from GTK for various reasons. Most listened…

Back to Calf. It’s not just Debian, Arch Linux is about to drop it as well:

The complete List of packages marked for removal on March/6 2024 can be found at


I don’t think there’s a 1:1 replacement… none that I know of. You can try with some stereo delay from Guitarix or you can do more advanced stuff with Delay Architect. There are some Arwindows delays but never used…

Yes we know… but can you explain the missing slider? Usually they work or not and they were workng fine untill 8.4 on openSUSE TW.

very likely an artifact from gdk-pixbuf. The version that comes with Ardour now only supports a minimal subset (png, xpm, xbm).

Aaah … airwindows.
For sure I can use the Calf stuff with the generic interface !!
It sits in one of my effect busses anyway without much user interaction.

Thanks Robin, that gives me some clarity. I thought it was something on my setting, I can still use the inline controls from Ardour which seems to work fine for no.

Ooof. Sounds like I shouldn’t have ignored years of gentle warnings! :smiley:

I guess I should finally give up on EQ10Q, as well.

I’m super grateful that, while the fancy interfaces were lost, the functionality remains. This will give me a chance to export some multitracks and stems from various past projects before some future distribution upgrade that no longer includes the plugins.

Yeah, the EQ10Q is part of my regulars plugin.

I guess that I will start using more the LSP ones.

Any tips on alternatives to calf?

The problems are that often there’s no a clear alternative. I use eq10q a lot and AFAIK the only alternative for mid/side eqing is lsp-parametric-eq. Great plugin with, IMHO, excessive complexity in the GUI. So even if you know that at some point things will stop working, you try to postpone the switch as much as possible to see if new aternative comes out.

While not as easy as a switch in the plugin, Ardour’s ACE Stereo Routing has “to Mid/Side” and “from Mid/Side” options.

And the you can add two EQs, one for each channel to separately EQ mid and side:


Thanks for the workaround but to be honest ugly like hell. What if I also nees a L/R eqing ? 4 plugins more ?

No religious wars but I try to use only open source software but damned it’s really complicated.

Invada plugins are also based on Gtk2 :frowning:

Just one.

Yeah, and ir.lv2 and phasex,… (see the complete List … link above).

1 Like

Stupid question from someone who does not know too much about graphic toolkits, programming and compilation:
Is there an easy option to compile calf and invada without gtk2, only the engine with the generic gui?

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.