Can't load ACE Fluidsynth in Ardour 8.4

This is a known problem caused by an icon file somewhere on your system.

So far nobody has put in the time or been successful in determining which file is the problem.

Ok, could I find out what the annoying icon file could be?

Any other workaround except going back to 8.2 loading the SF2 file,
opening with 8.4?
Editing a file in the plugins directory?

DaD does not work, cause the plugin GUI disappears when I go to Dolphin

Just read the ticket history. from that I assume there’s not a lot I can help to debug.
If I can please let me know. For me loading SF2 files is kind of essential :wink:

because it works in 8.2 and it does not in 8.4, does it have something to do with the gtk2?

No issue at all on openSUSE TW.

Hello everyone.

I have the same problem with version 8.4, I can no longer use Ace FluidSynth, IR LV2, Invada…

I unfortunately deleted the installation file for version 8.2, does anyone have it?

Thank you for your feedback.


Possibly. Does the File import dialog work (Session > Import …) and allow you to select audio or MIDI files?

Along with EQ10Q and Calf those plugins are end of life and no longer supported. Please see Ardour 8.4 Calf plugins [ERROR]: failed to instantiate LV2 GUI - #4 by x42

(unrelated to the ACE Fluidsynth issue)

Getting strange and weird now:

  • create new session, Ardour 8.4, empty template
  • adding a single audio track
  • click on Session → Import
  • crash

BTW: Import PT does not crash, I can traverse the directories (but of course do not have a PT session)

Any other occurrences of file import I could check?

Famous last words:

start clocking
Setting time domain
start clocking
Segmentation fault (core dumped)
ardour-request-device: watched PID no longer exists - releasing device.

No errors in log (except for one missing manifest.ttl in a ~/.lv2 sub-directory

even more weird and strange

  • adding a midi track with the Fluida plugin
  • with the plugins browser I can select a sound fount file (plays fine)
  • save and close session
  • re-open session
  • Ardour crashes when trying to open the main window

What’s going on.?

Opening any old session done with 8.2 and simply clicking on the ACE Fluidsynth slot in the mixer channel (edit view) Ardour crashes

This is almost certainly the icon-file-on-your-system-causes crash

It’s probably not the same issue, especially if Paul has concluded that it is an icon error, but the Hydrogen drum machine had a similar crash-on-opening-file-browser and that was due to some translations being to long for the size of the buttons they were attached to.

If your system is set up for something other than English, try starting Ardour from the command line with
LANGUAGE="en_US" LANG="en_US" /path/to/your/Ardour
and see if it makes any difference

  1. Setting the language did not help
  2. temporarily renaming ~/.local/share/icons/hicolor did the trick

So now at least I know it’s in my local icons, not in the system icons. Will take some time to debug, folder contains 16 k icons

Thanks for your guidance so far.

If I’m able to identify the bad guy I will post it here. (or in the tracker? don’t have a tracker account - yet)

1 Like

Good to know.

Just do it in halves; start by removing half of the icons and see whether it works or not and then add or remove subsequent halves. Repeat until the guilty one appears.

1 Like

It would help significantly if you find the icon and upload it so we can reproduce the bug.

It is likely a „sound“ symbol (for wav files)

  • Brand new day
  • fresh reboot
  • physically remove my local icons (~/.local/share/icons)
  • create a fresh test session with 8.4 (even using language settings for US_en)
  • add a midi track with ACE fluidsynth
  • open the GUI of ACE plugin
  • click on file browser
  • BUMMM !!

Now I’m quite desperate :frowning:

  • Are the icons cached somewhere?
  • And why does it work in 8.2?

At least I can hack the state.ttl file with a path name for the SF2, setting up all the links for the sound font file manually like I saw in one of my projects and I can get sound

@prefix atom: <> .
@prefix lv2: <> .
@prefix pset: <> .
@prefix rdf: <> .
@prefix rdfs: <> .
@prefix state: <> .
@prefix xsd: <> .

	a pset:Preset ;
	lv2:appliesTo <urn:ardour:a-fluidsynth> ;
	state:state [
		<urn:ardour:a-fluidsynth:sf2file> <Fingered-1%20Bass.sf2>
	] .

This might help:
When browsing for a file there’s this icon of musical notes (16th) for wav and midi-files (in previous versions of Ardour visible). I guess this is the little devil that’s causing this.
Now this icon is in most styles like Adwaita and Breeze etc. But not in Oxygen (and maybe others). So when I change my icons to Oxygen all works fine.
I haven’t found the name of this icon yet, search continues.

Edit: there’s more icon-themes that are ok, like high contrast, gnome, elementary xfce, desert cameo.
When having the Ardour-import window pointing to a wav file, and at the same time changing the icon-settings of your system you can see the wav (or midi, or sfz) icon change. If you do this in 8.4, the moment you switch to fi Adwaita… booom!

This is the one
maybe audio-x-generic.svg or audio-x-generic-symbolic.svg ?

1 Like

Could you please send me a pointer to where I can read something about changing icon themes. I’m not familiar with this subject, always try to avoid tweaking my system. I use the latest Ubuntustudio LT without any major modifications.

Btw it crashes ~1 sec after i click on the browser

Found it in the settings, set to Breeze.
Oxygen is not loaded, I seem to have GNOME, ePapirs-*, Humanity
Will check them

Coming closer.

  • Setting icon theme to GNOME
  • new session
  • added midi track, ACE Fluidsynth
  • selected SF2
  • can play sound
  • close
  • re-open session
  • change SF
  • plays fine
  • close, open …

So far ok

Then I will use GNOME fonts from now on.

cross my fingers that this will be stable

Still: can anybody tell me why it works with 8.2

8.4 uses a version of GTK that is now part of our own source tree, and has been stripped of certain components. 8.2 uses an external “full” version of GTK.

We did this because GTK 2 has been “end-of-life’d” on many Linux distros, and we want users on those distros to still be able to build Ardour easily if they wish or need to.

Yes, I saw this in many postings and it oerfectly makes sense.
And I will never understand in my whole life what exactly has been stripped. And I assume everything that is required for Ardour has been transfered, so a missing component cannot be the cause for this issue.

That’s certainly what we believed. But apparently some themes on some Linux distros contain icon files that cannot be read with what is left behind after the “stripping”. Figuring out what those files are is the first step to fixing this, and neither myself nor @x42 have systems where this is a problem.

Some themes on some Linux distros, …ehmm…, Ubuntu Studio being one of them.
The latest install of Ubunto Studio hasn’t any icon-theme to divert to, so basically impossible to use Ardour 8.4 without trying to add some unaffected icon-themes.
Now I was not happy at all when Ubuntu Studio decided to drop xfce in favor of Plasma.
Maybe this Ardour-issue is a final push for me to leave Studio behind.

I guess you have Virtual Machines to test/investigate a system where this is a problem?

1 Like