Having problems with fades


i’m having problems setting fades (in, out, cross) with ardour 7. sorry if this is a dumb question, but i just cannot set the fades. i pull them out as usual at the beginning / end of regions, but then they spring right back. it’s weird and i’m sure that i’m missing something, but i can’t for the life of me figure out what the issue is, though i’ve been using ardour for years – have not experienced this before.

many thanks for any help.

My previous answer was incorrect, sorry.

Could you please file a bug report at tracker.ardour.org with full details (if possible, attach the session archive).

Audio? MIDI? snap settings? rough zoom setting? anything and everything.

I’ve tried it here just now with audio and it seems to work just fine.

thanks for your reply.

sorry, but what do you mean exactly by a “session archive?” i have never filed a bug before.

i just tried again on a different machine, but same outcome. i’m wondering if there’s something i don’t have set correctly in the preferences.

In the main menu bar, you will find: Session > Archive ...

got it. will file the bug…

I created a thread about that issue some days ago here:

I falled back to ardour6.9 for now. thanks for filing a bug.

has anyone else experience this?

i’m using a debian linux os, by the way.


Ardour 7.0.0, Manjaro KDE: I experienced this behaviour. Dragging the fade to increase it, sometimes it would jump back to be shorter than before.

But when testing with Ardour 7.0.105 everything was working as expected, so I didn’t see any reason for filing a bug. Will test again with a newer “nightly”

thanks for your reply. i will give a nightly build a try.

I have tested on an old project on my secondary PC (Debian 11 stable KDE + Ardour 7.0 official), and the fades work ok. The project was recorded in Ardour 6.9, FYI.
On my new PC (Manjaro KDE) I can’t test it because I’m in the middle of a project and until I finish it I will continue in Ardour 6.9

when you say the fades “work,” did this mean you tried to extend them, say, out to 30 seconds? it’s been reported on the bug tracker that fades longer than seven seconds were often not possible without the fade region springing back to its initial position.

Ah, no. I haven’t tried such long fades. I only tried a few seconds…
Now I don’t have access to my PCs. When I can (tonight or tomorrow) I try long fades.

yes, the problem is with fades longer than, say, seven seconds.

I have tested it again with longer fades and definitely the problem also exists in my case (Debian 11 + A7.0) :grimacing:

It seems that the developers have fixed it for the next release :+1:

it seems not, at least not thus far.

does anyone have an installer for v. 6.9 linux? i no longer have this on any of my computers. i haven’t been able to solve this problem with the fades springing back with any of the nightly builds. i have 6.9 installed on one of my travel computers (not the main computer i normally work with) and this issue doesn’t occur in 6.9. unfortunately, i don’t have the installer any longer.

thanks for any help.

i managed to find a 6.9 installer. thanks.

just installed 7.1 but am still experiencing this problem with fades springing back. are any other linux users having this problem?

i’m on debian 11, using an old T530 thinkpad.

many thanks for any help.

I also have that problem with fades. I run ardour7.1 but it is still the same here, too
I am on trisquel gnu/linux 10 (based on ubuntu)

I’ve had the same problem with both 7 and 7.1.
Arch linux/Ardour 7.0 and 7.1 binaries.