Can't load Ardour project file

I have a project that crashed, and after this I cannot open the project at all. It gives following error message:

Session “/home/babygrrrl/Music/ardour/141 (snapshot 141)” did not load successfully:
Cannot initialize session/engine: Audio/MIDI Engine is not running or sample-rate mismatches.

—ERROR: Unexpected exception during session setup: negative distance in timecnt constructor
ERROR: Patch without patch name list - patchfile will be ignored

What’s going on here? I had just one snapshot so without recovering this file the project will be totally lost… is there any workaround?

Running Ardour 8.1.0 on AVL-MXE-21 Linux.

Create a session archive (Session > Archive) and send it to me, I will take a look and will be able to fix the session file for you.

But it does not let me even open the session, is there any way to create archive without opening it? Via command line or anything…

ah, good point.

Just use tar or zip on the whole folder.

Here is zip:

OK, you should be able to fix this in a text editor. Open the .ardour file in the session folder, and search for tere bin pal - tab@70-62.5 then delete that line. Save the file, the session will now load.

It would useful if we could reconstruct what you did that led to this situation. It appears that you split a region into three parts … the middle part ended up with an illegal offset within the data file it references.

Also, I’m puzzled. On my 16 core Ryzen threadripper, this session completely overloads the system (DSP load is 100% or more). What type of computer are you running this on?

If you’re not comfortable with the text editing, let me know and I’ll get you the file itself.

Ok it worked! How did you tell that this was the line that caused the problem? I don’t recall exactly but yes I think I had split that region which caused the crash… Quite often when I perform such splitting or transposing tasks too quickly then it causes crash. If I can ask what do you mean by “illegal offset within the data file it references”?

What type of computer are you running this on?

Actually not using any special computer, I’m on my old Dell Inspiron 13-5378 with Intel Core i7-7500U and 8GB RAM, I got it secondhand many years ago… Often gives me issues with performance when I have projects with 30+ tracks.

Hm, after working on it for some time now same session is giving problems with similar message to earlier one:

Session “/home/babygrrrl/Music/ardour/141 (snapshot 141-3)” did not load successfully:
Cannot initialize session/engine: Invalid or corrupt session state.

—ERROR: Could not set session state from XML
ERROR: Session: failed to load active playlists
ERROR: Session: cannot create Playlist from XML description.

Never had this sort of message before. Here is link to tar archive: WeTransfer - Send Large Files & Share Photos Online - Up to 2GB Free

I modified the code to actually crash rather than report an error. Then I ran in the debugger, found the numbers associated with the crash (start of a region compared to the length of the data file), then I search in the session file for the region start number.

I deleted the line, after checking that the region ID value doesn’t show up anywhere else in the session file.

1 Like

Could I request help repeating this for current session state with above link? I’m having trouble running through debugger, in particular I get these messages…

$ sudo /opt/Ardour-8.1.0/bin/ardour-8.1.0 --gdb
/opt/Ardour-8.1.0/bin/ardour-8.1.0: error while loading shared libraries: cannot open shared object file: No such file or directory

I dont have great experience with debugging Ardour so might encounter some rookie problems, is it ok to one last time have help finding the line which I need to delete? Thanks so much!

Stop using sudo for that and let me know what happens. I tried loading the -3 snapshot, and it has exactly the same issue as the main snapshot. A region starts at 752640000 within a file that is only 752634120 long.

This one is slightly more problematic because it’s a region actually in use in a playlist. The edit requires removing an entire XML node. You can find the edited file here:

It would be wise for us to try to understand what your editing process is that can so easily (it appears) cause these errors to appear.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.