YAMAHA 01V96 version2 used to control Ardour.

Hello there. I’m new to this forum.

I have seen a couple of post related to the yamaha 01v96, but none have solved my problem. It seems that I can’t get it to work.

I use linux mint 18.1, and jack2. I have used it intensively with audio programs and it seems to work rather well.

I can see the yamaha’s usb-midi ports in jack’s connections window. I patched the mixer’s midi outs and ins to ardour’s midi control out and in ports accordingly. The yamaha’s remote layer is set to General DAW.

Simply put, it doesn’t work. When I ctrl+middle click any fader in ardour and move a fader on the 01v96, ardour’s fader jumps to minus infinity. When I move ardour’s fader, the 01v96 indicates it is receiving midi signals. But the fader doesn’t move. The same happens with any other button.

Does the 01v96 work with ardour at all? I had it working with Cubase a long time ago. Maybe it’s broken? It’s 17 years old now.

Thank you.

I have an 01v96. I will try to find time to check it.

Great, thanks. I’ve spent two days trying with no results. I’d love to be able to use my 01v96 and save having to buy another controller.

Check the MIDI mode you have the O1V in, you could be trying to use a non-standard mode on the O1V. IIRC it has custom modes for Cubase/Nuendo, Protools, etc. that you can switch between. Or it is possible I am getting it confused with another console, but will double check on my O1V96i if I get a moment (Which is not guaranteed any time this week honestly)


Thank you guys. There is no hurry. I just happened to get my dusty old 01v96 from the attic to entertain myself for a bit.

Yes, you can select between cubase, nuendo, protools, general daw, user defined and user assignable layer (this last one is of no use here I believe). When I select protools, ardour gives me an error and crashes completely and closes. I can’t remember what the error message says, something like midiui: out of memory or something like that. I don’t have the mixer here to re-check it though.


Don’t worry, there’s no hurry on my part. But it’d be nice to get it working someday…


You did try the General DAW setting there correct?

Granted Ardour shouldn’t crash on any of the other settings, but the General DAW is the one that is most likely to work in this case.


Yes, I have been trying with the general daw mainly, as I said in the first post. It does seem the most logical option here. But I did try with the others as well, nothing to lose, and it turns out that the protools IIRC option does something strange and causes ardour to crash. If I get the chance I will record a video of it happening and I’ll even post the error message. But. that won’t be too soon as I’m a wee bit busy in my life.


Ahh somehow I missed that line in the first post, sorry about that.


I have progressed somewhat, but the results so far are not fully satisfactory. The lack of time and not having the mixer near when time is available is frustrating.

I have tested with both the 01V96 and with a DM1000. It appears that I cannot get the general daw option to work, but I can get it to do something in the user defined. When using this last option, I can make the channel faders control ardour’s faders (or any other parameter). But it seems to lose them every now and then. Specially if I move the faders quickly, ardour loses track. Moving them slowly works. And this happens on both mixers. I’ll carry on investigating…

I have recently purchased a midi controller, a Novation launch control xl, and that seems to work fine. So I guess there must be a problem with the way the yamahas send their midi signals, and how ardour interprets them. IIRC, I used to have the 01V96 working perfectly with cubase a long time ago.


The slow/fast movement stuff has a parameter in Ardour to help control it. It’s the “Smoothing” factor in Edit > Preferences > Control Surfaces > Generic MIDI

Oh! I was wondering what that was for. What does that smoothing do exactly? I’ll try it out and see what happens when I have a bit of time.


Smoothing is basically a way to deal with the density of the messages a MIDI fader sends. Imagine moving the fader really fast. You might get 8 messages from 1 fader and 64 from another, even though you move them both the same distance and across the same range of MIDI controller values. The first fader might send a message for every 8 steps of value, the second might send a message for every value change.

Smoothing controls how different the incoming MIDI controller value has to be to be considered equivalent or different to Ardour’s notion of the current parameter value. But really, the best thing is to just mess with the values - it’s easier to “feel” than it is to explain.

Well yes. I just set it to one and it worked. The faders went up and down in ardour as they should. Now I’ll just have to find the time to figure out how the user defined layer on the yamaha works.

I guess my problem is solved. Many thanks!!