ALSA can't find Yamaha O1V96 v2

Hey y’all,

Long time sandbagger since at least 2015 when I used Ardour to record from my moto 8 pre sometime in 2012 on a laptop and later in 2015 on a desktop.

I’m back because I’ve found myself needing additional inputs. I happen to own and have been using this Yamaha board for a few years now to do live mixing and sound at a local art collective for free for a few years to give back to my community, and keep an accessible venue going.

The Yamaha O1V 96 v2 is supposed to have 8 in/out (@24b/48k) via the USB 2.0 port. I’ve got it plugged into a USB 2.0 port on my PC. I’ve gone into the remote tab on the DIO/SETUP screen and changed the target to General DAW, on the midi/host setup page under “special functions” I have the DAW setup to USB 1-2 and the ‘Remote’ confirms that I have General DAW selected.

With it plugged in I am unable to see it in the ALSA selection / recording setup screen. (the screenshot was unable to see the dropdown menu, but I can assure you it’s not listed in the selections available for me to choose. I see 8pre, 2x intel HDA and 4x nvidia HDA inputs, no USB/Yamaha.

    ~  aplay -l                                                         ✔ 
**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC1150 Analog [ALC1150 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 1: ALC1150 Digital [ALC1150 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 3: HDMI 0 [LG IPS FULLHD]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 9: HDMI 3 [HDMI 3]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 3: D8pre [8pre], device 0: FW-MOTU [8pre]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

The ALC1150 I’m pretty sure is my onboard soundcard, the Nvdia is the RTX 3060 Ti and the moto 8pre is listed, but not the Yamaha. Strangely, I’m able to see it in the ALSA information script.

I also tried following this link which was the closest I could find to my problem YAMAHA 01V96 version2 used to control Ardour. - #8 by eddie3000 - but changing it to ‘User Defined’ did not result in it being listed in the ‘aplay -l’ command, even after restarting JACK.

Is there something special I have to do / am missing to get it to connect?

Thanks: additional helpful information below

inxi -F                                                          ✔ 
  Host: karen-main-game Kernel: 6.6.7-1-rt18-MANJARO arch: x86_64 bits: 64
    Desktop: GNOME v: 45.2 Distro: Manjaro Linux
  Type: Desktop Mobo: ASRock model: X99 Taichi serial: <superuser required>
    UEFI: American Megatrends v: P1.80 date: 04/06/2018
  Info: 6-core model: Intel Core i7-6850K bits: 64 type: MT MCP cache:
    L2: 1.5 MiB
  Speed (MHz): avg: 2861 min/max: 1200/4000 cores: 1: 1298 2: 1363 3: 4000
    4: 4000 5: 4000 6: 1200 7: 4000 8: 2904 9: 2371 10: 4000 11: 4000 12: 1197
  Device-1: NVIDIA GA104 [GeForce RTX 3060 Ti Lite Hash Rate] driver: nvidia
    v: 545.29.06
  Display: x11 server: v: with: Xwayland v: 23.2.3 driver:
    X: loaded: nvidia gpu: nvidia resolution: 1920x1080~60Hz
  API: EGL v: 1.5 drivers: kms_swrast,nvidia,swrast
    platforms: gbm,x11,surfaceless,device
  API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: nvidia mesa v: 545.29.06
    renderer: NVIDIA GeForce RTX 3060 Ti/PCIe/SSE2
  API: Vulkan v: 1.3.274 drivers: nvidia,llvmpipe surfaces: xcb,xlib
  Device-1: Intel C610/X99 series HD Audio driver: snd_hda_intel
  Device-2: NVIDIA GA104 High Definition Audio driver: snd_hda_intel
  Device-3: Yamaha 01V96 driver: snd-usb-audio type: USB
  API: ALSA v: k6.6.7-1-rt18-MANJARO status: kernel-api
  Server-1: PulseAudio v: 16.1 status: active
  Device-1: Intel Ethernet I218-V driver: e1000e
  IF: enp0s25 state: up speed: 1000 Mbps duplex: full mac: 
  Device-2: Intel I211 Gigabit Network driver: igb
  IF: enp7s0 state: down mac: 
  Device-3: Intel Wireless 3160 driver: iwlwifi
  IF: wlp8s0 state: down mac: 
  IF-ID-1: docker0 state: down mac: 
  Device-1: Intel Bluetooth wireless interface driver: btusb type: USB
  Report: rfkill ID: hci0 rfk-id: 1 state: down bt-service: enabled,running
    rfk-block: hardware: no software: yes
  Local Storage: total: 13.64 TiB used: 6.3 TiB (46.2%)
  ID-1: /dev/nvme0n1 vendor: Crucial model: CT1000P1SSD8 size: 931.51 GiB
  ID-2: /dev/sda vendor: Seagate model: ST10000DM005-3AW101 size: 9.1 TiB
  ID-3: /dev/sdb vendor: Micron model: CT4000X8SSD9 size: 3.64 TiB type: USB
  ID-1: / size: 915.53 GiB used: 629.51 GiB (68.8%) fs: ext4
    dev: /dev/nvme0n1p2
  ID-2: /boot/efi size: 299.4 MiB used: 288 KiB (0.1%) fs: vfat
    dev: /dev/nvme0n1p1
  Alert: No swap data was found.
  System Temperatures: cpu: 24.0 C mobo: 28.0 C
  Fan Speeds (rpm): fan-1: 2376 fan-2: 881 fan-3: 1586 fan-4: 0 fan-5: 0
    fan-6: 0
  Processes: 433 Uptime: 12h 27m Memory: total: 32 GiB available: 31.27 GiB
  used: 5.99 GiB (19.2%) Shell: Zsh inxi: 3.3.31
!!ALSA Version

Driver version:     k6.6.7-1-rt18-MANJARO
Library version:    1.2.10
Utilities version:  1.2.10

!!Loaded ALSA modules

snd_hda_intel (card 0)
snd_hda_intel (card 1)
snd_usb_audio (card 2)
snd_firewire_motu (card 3)

!!Sound Servers on this system

      Installed - Yes (/usr/bin/pipewire)
      Running - Yes

      Installed - Yes (/usr/bin/pulseaudio)
      Running - Yes

      Installed - Yes (/usr/bin/jackd)
      Running - No

      Installed - Yes (/usr/bin/jackdbus)
      Running - Yes

!!Soundcards recognised by ALSA

 0 [PCH            ]: HDA-Intel - HDA Intel PCH
                      HDA Intel PCH at 0xfb730000 irq 67
 1 [NVidia         ]: HDA-Intel - HDA NVidia
                      HDA NVidia at 0xfb080000 irq 68
 2 [D01V96         ]: USB-Audio - 01V96
                      Yamaha 01V96 at usb-0000:00:14.0-14, full speed
 3 [D8pre          ]: FW-MOTU - 8pre
                      MOTU 8pre (version:103800), GUID 0001f200000a54e6 at fw1.0, S400

!!PCI Soundcards installed in the system

00:1b.0 Audio device [0403]: Intel Corporation C610/X99 series chipset HD Audio Controller [8086:8d20] (rev 05)
	Subsystem: ASRock Incorporation C610/X99 series chipset HD Audio Controller [1849:1151]
05:00.1 Audio device [0403]: NVIDIA Corporation GA104 High Definition Audio Controller [10de:228b] (rev a1)
	Subsystem: Dell GA104 High Definition Audio Controller [1028:c976]
!!USB Descriptors

Bus 003 Device 004: ID 0499:5008 Yamaha Corp. 01V96
Device Descriptor:
  bLength                18
  bDescriptorType         1
  bcdUSB               1.10
  bDeviceClass            0 [unknown]
  bDeviceSubClass         0 [unknown]
  bDeviceProtocol         0 
  bMaxPacketSize0         8
  idVendor           0x0499 Yamaha Corp.
  idProduct          0x5008 01V96
  bcdDevice            1.01
  iManufacturer           1 YAMAHA Corporation
  iProduct                2 YAMAHA 01V96
  iSerial                 0 
  bNumConfigurations      1
  Configuration Descriptor:
    bLength                 9
    bDescriptorType         2
    wTotalLength       0x009f
    bNumInterfaces          1
    bConfigurationValue     1
    iConfiguration          0 
    bmAttributes         0x40
      (Missing must-be-set bit!)
      Self Powered
    MaxPower                0mA
    Interface Descriptor:
      bLength                 9
      bDescriptorType         4
      bInterfaceNumber        0
      bAlternateSetting       0
      bNumEndpoints           2
      bInterfaceClass       255 Vendor Specific Class
      bInterfaceSubClass      0 [unknown]
      bInterfaceProtocol    255 
      iInterface              0 
      ** UNRECOGNIZED:  07 24 01 00 01 8d 00
      ** UNRECOGNIZED:  06 24 02 02 01 00
      ** UNRECOGNIZED:  06 24 02 02 02 00
      ** UNRECOGNIZED:  06 24 02 02 03 00
      ** UNRECOGNIZED:  06 24 02 02 04 00
      ** UNRECOGNIZED:  06 24 02 02 05 00
      ** UNRECOGNIZED:  06 24 02 02 06 00
      ** UNRECOGNIZED:  06 24 02 02 07 00
      ** UNRECOGNIZED:  06 24 02 02 08 00
      ** UNRECOGNIZED:  09 24 03 02 01 01 01 01 00
      ** UNRECOGNIZED:  09 24 03 02 02 01 01 01 00
      ** UNRECOGNIZED:  09 24 03 02 03 01 01 01 00
      ** UNRECOGNIZED:  09 24 03 02 04 01 01 01 00
      ** UNRECOGNIZED:  09 24 03 02 05 01 01 01 00
      ** UNRECOGNIZED:  09 24 03 02 06 01 01 01 00
      ** UNRECOGNIZED:  09 24 03 02 07 01 01 01 00
      ** UNRECOGNIZED:  09 24 03 02 08 01 01 01 00
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x01  EP 1 OUT
        bmAttributes            2
          Transfer Type            Bulk
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0040  1x 64 bytes
        bInterval               1
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x81  EP 1 IN
        bmAttributes            2
          Transfer Type            Bulk
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0040  1x 64 bytes
        bInterval               1

The 01v96 does not have a class complaint USB audio interface. You need a dedicated device driver for it. One does exist for Linux, but I have never tried it (I do own the mixer).

okay, thank you.

I will try and find the USB audio interface driver for linux. and post a link here for future reference and other users if I find it.

Last time I looked, it was not maintained. There’s a good chance it is not usable.

Does it make more sense to just install WINE or a windows VM and put up with high latency for a DIY recording of our punk / noise album that is slightly better than a ZOOM 2hn in the middle of the room? or would I need to install windows and use it until the free trial period runs out?

Thanks again so much for your support! This is incredible for libre software!

Wine will not work (it cannot use Windows drivers, and is 100% dependent on ALSA).

A Windows VM will require the custom 01v962 driver from Yamaha (for Windows).

I gave up the idea of using the mixer as an audio interface a long time ago if you want to be on Linux, and I’d personally recommend that you do the same. Of course, you might find some other pathway …

ALAS, I gave up on windows in 2003, I’m unable to afford the $1000+ for other equipment at this juncture in my life, and doubt that’s in the cards for many years. Thanks again for your technical support.

How many channels do you need? You can get a quality USB interface for $100 or less these days (much less, sometimes, on ebay or equivalent)

GitHub - kryops/01v96-remote: WebSocket-MIDI bridge for Yamaha 01v96 is this the unmaintained drivers you were referencing?

I have 8 channels, i’d ideally like 22, but can make due with 15

I’m mic’ing 2x drum kits (both 6 mics - 4 for the kit and 2 condensors for the breakables) - then there’s 2x bass OR 1x bass and 1x Guitar, and then usually 1x vocals - the group chants from backup vocals can be caputred with a ZOOM H8 and added in post production with a lot of microphone bleed

Nope, that’s for MIDI only.

Actually, I revise my recollection. The only thing I found was a user-space audio streamer based on libusb. Limited to 16 channels and not usable on its own as part of a DAW ecosystem.

The 01v96 is essentially unusable for audio I/O under Linux. Other companies have made the same mistake - I also have an SSL Nucleus control surface that has a USB audio interface that is not class compliant. It is not even usable on macOS anymore because they refused/were unable to update their custom driver.

1 Like

So quick correction here that makes the entire thread moot I believe…

The O1V96 v2 only does MIDI and Control over USB, not audio. Even in the manual if you look closely, their diagrams show audio through ADAT or otherwise from the IO slot through a separate audio interface locked via Wordclock to the O1V.

The O1V96i is the version that made a USB audio interface, and as @paul mentioned there, it required a separate driver along with all the caveats of that.

1 Like

If you want to use a digital mixer with Linux, a viable alternative could be the Behringer X32. You may find them used for a very reasonable price. Besides, Behringer has started to support Linux better and better. Hopefully it will pull other manufacturers in the same direction.

Even lower cost is the Behringer XR-18 or MR-18 (the MR version has better preamps).

These work great under Linux, including the X-Air mixer control application which has a native Linux version.



1 Like

Is Ardour limited to 10 total channels? I’m realizing now that I’ve only seen 8 in and 2 outs, when I should possibly see 16 ins and 12 outs… I’ve borrowed a friends berhinger… might start a new thread

Nope. Ardour has no channel limit. I/O channels have no limit (only depends on the kernel driver).

What Behringer model interface are you borrowing?

On my Behringer XR18, I see all 18 channels.



Berhinger ADA8000 for the extra inputs, but it’s not working either. its only showing me the 8ins (xlr/trs analog ins only) and 2 outs (mains and headphones). I can get them to sync and add inputs to the Yamaha mixer, but that doesn’t help live multi track the band since the Yamaha mixer can’t out to my PC without buying a $500+ card for an obsolete mixer and a $800+ pci-e card for my desktop. it’d be way easier to get like the other person said a used $1000-1500 presonus 16-32 or xr/mxr air 16-32 berhinger recording mixer/stage box. but I don’t have any budget for any equipment for the foreseeable future.

I’m just guessing it’s just going to need a windows 8/10 box and the proprietary drivers and software to work on a lan/air gapped device to record, and then I’ll transfer the files to another machine to mix and master the recordings.

I don’t have ADAT on my computer so I’m just outta luck until I can make some money or someone gives me / lends me the correct equipment to interface or record my queer punk & metal project. we’ve been joking about recording the album with the zoom h8 in the middle of the room like we do our rehearsals and just printing that on CDs/tapes and for download… haha

for now I’m going to record 8 tracks with the motu 8pre to ardour, 6 tracks to a handheld h8 zoom and another 2 tracks to my sony fx30 audio interface, and then sync/mix/master it all in post afterwards.

it’ll give me 96,000 24 bit for all but 2 tracks (the sony’s fx30 audio interface only goes to 48000 pretty sure) and I can bounce the kicks, toms, snares from both drum kits onto shared busses because they’ll use the same dynamics and eq anyway, on my old analog behringer eurorack mixer, and I can pan them for added effect.

due to the limitations on aux outs on my mixers to send to my recording equipment I’m struggling to wrap my head around how I’ll patch everything and get the dynamics and eq I like from my board and rack units that I have all saved, but I’m sure I’ll manage it in post with fairlight (resolve studio tab), audacity and ardour. they all have a pretty good library available to them for the limited gate, compression, eq and limited reverb I’ll need.


This may be of use:




UMC1820/ADA8000 doesn’t work in combo - Cockos Incorporated Forums 1

UMC1820/ADA8000 doesn’t work in combo REAPER for Linux

this was an incredible find. nice. ya, the problem is the motu 8pre is a firewire/ffado device that uses proprietary garbage language to speak to a proprietary garbage OS, and they refused to help work with or develop tools to work with Linux.

after reading the manual very carefully it just isn’t going to work unless I add ADAT to my PC and an interface card to my mixer, which as noted above is not supported and not likely going to work.

I think I have a work around for now, and eventually I’ll get what makes it easier or what I need… maybe? or just make due with what I got. honestly ive got a lot of gear that will work, albeit with a lot of extra work, but it’ll do a pretty okay, even above average recording.

1 Like