Verify drag & drop files into LSP plugin GUI

gtk based DE

Okay this will be post attempt three to figure this out.
I am still trying to find out if Ardour has the ability to be able to support D&D of files into plugin GUIs in Linux (that support this feature)
I believe I tested this in the past in Windows and it could be done from 3rd party file managers but not from within Ardours import dialog.

It has been mentioned that LSP plugins support this capability, so would anyone be able to verify if it is possible in Linux, to D&D an impulse response file into the “LSP Impulse Responses Mono” or D&D any samples / IRs into any LSP plugins for that matter.
The plugin GUI says “Click or drag to load” so should work.
Tried two different 3rd party gtk based file managers and I have not been able to achieve this myself.

Thank You

1 Like

My last post about this was this one

Thank you very much Robin for your response, the thread was closed before I had a chance to thank you.
I ended up running a bunch of tests and I typed out a long post about my findings a while back but I figured instead of posting a ton of information, I would get even more specific narrowing things down to just LSP plugins, which as mentioned are known to have this capability.

Just tried from Thunar to LSP Impulse Response Mono under i3 DE / debian (testing), works fine.

Thank you for trying this out for me, also for mentioning some general system information.

This continues to get stranger, this does not work for me on a Debian based distro using XFCE (gtk) and one of the file managers I tried this with is Thunar as well. The only difference is XFCE, but this is a very common DE so can’t imagine this would be causing an issue?

Does anyone know what I could be doing wrong? I have seen some DAWs have embedding settings, does Ardour maybe contain something like this?

I mentioned in my post above that I tried a ton of things, one of them was trying the program Carla. With this program I was NOT able to D&D files into LSP plugins from 3rd party file manager either, but WAS able to D&D files from its internal browser in LSP GUI and it worked.

Still interested if anyone else could give this a try and share results, especially if using XFCE, just to see if that is a factor, but I doubt it.

Thank you for any advice offered

I tested it on Xfce and it works as well. Maybe there is something interfering with drag and drop globally (an obscure option in the window manager’s config ?) or maybe you’re using an old version of LSP (its changelog mentions regressions regarding d&d fixed in v1.1.28).

I had had some LSP GUI issues when I updated the LSP plugins. I did not remove the old .so files. I think there are three, that are used for all the plugins. Lsp was using the old .so files, and that caused several strange GUI issues

If you had manually updated the plug-ins, maybe they are using an older .so ? Try removing all LSP plug-ins along with the include .so files and reinstall to ensure you are using the latest versions of .so and plug-ins.

Thank you guys for your responses.

The version I am using is 1.2.10 which is a rather new versions. The current newest version available I believe is 1.2.13.
I checked the version history document in the 1.2.13 and it does not mention any recent changes made regarding D&D capabilities.

I looked through window manger settings / tweaks and didn’t see anything.

Does anyone have any other ideas of what it could be?

I mentioned that I had done a lot of testing regarding this in the past. One of those test was using Carla to verify any D&D issues as well.

I also not able to D&D anything in effect GUI (that support it) such as…
LSP Impulse Responses Mono
LSP Samplers
when opened in Carla using a 3rd party FM such as Thunar. However when using Carlas internal sidebar browser, all of the above plugins do allow D&D. Not sure why that would be?

While on this subject it was mentioned that being able to D&D in a gtk based program, into itself was not something that could be done / or maybe not done so easily. How is it that Carla, a FOSS program has the ability to D&D audio files into plugin GUIs (that support it)? I thought Carla was gtk based, but not sure at the moment.

Carla could not D&D certain non based audio files into GUI, because similar to Ardour, in the import window there are limitations to being able to access certain non audio based files such as virtual instrument formats / non supported formats in general. Carla grays some formats out as well, so you cannot D&D them.

Thank You

Is this your first/initial install of LSP plug ins on this machine, or did you reinstall over older versions ? Or were older versions also installed with your distro’s package manager ?

Thank you for your response,
I saw you mention this the first time, I thought I only had one version installed and then I got taken off course when I saw that some of this worked with Carla. I will have to back track and see if for some reason I had older versions of LSP?
Thank you

Open to others suggestions as well just in case this is not the solutions.
Thank You

Also, I wanted to try to D&D files other than audio files, many times I have tried to find a compiled version available for Sfizz, does anyone know if there is one available from a reliable source? Not available in my repo.
Although this plugin unfortunately does not contain everything I am looking for, I am still interested in trying it in Linux, I have only tested it a while back in Windows.
Thank You

Okay this Linux based drag & drop mystery continues.
I thought the coding in Ardour would have been the same for all plugin format types that support this capability, which is why I did not mention the plugin format.
I have noticed something recently while testing.
LSP was a perfect example to test because it comes in both VST2 & LV2 formats.

-I was trying this out using the VST2 version, which do NOT work (for me at least) in Ardour, when using a 3rd party file manager to D&D files into the plugin GUIs.
-I recently tried the LV2 version and they DO work when using D&D from 3rd party FM.
-Neither plugin formats work when trying to D&D from Ardours import window (which again is unfortunate) Have mentioned in the past that it feels rather inefficient for example if using a drum sampler such as LSP one (if you don’t want to use plugins small strange file pickers) you have to test samples out using Ardours import window which is pretty good (I have some suggestions I plan on posting for it in the future), provides audio preview but then you would have to leave Ardour, open up a 3rd party window FM, find the sample, then D&D back into Ardour plugin GUI window.
The coding of this was said to be too complex to offer in Ardour, which seems strange with tests that I will mention below. (I know you can probably use a 3rd party audio preview of some kind to eliminate some steps above, but still strange to have to leave Ardour, when it already has this)

Anyways, can anyone confirm that this above is true? Does Ardour not support D&D for VST plugins? only for LV2 ones? Again I will mention some more about this below.
I believe I tested this with bundle version 1.2.13 for each format.

In order to have something to test / compare results I tried to use application called Carla by KXStudio. Some strange results here.
-This application does NOT appear to allow any D&D from 3rd FMs
-However I have mentioned this before, this program DOES allow D&D internally from its own side bar browser. Not sure if it is just the type of program that it is, because it can connect different items together that maybe it does not experience the same GTK / GDK complexity that was described to me why Ardour cannot achieve this, but just odd that a FOSS program such as Carla would offer this, if the coding is that complex to achieve?
-Another thing noticed is that in this program, D&D DOES work for both the VST2 & LV2 plugin formats. So why would Ardour only be able to achieve this with LV2 and not VST2?

So as anyone who actual reads this can see, it is strange and almost opposite results between these two Linux based applications that I have chose to test this out with.
I apologize if I am doing something incorrectly to generate these results?

I know it might not sound useful to most, but being able to D&D in a computer program is not exactly, completely a crazy request. I don’t code, but it seems strange that in Linux this would be so difficult to achieve, if that is the reason why this is not added.

If anyone has any information about this please share.
Thank You to anyone who takes the time to read this and respond

Would either of you be able to share which format type of LSP plugins you were able to get to work? Were you both using the LV2 versions?
As mentioned above, the LV2 versions are the only format I was able to get to work, the VST versions do not work for me.

Does anyone have any success ever getting a VST plugin (that has the ability built in to do this) to accept a D&D of a file from a 3rd party FM into Ardours plugin effect window?

Thank You

I just gave it a try with LSP Multisampler x 12. I was able to drag into LV2, but it would freeze and crash.

I was unable to drag into VST2 version of the same.

However LSP Sampler Stereo worked with LV2, but I do not have the VST2 on the system to test it. Version 1.2.11

I just tested with LSP Impulse Response Stereo (1.2.14):

  • LV2: everything works
  • Linux VST: dragging doesn’t work, click to browse works

LSP Plugins
Oh wow, thank you guys so much for continuing to test these out I really appreciate it.
D&D has just been something that has really been confusing me in Linux / Ardour, couldn’t seem to find the consistency. Before getting your responses, I recently discovered something else that unfortunately adds to the confusion, but very helpful to know that you guys were basically able to generate the same results that I have with the LSP plugins.
Okay so as of now…

D&D from 3rd party file managers into Ardour plugin GUI window
LSP - LV2 - works
LSP - Linux VST - does not work

Thanks again for confirming this for me

rncbc Plugins
I thought I had found the consistency in Ardour but a different test adds to the confusion.
It was mentioned to me that the “rncbc” plugins such as “samplv1” and “drumkv1” both support D&D from 3rd party FMs. I tested the LV2 formats of these two plugins in Adour and the D&D does NOT work from 3rd party FM. So this might disprove that Ardour supports LV2 D&D for all plugins.
Tricky because I thought I remembered someone mentioning that these “rncbc” plugins are not compatible with Ardour, but this might have been old information?
Not sure if anyone will be able to confirm if “rncbc” plugins have any issues when used in Ardour?

I was just wondering if you would be able to confirm if this is true.
Does Ardour only support D&D from 3rd party file managers into Ardour plugin GUI windows for LV2 and not for Linux VST?
LV2 = yes?
Linux VST2 = no?
Linux VST3 = no?

If this is true, then why wouldn’t Linux VST D&D also be available in Ardour to be consistent with LV2 plugins. You mentioned the complex coding was only with being able to D&D from Ardour import window into effect GUI window in Ardour, but that D&D from 3rd party file managers was possible because then it was GTK to GTK based window.

Thank You

I’m having wierd drag and drop issues as well. Sitala, Samplv1, LSP do not work but speedrum lite does. This is dragging from ardour’s clip browwer to the plugin.

Could this be a permissions issue? I have speedrum in a .vst folder in my home directory…

At first when I saw you mention that you were able to D&D from Ardours clip browser I thought you might have been mistaken, but turns out what you were not. What you mentioned lead me to some interesting results which I will share more about this is a separate reply below this one.

Before I do, first I think I can answer your your question.
If the LSP plugins you are using are the VST versions then this aligns with my test results.

-Sitala 1.x - this plugin is a VST2 so does not work (the newer pay version 2.x comes in VST3)
-Samplv1 - is LV2 but maybe has a compatiblity issue with Ardour? (if someone confirms my observation above) Did not work for me either.
-LSP plugins, the LV2 should work if you have newer versions, but if VST2 then they do now work
-Speedrum - This plugin comes in VST2 & VST3, and I would say you are using the VST3 version.

This is why you were able to D&D, and not just from a 3rd party file manager (which works), (this discovery surprised me), but with VST3 plugins, it appears that Ardour supports D&D from within, using the Clip Browser sidebar as you mentioned & also Ardours Import window!

Hopefully this answers your question
Thank you for this as well

Okay, as mentioned above this seems to be true, regarding D&D from 3rd party file managers.
-LV2 supports D&D, the only LV2 plugins that have not are the “rncbc” ones “samplv1” & “drumkv1” which may be a compatiblity issue?
-VST2 have not seen any support D&D at all
-VST3 supports D&D not only from 3rd party file managers, but also allows D&D from within Ardour!
Which why was this not known / mentioned?

-Sfizz confirmed some of this because comes in LV2 & VST3 versions and both support D&D from 3rd party file manager.
-Decent Sampler comes in VST2 & VST3 versions, the VST2 version does not support D&D, but the VST3 version does. Cannot confirm the VST3 D&D from within Ardour because non audio file types are not supported in Ardour.

Still interested in hearing answers to my questions above if anyone is willing to answer them.
Also if anyone knows of any other plugins that support D&D into GUI, let me know and maybe I could test them.

Hopefully all of this will be helpful to other users

Yep, draging from Ardour (edit or clip browser) to plugins like samplv1 or lsp-multisamplers, does not work. Draging from outside (filemanager like Dolphin…) to Ardour or plugins, works well. Both plugins are lv2.

Another great piece if information.
Would not think this would matter, but the “rncbc” plugins “samplv1” & “drumkv1” are made using QT. If you D&D using a GTK based FM it does not work, but I tried two different QT based FMs, one being Dolphin and D&D works with both of them!

Not sure exactly what to do with all this information.
Good / helpful to know, but only really matters if Ardour developers are interested, which I don’t think they are. Obviously some of this would depend on the limitations of what Linux can and cannot support.

(Just thought about it)
I have not tried the reverse yet, of trying to D&D audio files from a QT based FM into other plugins that I have mentioned I tested above.

Thank You very much for this information, this was helpful.

I am still interested in answers to questions I mentioned, if anyone has any info / answers about this.
Thank You