Unable to enable Ableton Push 2 in linux

Attemping to follow the online manual:
when I Click on the “Enable” button nothing happens in the gui.
I have tried kde neon, a fresh install of ubuntu studio, installing version 6
with backports ppa, installing the 6.0 demo version.
installing /etc/udev/rules.d/push2.rules from this thread:

I installed the 6.0 demo version on my mac and there the enabling worked just fine.
I also once tried running ardour5 in a disposed ubuntu studio installation as root and there the enabling worked also.

I will appreciate any input and advice.
Beat wishes

The original file is https://github.com/Ardour/ardour/blob/master/tools/udev/50-ableton-push2.rules

Can you test if the Push2 matches the given USB-ID? In a terminal window run


And look if there’s an entry 2982:1967 for the Push2. Also see if you’re in the audio group, by checking:


PS. Ardour’s canonical manual is https://manual.ardour.org/ (in Ardour: Menu > Help > Reference).

Maybe try to rename the file to /etc/udev/rules.d/99-ableton-push2.rules or re-download

sudo curl -o /etc/udev/rules.d/99-ableton-push2.rules https://raw.githubusercontent.com/Ardour/ardour/master/tools/udev/50-ableton-push2.rules
1 Like

I just deleted my old udev rules file and did the:

sudo curl -o /etc/udev/rules.d/99-ableton-push2.rules https://raw.githubusercontent.com/Ardour/ardour/master/tools/udev/50-ableton-push2.rules 
  • rebooted
    (content was the same just different name)
    And the enable thing works.
    On a side note it seemed a bit flaky in ardour5 so I updated to v6.0 ppa version and finally got it to work correctly with alsa (not jack2) audio drivers.
1 Like

Yes the usb id was fine, just the udev rule file name needed fixing,see other post

Last Update
No problem with the filename the culprit was as copy paste error from this thread
I did’nt see.
all the "(quotation marks) where ” instead of "… :slight_smile:

I see. That is a side-effect from the forum migration. The old post came from drupal, and that CMS did not allow to use preformatted text in replies.

Anyway. I’m glad you figured this out and it works now.

Well yes thank you very much due to your helping hand,
I wonder if I should put some effort into getting that udev rule fix into the Ardour manual ?

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.