push2 not working on linux but working on win10

hi everybody,

i try to get ableton push2 working on linux - debian testing:

  1. connecting push2 over usb port seems to work device is recognized by the system:
    new high-speed USB device number 8 using xhci_hcd usb 1-1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
    Feb 2 21:19:49 dellesky2 kernel: [ 836.257667] usb 1-1: Product: Ableton Push 2
    Feb 2 21:19:49 dellesky2 kernel: [ 836.257670] usb 1-1: Manufacturer: Ableton AG
  2. start jack and ardour 5.5 works
  3. following http://manual.ardour.org/using-control-surfaces/Ableton_Push2/ i enable push2 in preferences but when i doubleclick the enabled line the “Control Protocol Options” is not shown and the push device is never initialized.

could somebody please give me a hint for linux. i tried the same with ardour on win10 (same hardware setup) and it works. please write if you need more information from me.

all the best and many thanks to the ardour dev community,

It seems to be the case that if you enable the use of the Push2, and then quit Ardour and restart it, it will be working after the restart. So that’s one thing to check. I don’t know why this behaviour shows up (if I did I would fix it immediately).

thank you paul, but unfortunately it is the same after enabling push2 and restarting ardour (i restarted several times). the device is not initialized. do you or anybody else have any suggestions to try. do i perhaps need a firmware or a special kernel module? all the best peter

You have to be in root mode.
In the cmd window, type:
sudo su
open the Preferences dialog, and then click on “Control Surfaces”. Click on the “Enable” button in the line that says “Ableton Push 2” in order to activate Ardour’s Push 2 support. The button below to configure the Push2 will be activate now! Regards

Please don’t ever suggest to run any user-space application as root. Set the permission to allow your user to access the Push2

Easiest way to do so is by adding a file /etc/udev/rules.d/push2.rules with the following

SUBSYSTEM==“usb”, ATTR{idVendor}==“2982”, ATTR{idProduct}==“1967”, MODE=“0666”, GROUP=“audio”