Ubuntu Studio 17.10 Problem


(No Such Error) #1

I can’t run Ardour5 in Ubuntu Studio 17.10. I get this error:
ardour-5.11.0 assert failure:***Error in `/usr/lib/ardour5/ardour-5.11.0’:free():invalid pointer:0x00007ffc98788b62 **
I’m running Cadence for Jack configuration. It was fine in 16.04 on this machine.
Anyone else got problems with this?


(Robin Gareus) #2

Perhaps try move the config-dir ~/.config/mixbus4 out of the way, and test again. Launching Mixbus from the commandline may also print some relevant information, but for Mixbus, best contact Harrison support.


(Len) #3

mixbus 4.3.19 starts and loads sessions fine on ubuntustudio 18.04 here. (Ardour 5.12 is fine too as well as Ardour 6.0 alpha… don’t use) Using the onboard Intel graphics here. (graphics cards being the most common cause of not working on only one system)


(Robin Gareus) #4

The upstream fix for this issue was on Dec 15, 2017 (removal of delete[] ctlchn;)
https://github.com/csound/csound/commit/7bad3e3801e219860d91b1845f42c87812fc1d89#diff-8839482122d7aa14591d57f3e35f47cc
csound 6.10.0 or newer should be fine.

Then again, if Ardour works, but Mixbus fails, it may be a different issue, unrelated to csladspa. It is impossible to say without further information


(scadaperspective@gmail.com) #5

Hi All,

Thanks X-42 this info.

Ubuntu Studio 18.04 “vanilla” causes the same problem.

Ardour 5.12 works fine.

Muxbus 4.3.19 fails on startup.

So any clues folks on what version of the LADSPA package doesn’t cause the crash ?

All the best

Ron


(Len) #6

You should file that bug with ubuntu on Launchpad. In a terminal type:
ubuntu-bug ardour

And then follow the instructions. A browser will open (firefox?) and lead you through.


(Mikeklapak) #7

I’ve had the same problems. It’s frustrating since 17.10 is probably the best release Canonical has had in years. It’s consistent across all machines and only occurs with Ardour itself. JACK and other audio programs work just fine. Ardour5 gets the invalid pointer error.
I’m a subscriber and I use the official .run installer, not the package from the repos. It’s consistent on every machine I’ve used running 17.10. Seems to be some sort of compatibility issue specific to 17.10.

I ended up switching to Antergos because I couldn’t find a workable solution.


(Robin Gareus) #8

Hard to say why this happens, a backtrace is needed to (see https://ardour.org/debugging_ardour) to know for sure.

As shot in the dark, I’d suspect a plugin pack which comes with Ubuntu, probably some LADSPA (which is loaded when scanned). You could try to uninstall some plugin-packs or simply /blacklist/ all LADSPAs:sudo chmod 0 /usr/lib/ladspa/ then launch Ardour to quick-check (re-enable with sudo chmod 755 /usr/lib/ladspa/.


(Rinaldimj) #9

I’ve installed Ardour right from the Ubuntu repositories and works perfectly.


(Robin Gareus) #10

The OP also uses Ardour from Ubuntu (/usr/lib/ardour5/ardour-5.11.0/… indicates that), I’m pretty certain that its a plugin installed on the specific machine, but without backtrace there’s no way to tell for sure.


(No Such Error) #11

x42 seems to be correct, running
sudo chmod 755 /usr/lib/ladspa/
then Ardour works. Thanks.
Unfortunately I don’t have time to look into creating a backtrace I did file a bug report with Ubuntu.
I’m running Ubuntu Studio 17.10 and the latest KXStudio plugins so it’s one of their plugins maybe.


(Paul Davis) #12

x42 seems to be correct … words to live by.


(Nachordez) #13

Nice clue, x42!
I was suffering the same, and it got solved uninstalling csladspa (which is not from kxstudio) package. Now, ardour/Mixbus open without problems.


(Marcel Lendi) #14

Thank you Nachordez,

I suffered the same problem. Sudo chmod 0 /usr/lib/ladspa/ solves the problem, but I loose some of the plugins I am using. So thank you for a more precise solution. I deleted the csladspa.so, cs_chorus.so and cs_phaser.so from the Ladspa folder and Ardour runs just fine.


(Brukmanster) #15

I have the same problem but this error *** Error in `/opt/ardour/bin/ardour-5.11.4’: free(): invalid pointer: 0x0000000001c88b9c ***.


(Robin Gareus) #16

I’ve reported the issue upstream and it has meanwhile been fixed in csound (git)


(Ardour) #17

Thanks to everyone who posted here, because your comments really helped me out. My Ardour5 was unable to connect to Jack after upgrading to Ubuntu Studio 17.10 - and these are the clues that helped me to solve it.

In my case uninstalling cadence put things back in working order. The relationships between ALSA and Pulseaudio and Jack have always been cloudy to me, but at least now I have a slightly improved grasp how the audio architecture is arranged.


(scadaperspective@gmail.com) #18

Hi Robin,

Thanks for the advice, it saved the Harrison folks a tech support request :slight_smile:

The LV2 stuff you do is pretty neat as well btw so thanks for being so helpful… I posted a reference on the Harrison forum to help if someone else ever has the same issue… Hopefully nobody does… If a bug is going to happen it will happen to me :slight_smile:

All I know is Len, with the vanilla install of MIxbus onto UBUNTU Studio 18.04 LTS, something is causing the executable to fail when it is scanning that directory. The problem is verbatim the same error as reported for 16.04. I used the terminal session output to find this thread. :slight_smile:

Note: by Vanilla I do mean a fresh install that has absolutely no updates to the OS applied. It wouldn’t be the first time that commits went missing in Ubuntu :slight_smile:

So by issuing the command line sudo chmod 0 /usr/lib/ladspa/ I got both version’s of mixbus to work. Now that config files (I presume) are created both apps are happy. No issues with upgrading to vers 5.

I haven’t tried deleting the config files but I re-enabled the directory with the command line sudo chmod 755 /usr/lib/ladspa/ after the initial bootup was successful with both versions and the apps are working happily. I will leave that to someone else to test as I would rather work on compiling some plugins.

I have loaded up a few different plugins after compiling them to try with no issues…


(Dmshch) #19

Thank you Nachordez!
Same problem in Ubuntu 18.04 was solved by removing csladspa package. I was agonize in two days before I find this topic.