Track menu option

What is the “custom” option in the track menu for? Why can’t we specify the number of tracks desired?

Someone just asked the same question

It would also be interesting to be able to define the number of inputs / outputs at once.

Also asked in that other thread :stuck_out_tongue:

can be, but that does not give the solution to create, in one go, for example 24 tracks

Do you mean 24 channels on a single track, instead of 24 mono tracks?
Why would you want to do that, and how do you want to pan those channels?

1 Like

I have an 18-channel studio (18 speakers) and I use a 64-channel spatializer that I developed with the Faust language.
http://blanchemain.info/Documents/Programmation/index.php?page=space3D64
Jean-Marc Duchenne, a colleague, has a 64-channel studio and we need tracks that can offer 18, 24, 32 64 channels on a single track for the assembly x traks of y channels of our creations : http://sonsdanslair.free.fr/l.acousmonef.htm

Yes, and I can add that for correct ambisonics productions which are now rather common, you need at least 5th order / 36 channels.
Even a 22.2 will need 24 channels tracks :wink:
It is not a new concern since I have found a post requesting the same kind of thing (30 channels track) dating from… 2010.

My bad, I didn’t associate 24 channels with ambisonics.

For Ambisonics preferably use a 4 channel track to record B format, that also goes a long with the various amb-tools plugins to pan or rotate the signal.

For the decoder(s) I suggest to add a 4 channel bus with “Flexible IO”. Loading the decoder plugin will then automatically add the required outputs to the bus. This way adding the outputs does not need to be done manually.

This workflow also allows to simultaneously target multiple formats, incl. perhaps a UHJ stereo folddown in addition to the multichannel ambisonic output.


That being said, If you really want a quick way to create a track with arbitrary I/O.
Ardour-Menu > Window > Scripting, copy/paste&edit the following and press “run”:

Session:new_audio_track (n_in, n_out, nil, how_many, "Name",  ARDOUR.PresentationInfo.max_order, ARDOUR.TrackMode.Normal)

e.g. to create two tracks with 4 input, 51 output each:

Session:new_audio_track (4, 51, nil, 2, "MyTrack", ARDOUR.PresentationInfo.max_order, ARDOUR.TrackMode.Normal)

PS. it is possible to have scripted track templates.

1 Like

Thank you for you answer… and for the scripting !
That will be very useful.

But as for ambisonics… well, even Facebook supports 3rd order’s 16 channels :wink:
Since microphone are yet mostly 1st order, some plugins like Harpex or the free Compass can get some interesting spatial upscaling, and for productions where processings are involved it is far better to use 5th or 7th order.

But that is not the question here : Ardour has a wonderful engine that allows to mix in high spatial audio formats, but can then render it to 24 max ?
Of course, I can record the mix in realtime on a track and then retrieve to indexed mono files that are in the session folder, then convert them to multichannel, so it is not impossible to work.
But if Paul or another of the talented developers could extend the Master beyond the 24 limit, it will certainly be much appreciated by a few people I guess…

There’s no limit of channels for the master bus.

PS. In your case however (for ambisonics, or for an arcousmonium mentioned earlier), I’d probably use a session without dedicated master. Then use multiple target busses (as many “masters” as you need): A stereo master a 3rd order master, a 5th order master… etc.

Ah, silly me, another “Add Audio Port” option !
Question : why don’t allow to set directly the number when we can choose the Master’s channels ?

But it seems nevertheless to be a problem : if I add some new audio ports, say up to 32, and then I open the menu “Session / Export in an audio file” Ardour crashes instantly.
I have tried both on Windows and MacOS (sorry, no Linux…), with or without a track being routed to the Master, it crashes everytime.
If I don’t add another Audio Port to the Master, there is no crash.

Little precision : the crash append when I add one Audio Port more than 24 if 24 was selected at start, or from 21 if I have started with a lower value and have added the ports one by one.

With your modified script for a bus:
Session: new_audio_route (32, 32, nil, 1, “Name”, ARDOUR.PresentationInfo.Flag.AudioBus, ARDOUR.TrackMode.Normal)
I have created a 32/32 bus, but if I want to export the created bus, I only have the same number of channels as the master, which in this case was 20/20. Problem!!!

It’s the same for a single track

Session > Export > Stem export. In the “channels” tab, select the bus.

Also pick a file format that can support 32 channels for the given duration. Probably, w64 or caf.

I used this menu and this export window well but when I select my bus I only have a number less than 32 channels for export

You can test. This is not a criticism, it is just the acknowledgment of a malfunction.

I have tested it and exported a 64 channel w64 file, also others regularly use Stem Export for this.

Default session export is known to have issues if you have a master bus > 20 channels.

We agree, there is a problem with normal export.