Time Signature and Tempo Change messed up

I don’t know if this problem is tackled in the 7.2 version, I believe I read about some Time-stuff not handled well in Ardour7 at the moment and changes coming (hope so :wink:

But anyway: I struggle with tempo changes after some divergent bars (3/8 in this case).
See picture.
After 3/8 bars a tempo change will not snap to the beginning of a later bar.

And what comes next, I don’t know, but a lot of bars have disappeared completely. Moving the tempomarker around leads ultimately to a crash. This happens in a sort of clean 7.1.0 session.
I don’t know if anyone has a workaround at the moment (looked into BBT markers and glueing or not). I can’t find any.

After some testing with an empty clean session; Ardour 7.1.0 can’t handle a combination of time signature-changes and tempo change.
And if dragged enough with the tempomarker a crash: Aborted (core dumped). Reproducable.
So for this session, back to 6.

I noticed bugtracker issue ID 0009107 deals with the same problem. I hope 7.2 will bring the fix.

1 Like

Fairly sure this particular issue is fixed. It would be helpful if you try a nightly build from nightly.ardour.org

Ok, I will try the nightly build.

I’ve tested the nightly build 7.1.174.
Altough it seems more stable, dragging the tempo change and trying out different time measures (no crash) the problem is still there: strange things happen in the BBT-bar when using odd time measures other than quarter (fi 5/4 does well).
When inserting 3/8, 7/16, etc the grid is messed up, maybe not initially but certainly if you move the tempochange marker. See picture, 7/16 may sound musically a bit extreme but it gives an insight in what’s happening.

I know that this is under development, so is it helpful to place another bug-report on this? Basically the picture tells all there is to it.

this is all mostly fixed in my local build, and should show up in nightly (and 7.2) shortly-ish.


Yes indeed. 7.2.0 Problem solved. Makes me very happy, thanks a lot :smiley:

Hmmmm. When importing old files to Ardour 6 tempo and bar changes are placed wrong. In 7.2 they’re completely gone? Not quite an improvement. Any suggestions?

Sorry for making Progressive rock :wink:

Hi, I don’t quite understand what you mean.
Is it that you converted your older Ardour-files to Ardour 7.2 and that tempo and bar changes got lost in the conversion-proces?

THX for your quick reply. I’ve opened a project made with an older Ardour version with A6. Result:Start tempo 73,000/4 and bar 4/4 are correct. The bar changes throughout the song are correct, but the corresponding tempo changes has moved. For example: Bar change in bar 59 (ok), but corrseponding tempo changed moved to bar 60. Later in the song are four 1/4 bars. Bar changes ok, but corresponding tempo changes moved to bars 91-95.
The same project opened with Ardour 7.2.: Start tempo is now wrong 120,000/4. All other tempo and bar changes throughout the whole song are completely gone.

Ok, now that’s beyond my scope of knowledge, I’m only a user not a developer.

Problem looks like:
Conversion from older(?) Ardour to A6: wrong positions of tempo- and time-signature changes
Conversion from older(?) Ardour to A7.2: tempo and time-signatures gone, even start tempo
Have you opened the older file with Ardour6 and corrected the positions of bar and tempo changes, then save as Ardour6 file. And then open that file with 7.2?
For me, conversion from 6 to 7.2 went well but I haven’t tried conversion from older versions (I doubt if I have them).

I don’t know what happens at the conversion from older then 6 versions to 7.2, maybe a bug-report is the way to go?

I am sorry I cannot be of much help, but I recently also imported an old song (made probably with Ardour 5.X) and had no problems. It does have many time signature changes (also a into prog!), but no tempo changes on this one:

So, perhaps it is the tempo changes causing the problem?

(BTW, have you posted your music? As a huge prog fan, I would definitely check it out.)

Thanks for your idea: Opened in 6 and corrected, saved and then opened in 7.2 is a possible workaround.

@finotti : No problem at all: You can find The J Conspiracy on any streaming monster (Spotify, Apple, Deezer, Amazon…) or check out our website www.thejconspiracy.net
Every song recorded on Ardour (Ubuntu Studio) :smiley:

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.