Some LXVST plugins not working in Ardour 6.5.0

Hi,

I just installed the new AVLinux Linux Distribution released just some days ago. This distro comes with Ardour 6.5.0 and a bunch of plugins preinstalled.
I just tried to do a scan of all the plugins (Window > Preferences > Show > Plugin > Plugin Scan) and I find out that many of the preinstalled plugins seems to not work in my system.

More specifically, during the plugin scan - whenever Ardour is trying to reach a not working plugin - I receive the error showed in the following picture:

The error seems to be a Wine error telling that the lin-vst-servertrack32.exe has stopped working and has to be close. That program seems to be related to the execution of the LXVST plugin through wine, but I have no idea what is the exact problem and how to solve it… Could you help me somehow?

If you are running plugins through wine, you are trying to run windows plugins, which is an entirely different topic than LXVST (Linux VST) plugins.

    Seablade
1 Like

Hi and thanks for the answer.

To be honest: I really don’t know.

The plugins which are not working are preinstalled in AVLinux and I really don’t know what kind of plugins they really are… According to the error message, they seem to be run with wine indeed. but it is strange, as I noticed that when Ardour tries to retrieve the plugin during plugin scanning, the type of the plugin prompted is LXVST, as you can see in the screenshot I posted…
This is kind of strange according to your differentiation between wine run plugins and LXVST plugins I think…

The error is from https://github.com/osxmidi/LinVst

That offers a way to make windows VST (.dll) work on Linux and make them appear as LinuxVST. It’s not something we recommend.

I guess you can simply ignore this error. The plugin will be blacklisted.

It is not unusual that some plugins don’t work, but it’s odd that AVLinux packages some that don’t. @GMaq can you shed any light on this?

1 Like

Thank you very much for the answer!

I just listed the ones that seems to don’t work, I can share the list if it can be helpful

@deperito

Please read the instructions in the User Manual bottom of Page 56…

On first plugin scan of Ardour it will scan for all VST Plugins (including a small set of preinstalled WindowsVST plugins that are there), the Windows VST Plugins will appears as LinuxVST (or LXVST) because they are set up with LinVST which is included by default because on Linux many Users like to have the ability to use Windows plugins along with the excellent Linux choices.

It is recommended to run the “Configure Wine-Staging” from the Wine Tab of the AV Linux Assistant to run Wine Staging for the first time to create it’s configuration files, Wine will ask to install some helper applications like Wine gecko and wine mono but you do not need to install them you can just cancel those installations

Then relaunch Ardour and run the Plugin scan again…

Hi and thanks for the answer!

Actually I already run through wine first time configuration, in fact it seems to start automatically at the first use of wine (it’s enough to launch something similar to wine notepad from the terminal) and it indeed asked me to install wine gecko and other helper applications… I answered yes.

Unfortunately, the issue I’m reporting is showing also after that wine configuration stage…

However, I didn’t run the “Configure Wine-Staging” from the Wine Tab of the AV Linux Assistant, do you suggest me to do it in order to solve?

Strange. I’ve been using the new distro myself (even installed a few windows plugins to test how the latest wine-staging/linvst handles things). No such errors on my end so far and I’m familiar with that error too as I’ve gotten it in other distros on rare occasions. As per @x42’s comment, I’ve simply ignored them and carried on regardless.

OK,

Have you run the plugin scan a second time after the first time failed? If Wine-Staging ran the first time and you installed the gecko and mono packages that will not hurt anything and you should not need to run ‘Configure Wine-Staging’ now, Wine-Staging will have run for the first time already. Try running a new session of Ardour and running the plugin scan again… from the Ardour Menu ‘Edit’–>‘Preferences’–>‘Plugins’–>Scan for Plugins

To my knowledge and testing with the exception of the Harrison-ava demos and their constraints with OpenGL all of the native Linux Plugins are working in AVL-MXE… Even LinVST ones shouldn’t be an issue with a second scan in Ardour after Wine-staging has had a first run but we’ll see what the OP comes back with…

Also clear the blacklist first in Preferences > Plugins > VST, and check Menu > Window > Log

There can also be some system specifics in play. e.g. some plugins require a modern CPU with SSE4 or AVX and hence may not run on older systems. Others need a graphics-card with OpenGL 3.3 etc.

I don’t know if this can explain the issue at hand though, but it might.

Hi again,

so, I just tried to rerun the plugin scan again after a reboot and if I delete the VST 2 Cache and the VST 2 Blacklist, the same error still appears.
If I don’t delete the VST 2 Cache and the VST 2 Blacklist (actually I think only the VST 2 Blacklist is important) I got no errors, but - of course - as I also read in this topic, this must be because Ardour just blacklists the plugins which are not working and doesn’t try to run them again…

I also retried the scan reading the message log window (I opened it through Window > log as @x42 suggested) and the only messages which seems to have some interest are the following:

2020-11-29T22:44:48 [WARNING]: LADSPA: impossibile caricare il modulo 
"/usr/lib/ladspa/ladspa_guitarix.so" (/usr/lib/ladspa/ladspa_guitarix.so: undefined symbol: 
_ZN4Glib10Dispatcher7connectEON4sigc4slotIvNS1_3nilES3_S3_S3_S3_S3_S3_EE)
2020-11-29T22:44:51 [WARNING]: Unsupported required LV2 feature: 'http://lv2plug.in/ns/ext/buf- 
size#fixedBlockLength' in 'Vex'.
2020-11-29T22:46:56 [WARNING]: Ignoring duplicate Linux VST plugin NC-17
Ignoring duplicate Linux VST plugin Monique
Cannot get VST information for '/usr/lib/vst/b_reverb.lv2.so': failed to load cache file.

I have also noted the name of the plugins that are not working, I’ll share the list with you below just in case it can help:

- MjUCjr (LXVST)
- DC1A2 (LXVST)
- IVGI2 (LXVST)
- LoudMax (LXVST)
- ClassicPhaser (LXVST)
- ClassicMasterLimiter (LXVST)
- ClassicEQ (LXVST)
- ClassicAuto-Filter (LXVST)
- ClassicDelay (LXVST)
- ClassicFlanger (LXVST)
- ClassicCompressor (LXVST)
- ClassicChorus (LXVST)
- ANWIDA Soft DX Reverb Light (LXVST)
- SHB-1 (LXVST)
- Emissary (LXVST)
- ESP_FreeeQ (LXVST)
- ESP_UniQ (LXVST)
- TSE_808_2.0 (LXVST)
- TSE_BOD_v2.0 (LXVST)
- sfz (LXVST)
- HyBrit (LXVST)
- LeXtac (LXVST)
- LeGion (LXVST)
- Le456 (LXVST)
- AnalogDelay (LXVST)
- Ambience (LXVST)

Out of curiosity (and I because I had some time on my hands), I booted up the live ISO of AVL-MXE and went through the steps of configuring Wine-staging via the AVL-MXE Assistant and then running a manual plugin scan within Ardour 6.5. I now get the exact same linvst error messages. Why I didn’t get them previously, who knows?

But…this is clearly not an Ardour 6.5 issue (this, I think, we already knew). The same happens on Reaper 6.17 (Linux) too. It must be those particular plugins because I can install other plugins via linvst and they scan/load just fine directly on this live iso.

1 Like

That plugin is not available as Linux VST, so it’s bridged (windows VST -> lin-vst/wine). Likely others in the list also fall in this category.

It may or may not be possible to use those windows-VSTs on Linux, but as @bachstudies mentioned, there’s nothing on Ardour’s side of things to solve this.

If you want/need those plugins, you’ll have to investigate wine and

or better yet, ask the vendor to provide a native Linux version of the plugin(s). Alternatively Ardour also runs on Windows, where there’s official support for those.

Step back and think about what “using Windows VSTs” really means: taking bits of software written with only one idea in mind—running on the Windows platform—and then trying to use them on an entirely different platform. It is a bit of a miracle (thanks largely to the incredible work done by the Wine project) that it works at all. But is this the basis of a stable, reliable DAW for a non-Windows platform? Getting Ardour on Linux to pretend that its really a Windows application running on Windows?
(from https://manual.ardour.org/working-with-plugins/windows-vst-support/)

A LV2 plugin in the VST folder?! That won’t work, but you can also safely ignore it.

@deperito, for what it’s worth, I use the Loudmax LADSPA version with no issues.

All of those listed plugins are WinVST. Hmmm, OK…

It is possible that LinVST must be run again after installation to although I have never seen that be necessary before I am using a new Live system and Installer so perhaps this is an unforeseen quirk, before we get too carried away… Page 54 of the User Manual will explain how to rerun LinVST to create fresh ‘.so’ files with linvst.so on your install…

So order of operations:

Create fresh linvst.so files as described in the User Manual…
Open Ardour and delete the blacklist again
Rerun the Plugin Scan and let me know what happens…

2 Likes

The B_reverb thing is not my doing, that is KXStudio stuff so is the Guitarix LADSPA stuff… I’m guessing that B_reverb being there something to do with running lv2 as vst with your bridge??

Not as far as I can tell, unless it’s a symlink to custom version lv2vst.so.

Yet only lv2vst.so should be in the LXVST_PATH, and that in turn picks up plugins in $LV2_PATH.

Furthermore the .lv2 won’t work without the *.ttl meta-data, and lastly others plugins would also have the same issue; b_reverb would not be singled out.

I’m just guessing… it’s not my packaging so I’m not sure, I better report it on the KX Repos github…