[SOLVED] How do I load a sample into LSP sampler?


(roithamer) #1

Does LSP sampler(s) work for you with Ardour? First of all I don’t know how to load a sample - when I click on this big black/dark gray field it spawns some tiny black empty nonamed window and that’s it. When I try to click some more it just crash Ardour :confused:

arch 4.18.16
ardour 5.12-7
lsp-plugins 1.14-2


#2

You have to click the “Click to Load” area with left mouse key. Then a file browser should open.

Do all LSP Samplers crash (Mono,Stereo, LV2, VST)?


(roithamer) #3

Yes this is what I did. When I click it, instead of a browser just a tiny black empty window pops up. What’s weird I don’t even have this “click to load” - just empty area.
Yes all LSP samplers crash. Arch package provides only lv2 no vst.


(Robin Gareus) #4

To narrow down the issue please double-check if official binaries from http://lsp-plug.in/ also have this issue and contact the Arch packager otherwise. Since the plugins work on other systems, this may be distro or system or configuration specific.

A backtrace (see https://ardour.org/debugging_ardour ) may also be useful for the lsp-author @SadKo .


#5

You can try running Ardour in gd … (Robin was faster ;))

If problems still occur with the official version you could also ask here:
https://linuxmusicians.com/viewtopic.php?f=24&t=19028


(roithamer) #6

Ok thank you guys.
So I uninstalled Arch package and put official lv2 from http://lsp-plug.in/ into $HOME/.lv2 dir. Basically it’s still the same - no “click to load” and no browser. But now it doesn’t crash Ardour.


(Rghvdberg) #7

Are you perhaps using openbox as window manager?
Another user had problems with lsp + openbox


(roithamer) #8

Thank you Rghvdberg, with your suggestion i was able to pin the issue down.
I tried different WMs and LSP worked fine in every one of them (including openbox).
And then I realized that in my default Xfce, Ardour launcher was modified to:
env LANG=en ardour5
That was causing the problem. With simple ‘ardour5’ command LSP behave as it should.


(Robin Gareus) #9

Wow. Nice find!

Note that LANG=en is not a valid locale. Perhaps try LANG=en_US.UTF-8 and also make sure that the locale is generated in /etc/locale.gen or try LANG=C (default, C, C++ locale). You can also try to disable Preferences > General > Translation

We have actually seen some locale issues with certain plugins in the past, mostly concerning plugin-state: Some locales use comma as decimal separator e.g. “1,5” instead of “1.5”. Plugins need to save/restore state independent of the locale, some don’t.


(roithamer) #10

Yes! Thank you Robin! env LANG=en_US.UTF-8 ardour5 works perfectly. No translation and LSP plugins are happy too.
For some reason disabling Preferences > General > Translation doesn’t work for me. That was the reason I’ve put this LANG=en there, probably mindlessly copy/paste it from somewhere. It just worked so I was like the hell with it :wink: