Slackware 12, problems runing ardour...jack?

Hello, I’ve sucessfully installed JACK+Ardour and all it’s dependencies, but whenever I try to run ardour, first that for running I need to run it as root(permissions…but no problem here), then, I always get this message when I try to start a test track:

the capture device "hw:0,0" is already in use. Please stop the application using it and run JACK again

Since I’m pretty new with jack, could you guys help me out?
I’m running jack like this:

jackd -R -n peacemaker -v -d alsa

And I run KDE as a Window Manager, maybe KDE is blocking things? I really don’t know even how to check this…Sound in Linux is a whole new world for me.

Thanks a lot guys.

Hi Zarnick,

I don’t use slackware but I am used to KDE. You probably have artsd (the KDE sound daemon) running in the background. Just disable it through the KDE system settings (System settings -> Sound System -> uncheck “enable sound system”) and restart jack after that. It should be all you need, unless your issue comes from e.g. a flash application running through an opened webpage, which you should close if this is the case because the flash plugin will busy your sound device without sharing it. So, as a rule of thumb, if disabling Arts does not work, try to spot every audio application that could run in the background (amarok, xmms, whatever) and terminate them.

By the way, once I set up my KDE environment as I wanted, I switched to openbox-KDE. It is more lightweighted and will preserve your KDE setup (panels, icons, menus). To the untrained eye, it will look as if you are running the full KDE. But you really don’t need that when running jack stuff, you want to prioritize the audio flow.

Thanks, it solved :smiley:
this is a very good piece of software, all I need is to find some VST plugins, specially an Equalizer.
Thanks a lot thorgal!

you’re welcome :slight_smile:
you could try this EQ :
it’s freeware :wink:

I actually found a lot of LADSPA plugins right here, on the ardour manual, but I’ll take a look at this, thanks a lot. :smiley:

BTW: Just one completely out of topic question, I have a guitar+some efects+a Digitech RP2000 and a 15W Peavey, what would be the best way to record the sound from my guitar? Mic the Peavey, (I have only “normal” computer mics, no professional mics) or plugin the output of the RP2000 to the input of my SbLive sound board? It’s really of the topic, but if you could give me your personal opinion…I would like to hear it.


What I would do in your situation is to avoid mic’ing the amp because of a lack of a “proper” mic (and preamp that goes with it). Your effect rack contains some amp modeling and certainly has some level of preamplification you can use to control the gain of your output before it goes inside your sound-card. There are advantages in outputing your effect box to your soundcard : you can play in silent mode and at the same time simulate the amp of your choice (among choices the digitech offers you). This is to me the best compromise considering what you’ve got. If you want to capture your amp output through a mic, you would have to upgrade a few things, and that’s unfortunately not for free. By the way, I don’t know the quality of the SBLive sound card (the ADCs, the builtin preamps, and so on). I have a RME HDSP system (Multiface II) and a RME QuadMic preamp for mics (4 channel preamp module) and I must say, to my ears, the incoming sound is quite nice (no buzzing crap, transparent). But I had to save up money for quite a while to afford this system. My experience with cheaper sound cards is not very good. The ADCs and the preamps sit inside the computer so they pick up quite some crap. You always have to clean up your recordings for this, which is really annoying. But at the end, YMMV :slight_smile:

I’d recommend going direct as well, you may have to fiddle with the levels a bit, also from my experience you might find that you get some mains hum if the unit has a cheap external power supply. Alternatively if the amplifier has a headphone output you might try that - though the level might be too high for your card. Unfortunately it appears that the RP2000 doesn’t have a USB output which some more recent ones do, which could be another option if it had.

That said experimenting with the microphone might yield some interesting, if not particularly purist, results :slight_smile:


hum and buzz from the guitar is mostly pretty terrible, in comparison to other signal sources, so what the Soundblaster adds to it is likely irrelevant.

Electric guitars just “don’t do” dynamic range. Not compared to other things like a violin or a singer.

A cheap-and-cheerful “comes with the soundcard” microphone in front of the peavey will likely not cope with the sound pressure offered, and distort horribly.

Hello, I’ve went with direct and made a very simple one take test, which you can find it in here. The point was to actually test a clean guitar with a fabric preset of the Digitech RP2000, both in a note by note, and on chords, if you listen to it correctly, you’ll see that when I start doing the chords, the sound starts to crack up, and that’s my problem. I never tryed with distortion, since it wass 2 am when I’ve did this. (alas, please don’t look at the errors on the guitar, I was really tired, and it was just a test)
I did tryed some EQ tough, it didn’t helpd, the output volume of the Digitech I have to put on max, otherwise the SBLive would pick it up really low volume, do you guys have any tips?

(BTW, you were all correct, mic is a hell hehehe)

Thanks a lot guys.

if i was listening carefully enough, the sound is crackling even on a single notes, about 9. and 10. sec.?


Probably, but it cracks like hell on chords.

For realtime permissions on Slackware you can use set_rlimits:

Is this a realtime issue?

Don’t know for sure that it is - is jack reporting any xruns? The slight artifacts I could hear in the sample sounded more like dropped frames than clipping to me, but maybe somebody with a better ear for that kind of thing can give their opinion.

for me it does not sound like a clipping but more like some drop-out.
i would try to increase the latency, than the craclings should disappear at some point.


Hum…and how do I increase the latency? As I sayd before, when it comes to sound, I’m a complete newbye on linux…hehe
(Actually, I used to use Windows just for this…hehe)

if you are using qjackctl for controlling jackd, it is pretty easy:

go to the setup dialog and try to increase ‘frames/period’
or/and ‘periods/buffer’ variables.


No qjackctl…it uses qt4, and I still depend a lot on qt3 :frowning:

No qjackctl…it uses qt4, and I still depend a lot on qt3 :frowning:

You can download the qjackctl-0.2.x series here:

which should build fine with qt3. I’m still using 0.2.22 myself with no problems, and it really makes everything jack-related much easier.