Regions Transparency in 7.2

Hi!

I’ve just updated to 7.2 (dl on ardour.org). The transparency of audio regions disappeared. I tried to set it up back, but I can’t find the right cursor (preferences → colors → transparency):
dragging regions obviously changes the transparency when dragging, it doe’s work.
Any of covered region base, editable region or region alpha doe’s change anything, in grab or edit mode.

When I have overlaid regions for crossfade or punched-in records, I like to have an idea where does the lower region starts/stops and how is the waveform. When I drag the region it becomes more transparent and I can set it very accurately (this is working).

thanks for posting this, I was confused when noticing a different picture from what I customized to my needs in a challenging and timeconsuming exercise
best
-s

@Blindekinder:

This change was made to better reflect the difference between audibly-opaque and audibly-transparent regions. Allowing opaque regions to ‘look’ transparent can be confusing.

The (visible) region transparency was originally devised as a way to allow the grid to be seen(*). In the last few weeks, Robin found an innovative way to render the regions so the grid remains visible (as if it were overlaid on the regions) with minimal cpu cost. So it’s no longer so necessary to allow the region transparency preference.

This has been the default operation on Mixbus for several years (opaque regions are fully opaque). So there is some precedent that it is workable once you get used to it.

That said, if enough people request it, we could re-introduce the preference and default it ‘fully opaque’ for Mixbus while leaving some transparency for Ardour.

In the interim, I suggest that you consider these ideas:

  1. as you’ve noticed, the regions go transparent while you are dragging them. In many cases this accomplishes the desire for “an idea where the lower region starts/stops”

  2. since 7.0, there’s now a keyboard shortcut to quickly switch between layered and stacked region modes, so you can quickly see a fuller picture of your region stacking, and then switch back.

(*) Regarding the grid, Mixbus’s approach was to leave a small gap between each track where the grid lines could be seen. But I like the new 7.2 way much better, and it’s also much better for MIDI regions. So now Ardour and Mixbus will behave exactly the same, by default.

-Ben at Harrison

1 Like

thanks for your answer, which leaves me somewhat disappointed, because for me it felt more as a bug, so I switched back to 7.1 today hoping for a fix in 7.3.
It’s not only the disappeared Gridlines behind the waveforms which for me is definitely a step back, but also my waveforms which were pretty dark now they look more grey and I can’t get them back to dark anymore, which means a worsened visibility for me.
Reinstalling at least part of the previous status (why not completely?) would be really great
thanks
suse

I cannot see regions at all on 7.2 (also downloaded from ardour.org). I’m running Manjaro.

I will downgrade to 7.1 to see if the problem disappears. Or, um, stops disappearing.

I have been using 6.9 for older projects but converted one to 7.2 and then opened a new empty project and imported audio into it. Both 7.2 projects show me nothing but grid in all of the regions, whether audio or midi. Starting the playhead produces the sounds that I am expecting to be there; I just cannot see them!

Posting in this thread because it seems related. I can start a new one if need be.

At least I think it should be a possible option. Opaque (visually) by default in layered mode is probably ok, but one should be able to change it.

about your propositions:

  1. I already use it, I like to have my regions very transparent when moved, and more opaque otherwise.
  2. I’ll try that in my next project. Maybe the editing is more readable when fully opaque.

For the grid I don’t know, I use it very few since I mainly work in sound creation, sound pieces and contemporary music, where regular rhythm is usually not relevant.

It doesn’t change nothing visually when I switch in the dropdown menu (under punch in/out). Is it an issue?

The “record mode” menu only affects what kind of region(s) will be recorded, it doesn’t have any effect on the regions that are already on the timeline.

I guessed it was something like that… thank you.

Have you used an early nightly builds, and have customized the color theme? if so either delete the custom color theme from the config file or add the following line near the end:

   <Modifier name="region alpha" modifier="= alpha:0.75"/> 

If that is not present, alpha is assumed to be zero, and all regions will be 100% transparent.

A minor version update invalidates the color scheme, but if you have used nightlies that may cause this issue.

Hm, I can’t seem to find any setting that makes the regions completely opaque. Where in the preferences is that option available? I’ve tried to lower the “covered region base” setting to zero, but nothing seems to happen. I would love to have completely opaque regions which turn a bit transparent when moved. Any help much appreciated.

Preferences > Appearance > Colors > Transparency
Set “Region Alpha” opacity to 100%

1 Like

This feature seems to be slowing down the performance in editor page.

Just echoing @Blindekinder on this. I really miss having slightly transparent regions. Fine-tuning crossfades is impossible without being able to see the lower region. And no, I don’t want to continually switch between layered and stacked modes, or have to move the top region to see where the lower one ends.

FYI, I “fixed” this by reverting these commits in my local build.

  • bb3c7f685d1755122c31e9381b48513b6955e04c
  • 50ea360571194cce04093c0e62d67b0e2afe5436
  • 49d36407ac0f3851fb60b60d3a65fb4fe126ac19

Note that “opaque region base” is still listed in the Preferences > Appearance > Colors > Transparency options even though it has no effect.

That’s still very much possible in 7.2, adjusting the “dragging region” fader under Preferences > Appearences > Colors > Transparency does the trick, at least it did for me.

does that also fix the scrolling and zooming performance?

I haven’t noticed any performance issues either with or without these commits.

interesting, if you have a session with like 16 or 30 tracks, and then set the view to all tracks then try zooming in and out of all the tracks and it should be slow. but maybe considering you may be using linux you don’t have this issue.