Recording with Ardour on windows 10

Hello, I´ve recorded my guitar with ardour on windows 10, but the files are not present into “mysessionfolder/interchange/mysessionname/audiofiles/”. I have into my session folder only imported files but not my recorded tracks. I have only a file named “recorder” with 0kb. Any suggestion where my recorded files could be saved into my PC? I´ve tried with many sessions and it is the same, the recorded files are not visible into my folder session. Thanks in advance, I need found the recorded files to move to another computer.

Please see Moving session from windows 10 to Ubuntu 20.04 - Ardour 6.6 - #2 by x42 (and the surrounding thread)

thanks Paul, the problem is not only the “recorder:” prefix, it was fixed using search and replace in ,ardour file, the problem is that .wav files recorded are not present in the session folder.

If you can, please attach/include:

  • a listing of the contents of the interchange/SESSION/audio folder
  • the <Sources> XML node from the session file
  • the session path specification at the top of the session file

thank you Paul. At this Google Drive Link I´ve uploaded my root folder where I save my ardour sessions.
If you open the session you can find two imported files, but the guitar track recorded into ardour is not present in the interchange audio files. I tried looking for this file in my disk for this session and others and the problem it´s the same, the recorded files are not present on my disk, but the recorded tracks are present in Ardour if I open my session in this computer, but if I try to move to another computer the recorded files are lost, even when I fixed the “recorder:” prefix and using the archive method too.

How are you moving stuff between computers?

I´ve tried with archive method (making an archive and open the archive file in the other computer), and coping my session folder to another computer, with both methods the recorded .wav files are lost, include when I looking for them in the same pc where I started with my session, I cant found the recorded files on my computer, but these are present in my session. It´s a weird issue.

It’s also weird that you can see the waveform for a file that’s not present on your system.

Underneath your main session folder you’ll find a sub-folder called ‘peaks’. With the session closed, try deleting all the contents of that folder and then re-open the session. This should cause the peak files to get regenerated. Do you still see those waveforms or are they missing now?

hello John, thank you for reading this post. I´ve deleted all files into peaks folder and the waveform graphs was re-generated when I opened again the Ardour session, but the .wav files from my recorded guitar is not visible in the session folder structure nor anywhere in my disk…I think that is a bug, In some sessions works fine, but in the most of cases I have this wierd failure (only on windows 10, Ardour on Ubuntu works fine ).

Note: I´ve descripted the process in my PC, when I switch to my laptop (ubuntu) I can´t load the missing files because I can´t find them in the windows machine (but the session is reading them. Absolutely weird issue.
To deal with this I exporting my tracks without effects and I replace them in the new computer.

The files are indeed missing from the zip file you sent me. There seems to be a different, unrelated issue regarding the use of ‘%’ in file names related to stereo tracks, but lets ignore that for now.

I’m going to suggest that you read this page: linux - Equivalent of Unix find command on Windows - Super User

then use the information and examples there to search you entire drive(s) for the “missing” audio file(s). Let us know what you find.

hello Paul. I tried with this .wav lost using the command suggest to find the file…



File is not found.

I´ve tried with *.wav in the session folder and I´ve found other files, but not gtr_rythm

Searching for recorder:… will not work because : is not allowed in any windows filename. You need to use a pattern match against the filename after the colon.

Also, have you rebooted the machine since recording this session?

Also - searching for d:\gtr_rythm_01-4.wav might only search in one folder.

And is that name right? Your screenshots make it look like the missing file is called gtr_sfr01-1.wav

Try searching with asterisks:-

dir /s gtr_r*.wav

or maybe

dir /s gtr_sfr01-*

“:” in a filename is allowed; but the resulting file is a bit strange and that’s probably the cause of mlopezfunes’ problems.

If you start a cmd prompt, type notepad recorder:gtr_test.wav and hit Enter you get a file that you can type into and save.
If you look at it in Explorer it’ll appear as a zero byte file named “recorder” and if you try to open in there it’ll appear empty.
But if you go back to the cmd session and type the same line you’ll see the content again.

There is a “recorder” file in mlopezfunes’ google drive folder so I’m guessing that is the actual wav-file.

There doesn’t seem to be any elegant way to rename the file but one thing that should work is to go to the audiofiles folder in a cmd window, run notepad recorder:gtr_rythm_01-4.wav and Save As gtr_rythm_01-4.wav

A neat thing about Notepad is that it doesn’t add any formatting to the content of the file, so the new file should be the same valid wav as the strangely named one. (EDIT: This is incorrect. Notepad++ , however, works that way)

Notepad reads the entire file into memory so the above may not be feasible if the file is too large.

1 Like

Also; if you use cmd and notepad to create a recorder:gtr_test2.wav file you’ll get a separate file with a separate content but Explorer will still only see it as one “recorder” file.
So the “recorder” file in the google drive folder is probably all of the different recorder: files mlopezfunes has in that session.

The “recorder” file in the zip produced by google drive is an empty file.

It appears to be empty because Windows file manager can’t handle it properly.
As I explained in my previous post the only way I’ve found to access the file hiding behind the “:” is to use cmd.

I tried
type c:\Windows\Media\Ring05.wav > empty:testfile.wav
and ended up with a zero byte file called “empty” both in the file manager and when running dir.
Then I ran
notepad empty:testfile.wav
and saw the RIFF WAVEfmt header and the rest of the file.

But I can’t save it as testfile.wav and be able to play it and I can’t use Audacity to open in in cmd.

NCH Software’s WavePad was able to open the file using
<path to>\wavepad.exe empty:testfile.wav

I thought the recorder: issue had been fixed recently - or hasn’t there been time to release it yet?

It is fixed, but there’s no release yet (soon, though!)

hello Paul, I´ve tried with “recorder:” without “recorder:” and *.wav and I can´t found the recorded files.
I´m trying the method explained by Peder Hedlund using notepad right now.