Recommended hardware USBpre2 no longer working for capture

Since a change in the linux USB stack in the way to handle duplicate endpoint declarations, the USBpre2 from Sound Devices is no longer recognized as capture device by ALSA, even when full speed USB1 mode is forced (by pressing “Input 1” button at startup on the unit). It is therefore currently impossible to use the unit to record under Linux (only playback is recognized). The USBpre2 has been working flawlessly in full duplex (USB1) for me since purchase (> 5 years). I discovered the bug recently, apparently I’m not the only one :
I contacted sound devices and they (very quickly) responded I should fall back to previous Linux versions and said “We only support use of the USBPre-2 under Windows and Mac OS”. It is sad to read this message from their support while Linux is officially mentioned on product’s webpage and documentation.

Anyway, I purchased this interface partly because it was (and still is) listed as recommended hardware on Ardour webpage. Given the current situation I think it should no longer be listed as such for Linux users.

As discussed elsewhere in the forum the Sonosax SX-M2D2 could be a good replacement for those who are looking for very high quality and linux compatibility (and have the money!).

Wow, that’s too bad! It’s strange because the USBPre2 is described as class-compliant and always worked perfectly for me in Linux. Coincidentally I have a Sonosax M2D2 arriving today, but I no longer have a Linux machine so can’t test its compatibility.

FYI, I debated between the Sonosax and getting the new Merging Anubis, which appears to be compatible to some extent with Linux but it’s not entirely clear. They have a Linux driver for their Ravenna network, but I don’t see a Linux version of the Aneman routing utility. The Anubis is a much more multipurpose device, has two high-quality preamps and state-of-the-art AD/DA converters, but uses Ethernet instead of USB. Ultimately I settled on the Sonosax due to smaller size, USB interface, and the ability to connect to a range of recorders (even a smartphone).

The meaning of “class-compliant” is not clear for me but, from what I understand in the technical details of the first link of my message, USBpre2 has a partly broken implementation that was kind of tolerated by previous Linux kernels but no longer is (probably to avoid problems on other devices).

Also, when one investigates the attempts to make it work in USB2 mode (UAC2), it seems that, even with a uggly patch of the kernel, the device was not recognized for capture. To my knowledge it has never worked under Linux at its full potential. Note that Sound Devices don’t even support Windows in USB2 mode (allowing 192kHz). Is this a “class-compliant” device?

Anyway, it seems from the same link of my first message that a patch can solve this (by reverting to previous behavior for a list of blacklisted specific devices including USBpre2). It might appear in the kernel development tree quite soon. For the normal user using a standard distribution however, it means a long period of malfunction waiting for the patch to be integrated in stable kernels. So I really think ardour webpage should by updated to avoid newcomers to Linux/ardour to face this problem.

Concerning the Sonosax M2D2, I would appreciate your feedback. Can you test the device with an Android phone? Is it able to record at 192kHz?

I do have an Android phone with USB-C input, so will give it a try tonight and let you know.

I can confirm that the Sonosax M2D2 can record into an Android phone (using the Field Recorder app, which is recommended by Sonosax); I tested at 48 kHz and 192 kHz and both worked.

There is definitely a learning curve with the M2D2; I studied the manual before I ordered it, but it still takes a while to understand how to adjust settings, get back to the main menu, etc. I can’t say yet that I hear an obvious difference in sound quality between it and the USBPre 2, but I plan to do some real recordings with it this coming weekend and will have a better sense after that.

For clarity:

It doesn’t seem like Sound Devices changed anything, they have always worked like that. The Linux Kernel changed, and thus a bug was introduced, discovered, and it sounds like a patch is incoming to fix, so not really all that big a deal, that is exactly what you would expect.

I am curious to try my Mixpre6-II at some point with Linux but don’t have a box other than ChromeOS to try it on right now where it is not detected but I am not willing to write that off yet as it is more than possible (And even likely given my past track record with ChromeOS) that it is something weird in Chrome OS.

1 Like

FYI, I had a closer listen on my computer to the recordings I made on the Android phone, and there are lots of xruns at 192 kHz. So while it can record at that sample rate, it’s possible that you’d need phone with a stronger processor than mine to avoid clicks and crackle (I have a Google Pixel 2).

1 Like

Hey folks, I’m interested in the a Pre II. While it looks like the changes to the kernel to (re-)support this device were accepted, does anyone know if it’s actually working? I would only use with Linux and it’s an expensive piece of kit to not function. Thanks in advance!

It sounds like you’re talking about a different device from the USBPre 2; are you talking about the MixPre series, version ii (with 32-bit floating point)? The first-generation MixPre series recorders/interfaces reportedly did not work as interfaces in Linux (see but I can’t test as I don’t currently have a Linux machine. I haven’t heard any news about the new generation of MixPre recorders being compatible or incompatible as interfaces under Linux. FYI, they are a bit tricky to set up and use as interfaces, but are great recorders.

If you are actually talking about the USBPre2, I don’t have a Linux machine currently to test it on.

Ohh. You’ve understood my intent. I am concerned with the newer devices, sorry for the noise!

If I ever get funding one of my projects is replacing my studio computer again and I may go Linux on it again. If I do Ill let you know how well my Mixpre 6-II works or doesn’t on Linux on it. As of right now all I can confirm is it doesn’t work on ChromeOS right now:)


This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.