Rave Generator 2 VST no GUI (AMD Graphics)

Good morning,

after quite some time I’m trying to use the great Rave Generator 2 VST plugin, but it will not show the GUI, just a black window. This used to work in an earlier version of Ardour (on the same system), but I can’t remember, how long ago this was. (now Debian 11, Ardour 6.9 from official package)

In this old thread, (https://discourse.ardour.org/t/rave-generator-2-probably-the-best-plugin-ever/101722/5) Paul mentions this problem in connection with the nouveau driver, but my system has AMD graphics:

Graphics: Device-1: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590] driver: amdgpu v: kernel Display: x11 server: X.Org 1.20.11 driver: loaded: amdgpu unloaded: modesetting resolution: 1920x1080~60Hz OpenGL: renderer: Radeon RX 570 Series (POLARIS10 DRM 3.40.0 5.10.0-13-amd64 LLVM 11.0.1) v: 4.6 Mesa 20.3.5

Any ideas what I could do? File a bug report?

Thanks!

p.S.: The plugin as such seems to work, when I select a preset I can hear sound

After some research it seems that this is not related to Ardour.
Apparently the GUI uses an older version of QT which is no longer available in Debian…
Shame, that was a nice Plugin :frowning:

Found a quick and dirty way to get the QT4 libraries in Debian Bullseye. You could read about it here (in german).

Anyway, working fine again:

Requiring an external graphical library is likely to eventually cause problems. Plugins are expected to be self-contained, and using Qt, GTK, or other heavy weight shared libraries is highly discouraged.