Properties window doesn't open

I am using Ardour 8.1.0 on Fedora 38.
The Properties window does not open. If I open a new session and go to Session > Properties or press Alt+O it works fine but if I save the session, close Ardour and open the same session again the window does not appear.

I have tried the solution in this thread: Properties window missing! without success.

It worked before, but I don’t know if it was with the new version or something I did.

I’m on Ubuntu 22.04 and it works fine here.

Which desktop environment? KDE does not support standard window layer settings, there is a config option in Ardour you can set to help with secondary windows/dialog boxes being stuck behind the main Ardour window. Not a problem with Gnome, I believe only KDE. That would be useful if the properties window actually did open but is just hidden behind another window.

Indeed, try to enable Ardour > Preferences > Appearance > Quirks > All floating windows are dialogs and perhaps also Quirks > Transient follows front.


Nothing happens.

I exclude version 8.1.0. I installed an earlier version and the window does not open either.
I must have touched something in the configuration or a system update broke it.
It only happens with this window.

Thanks for trying to help.
I haven’t figured out the problem, but I deleted the ardour8 folder in ~/.config and let ardour create a new one and it works.
I changed the preferences one by one, checking that the properties window opened each time until everything was the same as before, and I think everything is the same now. At the moment the bug has not been reproduced again.

It seems that it is because of the language, if I uncheck the box “Use translations” so that the program stays in English the properties window does not open, on the other hand if I check the box it translates to the language of my system (Spanish) and then it works correctly.

Is this only happening to me? I just want to know if it’s my system or a bug in Ardour so I can report it as such.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.