Playback doesnt work at all


I´m really new to Ardour b/c I´m trying to move to Linux and searched for a software I can mix my 16-track records. I installed ubuntustudio 7.04 and ardour 2.0 (built from revision 1762).

I imported some recorded tracks but I didn´t get the simple playback working. When clicking the playback button (>) nothing happens. The button doesn´t stay pressed. No playback line or something like that.

Before starting ardour I started JACK and audio playback with other applications (browser, musicplayer) works well.

Can anybody give me a hint what to do? I search the manual and tutorial but couldn´t find a helping hand …


Did you press the play button in Ardour, or in qjackctl?

I pressed the Start button in qjackctl and the PLAY button in Ardour! But nothing happens …

The start button in qjackctl does nothing unless Ardour (or other jack transport clients) are configured as jack transport slaves.

What sync settings do you have when the play button in Ardour doesn’t work? See the combo selector box on the right of the two clocks and the button below it. Playback should always work when it’s set to “internal” and time master.

One other possibility for playback to not work would be if ardour was disconnected from jack. That you can check from the qjackctl connections page. If you don’t see any audio inputs or outputs for Ardour, it’s not connected.

In Ardour it´s set to internal an Timemaster. In Ardour´s JACK menu it also seems to be connect b/c the connect entry is disabled, only disconnect is available.

In qjackctl I see that Ardour is connected to my soundcard.

See the images, maybe you can find sth useful:


Do you see the end marker anywhere in that session? If that marker is by mistake at the start of the session, playback might not start at all. If you don’t see the marker anywhere, try moving the start marker and see if there’s another marker below it.

If that doesn’t help, you should try changing the sync to something other than internal and then changing it back to internal.

Hmm … start marker is at the beginning and end marker at the end. There are no other markers.

I also tried to change the sync to MTC or JACK and back to internal but nothing helped.

Can you move the playhead (the red cursor) manually? What if you drag the “shuttle” (above “stop”, “%” and “Feder”) control to the right?

Btw. Which translation are you using?

I can move the red cursor (also the blue one), if we mean the same. I moved it a bit to the right and shot a foto … maybe you can check if we mean the same.

I can drag the shuttle to the right. When I release the mouse button it snaps back to the middle. I can´t see anything changing when moving the shuttle …

As I am from Germany ubuntustudio installed the german language version.

tabster, please check in the menus under Transport -> Options -> Sync Startup to Video. Is this option checked?

hi paul, this option was not checked. but checking also didn´t change anything. maybe there´s something else wrong with my (sound)system? … but I don´t have an idea what to check …

since sampo put the question about the translation into this thread, perhaps it is worth of trying to start ardour with:

‘LANG=en_US.UTF-8 /usr/bin/ardour2’

as i suppose that ardour2 is installed in /usr/bin.

i am on a german keyboard here too, and using the ‘LANG…’ prefix solved here some very strange issues too.


nowhiskey, changing to the en_us version didn´t help …

is anyone out there who can help me?
maybe i should provide some more information about my system, but i dont know which.
please help me!

perhaps it is worth of trying - you build 2.0-ongoing from svn.
there are instructions at this page available how to do it.
my first ardour was ardour-beta23 and it was packaged by agnula, but as soon i switched to use a selfmade ardour, it became less fragile here.


okay, thanks for the hint. i´ll try it. on the page i found the required libraries and installed them using the synaptic package manager. then i downloaded the 2.0.2 sources.

but i can´t find the commands i have to execute for building ardour itself. can u give me a hint?

and: should i uninstall ardour and jack at first?

you should not have to do anything with jakc, as it is already running at your machine?!
i think it is not a bad idea to uninstall ubuntu-ardour2 first

cd into dir where you saved the tarball, than do :
‘tar xvjf ardour-2.0.2.tar.bz2’
the tarball will get unpacked.
when this is finished and you are on the prompt again, cd into the sourcetree:

‘cd ardour-2.0.2’

and than type ‘scons -j2’

it should take about half hour to compile, than become su(passwort) and type:
‘scons install’

if you don’t get any errors, ardour2 will be installed in /usr/local/bin/ardour2, so you have to change the menu entry for starting it, since it is pointing to /usr/bin/ardour2 in the moment.

you also can compile with:
‘scons -j2 PREFIX=/usr’ than you start ardour2 with ‘/usr/bin/ardour2’.
i have ardour2 compiled in /usr/local

hope this helps?!


so, i compiled ardour as you described. everything worked without a problem. thanks for your description. then i started ardour by typing /usr/local/bin/ardour2 on the command line. but there is the same problem as before: pressing the play button in ardour doesnt do anything.

maybe it´s because of another application or because of a problem with jack? do u have an idea?

look, if you are able to place a playhead (the red line) by simply clicking in the timecode line (the black one on the top), you could try to switch the 'auto play’funktion on.
than, ardour should start playing automatically, everytime you click in the timeline.


I am having this exact problem runing UbuntuStudio