No sound in Ardour5 on Linux Mint/ALSA


this is a follow-up to a related thread.

Using Ardour5 for a couple of weeks on this PC, OS is Linux Mint, not using Jack, just ALSA. Ardour worked so far as usual. After a onfiguration change it stopped outputting sound.

Configuration changes before Ardour stopped outputting sound were:

  • Removed a graphics card because Ardour’s UI responded with annoying lags and delays;
  • switched to on-board graphics (Intel), Ardour’s UI responds now smoothly;
  • sound output from mainbaord is now routed through the HDMI cable and played back on the monitors built-in speakers;
  • reconfigured audio settings for OS; other audio stuff like Audacity or VLC works fine.

However, if I connect a 3.5" headphone directly to the mainboards line out, Ardour outputs audio on the headphones when I switch the OS audio settings to analog.

I assume Ardour does not use the same audio stack as other applications and that Ardour does not understand that the audio signal comes through an HDMI cable.

Output from Paul’s helper script:

$ bash 
Part I: ALSA
Advanced Linux Sound Architecture Driver Version k5.3.0-51-generic.

Card 0 (PCH):
  * Playback Device 0 (ALC887-VD Analog):
    - Subdevice 0 (hw:PCH,0,0):

  * Playback Device 3 (ALC887-VD Digital):
    - Subdevice 0 (hw:PCH,3,0):

  * Playback Device 7 (HDMI 0):
    - Subdevice 0 (hw:PCH,7,0):

  * Playback Device 8 (HDMI 1):
    - Subdevice 0 (hw:PCH,8,0):

  * Playback Device 9 (HDMI 2):
    - Subdevice 0 (hw:PCH,9,0):

  * Recording Device 0 (ALC887-VD Analog):
    - Subdevice 0 (hw:PCH,0,0):

  * Recording Device 2 (ALC887-VD Alt Analog):
    - Subdevice 0 (hw:PCH,2,0):

Part II: jack processes

I don’t see a problem in Ardour’s mixer, and in Ardour’s Global Settings I can not find something related to sound output.

Where do I go from here?

Is there something like a troubleshooting checklist to work through if Ardour does not output sound on Linux?


Hello where do you want to output ardours soind?

Maybe can you give us a screenshot of the audio setup page of your ardour?

It seems that your onboard soundcard has only a single device hw:PCH that abstracts all audio (incl. sending sound to the HDMI display) as sub-devices

Arodur 5.12’s setup dialog cannot handle this.

You have two options: Ardour6-beta should be able to allow selecting the “ALC887-VD Analog” device for Ardour/ALSA.

Alternatively you could use JACK, and set it up using qjackctl or another jack control application for use with Ardour 5.

@Sahaathyva: Thanks.

What I would want is that Ardour outputs its sound exactly through the same loudspeakers as the rest of the PC. Just the most basic use case for an audio application - two channels (stereo) go to two speakers.

Ardours audio setup page:

2020-05-03 23-51-45

Probably nothing to miss here.

The problem here is the ambiguity. “HDA Intel PCH” can mean anything in your case.

Ho that s*cks…

In my case this means analog out

@Robin Gareus: I tried to start Ardour with Jack. Results in error message:

“Session … did not load successfully”

Trying to create a new Ardour project doesn’t work, either. Error message:

“Can not create project …”

Running a beta version is not an option for me, sorry. I can hardly manage packaged software in Ubuntu.

So I can not use Ardour, because Adrour can not handle an onboard audio chipset like this HDA Intel PCH/ALC887-VD, right?

Let me guess: you have not set up realtime permissions for your user? On Ubuntu easiest via

 sudo dpkg-reconfigure -p high jackd2

Set it to “yes” and re-login.

No realtime permissions for jackd? I don’t think so:

The checkbox is only to “request” it. Have a look in the log window if the request succeeds.

I guessed wrong then. So

“Can not create project …” did no end with “…missing realtime permissions” then :slight_smile:

It should work with Audio System: JACK.

That windows shows you selected 44100 for sample rate, the previous setup dialog showed 48000 as sample rate. The Ardour project sample rate must match the set hardware sample rate, so one of the two selections (either the one shown for jack or the one shown for Ardour ALSA backend) may not be correctly matched to the session sample rate.

You should post the entire error messages. They usually explain in detail why the error occurred.

It’s a bit weird that you’re running jack at real time priority 10 and not “default” but that shouldn’t be a problem.
Neither should a sample frequency mismatch be; ardour should give you a warning and allow you to continue if you’re fine with that.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.