MXtune Plugin not working - solved

I put the vst dll in following directories too and added an additional directory but Ardour cant find mx_tune … :

LV2 plugins should be found in /usr/lib/lv2/, /usr/local/lib/lv2/ or in a directory mentioned in your LV2_PATH environment variable. The most common mistake made by distro packagers, is to use a path like /usr/lib/$ARCH/lv2/, /usr/lib64/lv2 or /usr/local/lib64/lv2 and find that Ardour will not find that by default. The user can either add a link from this actual directory to the standard directory or add this path to LV2_PATH.

Under Ardour/Carla Ardour crashes immediately. In Reaper it works but Ardour … no way whatever I try …

I am misleaded somehow …

1 Like

I can confirm that MxTune crashes Ardour 7.2 (regular download). Probably a memory leak, it froze my machine after having eaten 83% of my ram (32go, oof).
Try the test version found in the issues tab, it doesn’t crash here. Also the GUI doesn’t scale properly on my HiDPI screen, but that is a topic for the creator’s github ^^

1 Like

It is not a memory leak. The release version exposed too many symbols and this caused confusion over which version of the aubio library got used by the plugin, which then leads to some very bad things happening. Like allocating huge chunks of memory :slight_smile:


Create a folder like .vst2. Then copy the file in that folder. In ardour you have to add the path to the directory .vst2.
That’s it!

1 Like

I believe you have a misunderstanding about plugins.

I think you may be confusing ‘LV2’ with Linux plugin. LV2 is a plugin format that works on Linux as well as Windows and Mac. VST is another plugin format that likewise works on Linux, Windows, and Mac.

There are Linux native VSTs (Typically end in .so) and Linux Native LV2 plugins (As paul mentioned above, will be a directory ending in .lv2 mostly). The software you are referencing has a linux native VST, but does not have an option for LV2 that I see. As a result you are definitely dealing with the VST plugin.

There are also Windows native VSTs (Which end in .dll typically) as well as Windows Native LV2s. Some programs will run these on Linux via Wine, but this is always at best a workaround, and you should use the appropriate Linux Native version in those cases instead. Carla supports both methods, and Reaper can run linux native plugins just fine, but if reaper is run under Wine it will load Windows DLL VST plugins.

The most recent code of the plugin you are mentioning has changes to fix it’s behavior on Linux when loaded into software that uses certain libraries (Which Ardour also uses). This code may or may not be released in a public build yet, not sure. Until it does get released it could work fine in say Reaper, which I don’t believe uses those libraries, but would have issues in any software that does use those libraries, like Ardour. Once it does get released if you install it in your VST directory (NOT your LV2 directory) it should be seen by Ardour and recognized.

1 Like

Thank you woozl.1986, it works this way! The mxtune plugin is now displayed by Ardour at least. But it still crashes as soon as it loads. Inside Carla it works anyway! I think Paul and Robin will find a solution to make the mxtune plugin run correctly.

1 Like

Hello Seablade, thank you very much for your help in making me understand! In fact, I was not aware that there are special linux vst plugins which probably have the file extension “.so” and do not correspond to their vst windows dll counterparts. I hope Paul and Robin will find a way to integrate the mxtune plugin into Ardour ideally without using Carla.

1 Like

As mentioned in that post and others before it, there is a Linux Native VST plugin already existing for that plugin, but it had bugs that the author has already fixed, just not sure if he has released a version with those fixes yet. Once he does, that will work like any other plugin in Ardour.


1 Like

No work is needed in Ardour to use mxtune. The fix is in the mxtune plugin, and is already done (but not released).


MX Tune new version 1.2.0 is still not working in Ardour - not even in Ardour/Carla. Works in Reaper/Carla without problems. Actually I wanted to go back to Ardour but without a usable pitch correction tool (comparable to at least to ReapersReatune … without mentioning Melodyne) it won’t be possible for me. What a pity …

Did you try the test version i linked in my previous message ?

Releases · liuanlin-mx/MXTune · GitHub - fresh upload from today

Same with your test version baptiste, crashes immediately in Ardour 7.3 - Thanks for your help!

BUT it works in Ardour 6.9! (not 7.3) - Perhaps you tried Ardour 6?

Tested on Linux/Ardour 7.2: i can scan and load the test version but the scan reports an error for the newer 1.2.

edit : same with Ardour 7.3

Weird … lets wait and see what Paul means …

Ah, ok…I’m working with ardour 6.9 and yes, it works fine. I don’t know if the plugin works in ardour 7.3.

For pitch correction, try gsnap with midi. You get so great results.
And gform for pitch shifting.

You can download here: GVST - Downloads

These little tools are nice toys but not good for semi-professional serious work with vocals. Melodyne is best to work like this - Autotune is a completely different approach (just to save out of tune singers). Thank you woozl.1986

Just a wee heads up troops - the latest version of mxtune works on my machine with Ardour 7.3 (just downloaded and tested). Could probably do with renaming this thread though.

1 Like

@willy_dinglefinger You might have done the community a better service to report that status on a new thread, rather than revenant-bumping a five-year old one.

1 Like

Version 1.2.0 on Ardour 7.3, works for me, too.
Found a video on YT to get kick-start info.