More different midi tracks routing to 1 instarument - howto?

Hello everyone,
i use Speedrum and i have more midi tracks. How can i route the midi tracks to the track where speedrum is as vst2 plugin in the track?

If you take that approach, I suggest to use a MIDI bus for the instrument.

Then create various MIDI tracks without instrument plugin, and connect their outputs to the Bus. Easiest by using the “I/O connection” button at the bottom of each mixer strip:

Thank you very much. I know now how midi works.

Let me ask about the audio routing to Speedrum or other instrumentes who can can send to more outputs- I’m sure you know how it works and can explain me.

I made a midi track with no instrument and added the Speedrum manually (otherwise, speedrum makes 32 outs hisself).

I testet e.g. out 10 and i can hear the sound - and see it at out stereo pair. My question: What do i have to do, to route e.g 3 different outs from the Speedrum to 3 mixer channels.

Additional Info: that comes if i point with the mouse to the “Master L+R” bar.

I’ve downloaded Speedrum DEMO and played with manually arranged IN(s) & OUT(s):
To make 3 MIDI IN(s):

To add 5 OUT(s):

Wow - Thank you. Now i understand how Ardour works.
The different Midi ins (your first video) works.

If i make it with the outputs so as you described in the 2nd Video, i had some “errors”

  • in the Routing Grid not Speedrum out 1/2 brought the Out 1 of the Speedrum VST to the audio out, but the out 13/14.
  • and i had some Crosstalk of the channels. e.g. Snare on Audio 2 → Routing Grid 15/16 → Audio Out 2 Stereo, but also on Out 3 the left channel brings the signal a bit.

But: After seeing your Video how to merge midi tracks here, (btw very complicated in Ardour) i work now so:

  1. I merged all drum midi tracks to one track and copied it to a new Midi Track of Speedrum. I made the multi outputs with the wizard, that comes, if i create a new midi channel. I have 16 stereo outs - but that works without crosstalk.

I hope this would be improved in Ardour in the future to plug and play as e.g. in Cubase.

One question:
How can i show the track numbers you have? I have only the track Names

Session > Properties > Filenames > Prefix Track number

1 Like


BTW: With which software do you make your screenvideos?

Not really understood what the “wizard”? When I add a new MIDI track with multi-out plugin - I’ve no any wizard. (could you make a screenshot?)

If i add e.g. Speedrum

His window (i called this wizard) comes.

Wizard for Outputs

And that makes 16 stereo outs and all works correct.

In my Ubuntu 22.04:
For *.mkv - videos - I use Simplescreenrecorder:

For *.gif - pictures - peek:

sudo add-apt-repository ppa:peek-developers/stable
sudo apt update
sudo apt install peek

(If your peek will not record mouse cursor or other recording *.gif problems - just start it not with an usual application launcher, but use a terminal and run a command peek -b ffmpeg)

aa… I got your approach…
If you want to disable the creation of the 32 audio tracks - switch off the Fun out button in the dialog (“wizard”):

you can add a new MIDI track with the desired multi-out plugin with automatic outs added if you can change an option from Strikct-I/O to Flexible-I/O in add track dialog:
(this makes a track without any dialogs)

PS: to change the Ardour’s behavior globally just check/uncheck the option Edit > Preferences > Signal Flow > Use ‘Strict-I/O’ for new tracks or buses

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.