Minilab mkII + Ardour + define pads

Hi, I am starting with Ardour and music edition. I bought an Arturia MiniLab mkII. I want to work with Linux (Ubuntu right now).

My first test was with MIDI Learning, but I don’t know exactly how to assign a pad.

For example, I am using sfizz with african drum. I want to assign Pad 1, 2 and 3 to drum sounds.
I know that CTRL middle mouse button works for volume.

How can it be done?


if no one can get you an answer sooner, I’ll get back to you by Sunday. I don’t use sfizz so I’ll need time to install it and get it going and play around. In the meantime, look at this portion of the manual:

Also, when you start the project, you will need to have selected the Minilab as the “MIDI System” device in the Audio/MIDI Setup dialog. Play around with those things, and if you can’t figure it out, I will try to help you out once I have time.

1 Like

Thanks Saam. I know that Minilab is working, because it reproduce the drum in the keyboard, but I want to know how to configure a pad button instead of a piano key.

I am playing around a lot I hope the answer appear soon. :hugs:

that’s a good sign, your solution shouldn’t be far away. If the keys on the Minilab are producing a sound, maybe we need to configure sfizz to assign the appropriate MIDI notes to the sounds that you want.


could be the problem is at two places, MIDI setup in Ardour and your keyboard.

The first one is described here. You asked for MIDI learn, and that’s the place.

I mentioned the second one because I did configure my small Akai MPK Mini so that I have a piano sound on the normal keys, and drums on the pads. I have not done that with my Arturia Keylab Essential yet, so when I hit a pad on that one I’ll have piano (or whatever standard instrument) as well.

I think the solution to the latter is in the Arturia manual somewhere, don’t even know if it can split MIDI channels for normal keys and for pads - drums are usually on channel 10…

1 Like

The MIDI tracer will make it clear what channels the Minilab data is coming in on, that’s why I linked that part of the manual. If the Minilab isn’t outputting the pads on Channel 10 and the keys on Channel 1 (or whatever else you want) you will be able to ttell from the MIDI tracer. If that is in fact the problem, you will probably need to use Arturia’s Control Center to configure the Minilab channel’s to your liking (there might be a way of doing this directly on the Minilab, I know channels can be changed on the Beatstep Pro without using the software).

Hi @wjl , you configure your small Akai MPK Mini. You did it with CTRL + middle button? There are three ways to resolve it in that link:

  • right click on the processor element in the mixer strip, and choose “Edit with Generic GUI”
  • right click on the processor element in the mixer strip, and from “Controls”, make the desired parameter visible inline in the mixer strip
  • in the editor, click on the “A” (automation) button for the track, find the desired parameter. This will make the automation lane for that parameter visible, and it comes with a fader you can use for MIDI learn.

Here I can’t understand what control is. The MIDI Learning example is easy, but I can’t imagine which key is correspond to which control. African Drums sample have only three keyboard keys (F2, G2 and A2).

About MIDI Tracer (@drsaamah ) it display this for the keyboard’s key (F2):

   139121203         NoteOn chn  1 2d 7a
   139125080         NoteOff chn  1 2d 00

And this for the pad nº 1:

   142424210          NoteOn chn 10 24 11
   142429260    PolyPressure chn 10 24
   142430274         NoteOff chn 10 24 00

Apart of that, I am linux user. Do you use Arturia Control Center with wine?

Thanks for both responses. I apology my english.

Can you take a screenshot of the sfizz window that looks like this:

Your pads are coming in on Channel 10 which is correct and the keys are sending notes on Channel 1 which is also correct. the problem here is the configuration of sfizz. we need to setup sfizz to asign channel 10 to the drum sounds and the channel 1 to whatever other sounds you are using.

sorry i didn’t answer your question. i keep a small windows partition on my laptop so in the rare case that I need Arturia Control Center or whatever windows application, i just boot into windows, make the appropriate adjustments and go back to linux. but anyways, that is NOT the problem here. your Minilab is outputting on the correct channels, we just need to configure sfizz to assign those channels appropriately.

Last thing… although it should be by default… right click (in the editor window) on the MIDI track that has sfizz and go to “Channels” and make sure that it is set to read and write on all channels.

Thanks again @drsaamah for your replies. You are helping a lot (both of you). I am learning.

Let’s see. I don’t have the same window for sfizz, but…

Now I have to stop here because I have to go out. I be back later.
Thanks a lot for your help.

(Note apart: by the way, I was in sfztools chat room yesterday and they told me that the solution could be using x42 mapping plugin or something like that. I don’t understand. I though they mean to map the keys with a setup file. I prefer to avoid this if possible.)

@drsaamah I check all the things you said. All channels are selected.

by end of the day tomorrow, I will get this is on my computer and see what we can do. for now, its good that all channels are selected, which should be the default. the issue is definitely in sfizz somewhere. obviously, the midi tracer shows the signals are coming in, they’re coming in on the appropriate channels, and the midi track in ardour is reading all channels. the issue is the voices sfizz has associated with those channels.

I am so sorry but I cannot install sfizz. i have the repo installed but aptitude still can’t find the package. but this is definitely an issue between the sfizz and the minilab. have you tried reaching out in the sfizz irq or discord channel? there’s also an email provided for support.

Ok @drsaamah . Maybe there is an example with an useful plugin that you have that works for me. So I can figure out the idea how to define my pads with sounds. :man_shrugging:t5:

It needs to be done in a user template. Follow the directions in the mkII manual for making one.

Then you can map a pad to whatever sound you want.

Simply put… you map the pads to the keyboard - the sounds to the keys.

His issue is not with the Minilab. MIDI tracer shows that the pads and the keys are sending signals to Ardour and that they pads and keys are coming in on different channels. sfizz is not mapping the channels to the sounds that he wants. the issue is definitely with sfizz.

Yes because that’s the way the keyboard is set up.
It needs a new template with the pads (which are set from key # 37 I think ) set to the key on the keyboard that the drum is set to (#c4?) then it will sound with that drum.
At least that’s how I understand the issue…he wants the pad to sound that drum.

So, the thing is that I can’t define that function with Ardour: change a sound from one key to a pad. The solution are, 1) Minilab template thing, 2) or a plugin configuration. I though it was going to be easy, maybe I am to innocent.

Anyway, uhm, I can check another plugin. DrumGizmo for example. But the problem is the same. To change the function of a pad, I need a new template? So I need MIDI Control Center, so I need Windows or an emulator?

Thanks @Steve9600 and @drsaamah for your replies.

Yes I think you need wine at least, I do not know if that would work with their midicontrol app
You have 8 presets maybe one of them will work for you.
Press shift and press a pad to get to the pre sets.

If the only option is wine I would download avlinux and run it as a live usb everything you need is provided in the iso. At least you could see if it worked.

If you have access to a windows pc you could do your editing there.

Little late to say this but if some hardware has to have
Windose to make it work I look elsewhere.
Can you return the keyboard? :nerd_face: just a thought.
Good luck