midi overdub

I’m using debian stretch with ardour 5.5 and freebsd 11.1 with ardour 5.11; Ardour 5.5 is the “ready to run program” from “https://community.ardour.org/download
and the freebsd ardour 5.11 is complied from ports.

Currently, when I re-record midi, it just adds notes to the old take. It doesn’t overwrite the old take.

Is there way for midi punch in/outs to overwrite/replace the old take?

Audio overdub I figured out just fine:
I set the punch points, record the new audio take, and the old audio is replaced with the new audio. On playback, the new take is there.

Midi overdub I can’t figure out:
I set the punch points, record the new midi take, and the old mid is not replaced with the new midi: it is added to the old take. On playback, both the old and new takes are there.

I would like the new midi take to overwrite/replace the old.

Any help would be appreciated…

Cheers

I bought Ardour 5.12 for linux. In slide or lock mode, I’ll select “edit->separate using punch range” then delete the offending midi region… overdub. That’ll be fine.

You can red here:

https://community.ardour.org/node/13648

And watch here:

Synthetic drums midi record:

Acoustic drums midi record:

(This is from https://community.ardour.org/node/14375)

Sorry “red” - “read”

Ardour 6.9.0~ds0
“After Bach”
(rev 6.9.0~ds0-1)
Intel 64-bit
This is the most basic function in MIDI recording…Record midi notes on a track, make a pig’s ear, ditch the recording and re-record. I’ve seen “control+space bar” as asuggestion, but, it doesn’t work for me. I’m really embarrassed to ask how to do such an infantile function, but, red faced, I’m asking. Regards all. P.

“Control+space” cancels the current (running) recording, discarding the porcine appendage. :slight_smile: If you instead stop the recording normally (“space”, or using the transport), then you can use the menu option “Edit | Remove Last Capture” to discard said appendage.

I must say I’ve had two responses to inane posts at the speed of light. I’m no less embarrassed,but, extremely grateful. I’m now off to find how to import a MIDI file without 1) everything arriving on one track 2) crashing using the import function even, as suggested, selecting “none” as the instrument. Apart from these stupid basic clangers,(my clangers!) I’ve got to say Ardour is the biz. Stand by for donations to be rattling as they drop in the tin. Regards all. P

This combination stops the record and cancels the storing the clip in the track… Anyway I’ve made a new version of video about the drum midi overdub here:

I’ve over-complicated the approach and added a simplest way for layer method recording there:

sorry for a jumble :crazy_face:!