midi controller and connection

Hello everyone! do you think there is no way to run this type of controller of ardour 3?


second question: is there a way to save the connections of the various software set from the “jack audio connection kit”?

TouchDAW uses RTP MIDI. There is no implementation of this protocol on Linux. If there was, there would be no problem with this device being used. I note that they do support various USB MIDI connectivity options, for Linux it would be necessary to investigate that.

On OS X, it could be used as is.

But note: devices like this are MUCH better supported in Ardour3, which will be released shortly. Although Ardour2 does have support for MIDI control, it is a bit more cumbersome to use.

if you could use as a midi device a tablet would be great! with 100 euro you can have all the controls! :slight_smile:
but according to you, with that program (or similar) can also move all the knobs and faders of a synth plugin?

by the way! when it is due out in ardor 3? (I’m using it already :))

In regards to the first question, sure no reason it wouldn’t that I know of. Of course you also have options like this…

Which last I checked needed some updates to work, but would probably be a better choice:)

Or of course any of the numerous OSC apps.

In regards to your second question, what you are looking for is a session management solution most likely (Or QJackCTL’s patchbay functionality, depending on what precisely you are looking for). There are a few to choose from, none have gained universal acceptance.

  1. but with this app I could also control a synth plugin?
  2. what are these programs? and pros / cons are?

hello friends! I am continuing to try to control and vst ardor of festige via TouchOSC (Android app).
reading this topic I’ve seen that it should be feasible:

I was able to communicate with the app and the computer (with pure data) now I have to be able to forward these messages to ardor.

unfortunately I’m stuck in step 4:

4. Fire up Ardour and click options/misc. options/use osc

I use ardor 3, but I can not find “options/misc” where is it?

and the second question: if I can make it all work out then automatically ardor will also festige? or I’ll set it aside for this program?

thanks :slight_smile:

Main menu bar in the editor window > Options > Misc Options > Use OSC

Festige has nothing directly to do with Ardour at all. I don’t really understand your question.

in the top menu “editor” does not exist, but exists only “edit” and “window”.
in “edit” no “options” but “preverences” and in the tab “Misc” there is no “use OSC”

My second question was, once I am able to configure ardor to use TouchOSC, I can also use the plugin festige? this will require a configuration or separately?

thanks :slight_smile:

Answering the second question, as Paul said, festige has nothing to do with ardour. Actually, festige is not a plugin, but a host for windows VST plugins (actually, a gui frontend for dssi-vst and fst). And, of course, you cannot control festige from ardour.

However, you can always connect festige to ardour, via manual jack connections or by means of an insert in an ardour track but that’s all.

I am not sure about festige and OSC. You should ask falktx. He is at linuxmusicans dot com, linux distributions and other software, kxstudio forum board

Cheers! Pablo

i did not mean Main Menu > Editor > Window > …

i meant, in the editor window, in the main menu > Options > Misc Options > Use OSC

I do not even options … I have only:
session, transport, edit, region, track, view, jack, window, help …

i missed that you are using ardour3. you need to go to Edit -> Preferences -> User Interaction

then enable OSC.

here! I found it!
I state that I do not have similar experiences in the device configuration OSC, so maybe I’m doing something trivial.
I am attaching the screen what I see:

the white screen on the left is PureData that takes data from my phone.
in the middle is the mixer, but despite the computer detects the movements of the fade of the mobile phone, the mixer ardor nothing happens … why do you think?

no idea, and i don’t discuss technical matters like this on a medium like a web forum. its slow, clunky and completely stupid. if you want to talk about it, find me on IRC (though probably not on christmas day).

Touchdaw is working with Ardour 3.1.10

you have to use Qmidinet create 2 ports for Jack
on Ardour edit > preference > user interaction > control surfaces
choose Mackie > BerhingerBFC2000
with Qjackctl connect midi
Qmidinet out_1 > ardour mackie control in
aedour mackie control out > Qmidinet in_2
on Touchdaw you have to choose wifi multicast to connect

Yves, thanks for your pointers on this. I’ve gotten TouchDAW working on my Android tablet (a cheapo 7" Coby) and will run it through some tests to see how stable it is. Since I do a lot of mobile recording, this could be a big step forward in easily controlling my setup when in the field.

Something I noted is that it doesn’t seem to matter much which DAW is chosen, the functionality seems pretty consistent. Onto the testing!

Ill be interested how well this does or does not work for you. I have a MCU gathering dust I would rather replace with a basic controller on a tablet in most cases, but still deciding


This is working better for me than I had hoped. When I started, I’d often have Ardour lock up on me, and I’d have to resort to killing Ardour and jack from the command line. There were definitely issues on my system (running Arch Linux). After many gyrations, including installing the RT kernel and wireless drivers (as well as some hair pulling over the rt-wireless driver naming my wifi interface as eth0), it turns out the root cause was user error. A change in systemd meant /etc/sysctl.conf was no longer read. I hadn’t remembered that I’d changed it, and some parameters like vm.swappiness were set inappropriately for a performant system. Once I correctly set this, it was great.

With the laptop now running the RT kernel and interfacing properly with the wireless network, serendipity happenned - I’m now running jack against my Alesis mixer with a Firewire interface with only 128 frames/per and 2 periods/buffer, which is such low latency (Ardour reports 2.7ms) that I can have Ardour perform the monitoring. This lets me control the live sound volume with Ardour’s mixer rather than with the Alesis’ faders. Huzzah! I no longer have to be tied to the mixing board! Now when the singer moves the mic and starts to feedback while I’m over at the keg, I don’t have to make a headlong dash over to the mixer - a gesture on the tablet and the singer’s volume’s is brought down a tad. Since I mostly do live sound and mobile recording, this is a HUGE win for me.

I’ve now recorded over 80 minutes of all 18 channels from the mixer (16 channels plus the main mix in stereo) with this setup with nary an xrun to be seen. I’m declaring this a real success.

Not all the controls in TouchDAW seem to work, but that’s OK. (I’ve got TouchDAW set as a controller for Logic. If anyone’s used anything else more effectively, I’d love to hear about it.) In the mixer section ann the controls work as expected (I really like the Flip button which swaps the volume and pan controls between the rotary and slider pot controls - very handy since the rotary controls are a bit finicky). I can arm and disarm tracks on the fly nicely. In the control section, zoom and navigation work well and switching banks brings me back and forth quickly. Stopping and starting work as expected. I found I can arm the global record button from the tablet but not disarm it, but that’s great as far as I’m concerned - there’s no chance I’ll accidentally hit it and stop recording all the channels. Even the Save button works!

Now, what doesn’t work? The clock doesn’t work at all, it remains at zero on the tablet the whole time. The channels are not always updated with their fader level or mute/solo/arm status until a change is made either on the tablet or at the computer. Neither of those are an issue for me.

I don’t know that I’d want to try managing a full recording session with just the tablet, but all the basic functionality I want in controlling a live show is there and is working fine for me. TouchDAW might be the best $5 I’ve spent on my mobile setup! (I was lucky enough to already have a spare wireless access point I could add to my mobile rig.)

Seablade, if you’re familiar with the MCU already, you might be able to give more input on how TouchDAW compares to the real thing.


Are you using the Behringer profile for the MCU? That might be why your clock doesn’t work, the BCF doesn’t have a clock IIRC so I don’t believe the value is ever updated.

By the way, is this with A2 or A3? From the fact Save works, I am guessing A3. If so it would be worth filing a bug report on the issues you are noticing most likely and see if anyone with a BCF can confirm them, I may be able to check with my MCU at some point as well.


I’ve used the setup just as laid out by Yves in his post. I tried some of the other choices in Ardour for controller early on but had no luck with operations at all. Of course, that was before I got to the level of stability I have now, so it’ll be worth another go once I have the time.

It makes sense that since the BCF has no clock, there’s no update. That’s OK by me, the less traffic that has to be handled, the more reliable things are likely to be.

I’m using Ardour 3.4, downloaded from here as opposed to whatever’s in the Arch repos.

I have a BCF2000 as well, but I’ve never used it in Mackie mode. Perhaps I’m losing a bit of functionality, but it does just what I need so I haven’t really tried anything more.