LSP Artistic Delay and Ardour Startup

I’m having a lot of difficulty on Ardour startup when the LSP Artistic Delay is on an aux channel. The symptom is a loud noise when Ardour starts, just before it puts up its “ready to use” window. The noise sounds like about 1 second of high-pitched Morse code tapping. I have 2 aux buses with LSP Artistic Delay plugins. The noise does not occur if I disable both of these plugins and restart.

I’m running Ardour 6.9.0~ds0-1 on Ubuntu Studio 22.04 LTS, with KDE/Plasma desktop. LSP plugins are version 1.2.15 and are in /usr/lib/lv2/lsp-plugins.lv2. I recopied these from the tarball this morning to be sure they weren’t corrupted. I don’t have any kind of audio interface so I’m using my computer’s sound card. Audio tracks come from a standalone Yamaha hardware recorder/mixer.

I might be doing something illegal - some kind of feedback perhaps -
so I’m including a screenshot of my mixer below. I’m trying to send a stereo audio channel to a long reverb, a quarter-note artistic delay, and a dotted-eighth note artistic delay. With just these two enabled , the short burst of noise is produced when Ardour starts.

The problem gets worse if I try to send the delay aux channels to an x42 plate reverb. Then when I start Ardour I get a one- to two-second blast of white noise that fades away. After that things seem normal.

Can anyone see any issues with this setup? Is there any kind of log that might shed some light on what’s happening? I’d appreciate any suggestions.

BTW I love the LSP Artistic Delay plugin - so completely configurable. I’m thinking I might replace the two instances with a single one using two different delay lines, perhaps that will help.

Well this is typically a symptom of a problem in a plugin, but first things first, have you tried with Ardour 8.4 given that 6.9 is VERY old at this point?


Thank you @seablade for a very fair comment. No, I have not tried it. I’ve been looking at how I might do that. The verbiage on the Ubuntu Studio site has given me pause, but they do provide some backport repos. I also might sign up for the “paid” version - currently 7 and 8 - if I can figure out how to install it and still keep the distro version for all my existing projects that have been mixed on that version.

So you can download even the free trial version from this website and install it that way to see if it fixes the issue. Whether trial or paid though both of those will install in /opt and be completely separate from the distro version. The installation is not difficult and is described here:


@seablade I went ahead and submitted payment to upgrade to 8.4. Long overdue, so thanks for that.

Unfortunately, the problem with the LSP Artistic Delay persists. Still hearing that high-pitched sound just as Ardour starts up, things seem normal after that.

During the install of 8.4 Ardour suggested I check the performance governor on my CPU. I’ll do that but I think it’s already running on “performance”, with the low-latency kernel:

Linux xxxx 5.15.0-101-lowlatency #111-Ubuntu SMP PREEMPT Mon Mar 11 11:10:57 UTC 2024 x86_64 x86_64 x86_64 GNU/Linux

As above I’m also going to try to reconfigure the LSP Artistic Delay to use a single instance of the plugin.

@SadKo You have any thoughts?


More information. With the Artistic Delay channel sent over to the x42 convolver, I still get the blast of white noise during startup. See first screenshot and notice the meters on the x42 and master.

I reconfigured the LSP Artistic Delay to use a single instance of the plugin with the two different delay and panning settings that I want. GUI shown in second screenshot. Prior to this I set my CPU governor to “performance” using the commands

powerprofilesctl set performance
~$ powerprofilesctl get

Another thing I will try is to re-build the entire session starting from scratch. The previous attempts with Ardour 8.4 were using the imported 6.9 session. Maybe it’s contaminated in some way.

EDIT: no change in the behavior in a fresh session created under Ardour 8.4. If I disable the LSP Artistic Delay prior to save-and-quit, there are no noise sounds produced on the next startup and I can re-enable the plugin and use it at that point. If I leave it enabled, save-and-quit, the loud noises occur on the next startup.

I don’t exclude the problem with Artistic Delay. But I need to have simple reproducible case. Maybe some tiny Ardour session where it is reproducible.

Another thoughts: I see the red meters on convolver but don’t see red meters on Artistic Delay’s bus. You also can place some plugin like LSP trigger after the Artistic delay. If artistic delay generates a blast, then you’ll see it on trigger’s oscilloscope graph within 5 seconds.

Thank you @SadKo for your quick reply and suggestions. I added the trigger plugin (nice, as always) and managed to capture a quick screenshot right after the startup of Ardour. Is this what you were anticipating? Couple more bits of information/speculation after the screenshot.

There are two different types of noise artifacts that occur. With the send to the convolver and the convolver itself disabled, the sound is the “fast morse code” - a high pitched burst that sounds like really fast dots-and-dashes. As you can see from the screenshot, this was the setup when the screenshot was taken. Note that most times this will also result in red bars on the Artistic Delay aux bus.

If I turn on the send out of the Artistic Delay and enable the x42 convolver, the noise changes to a very loud blast of “white noise”. This typically results from the setup shown in the screenshot in my previous post. I had been speculating that the change in noise was just the result of the convolver (I was using the “Large Plate” preset) doing its thing on the “fast morse code” noise artifact.

If I disable the Artistic Delay plugin, no noise occurs on startup. Then I can re-enable it and the mix plays normally (and of course sounds better).

I will work on putting together a small test case. Is there a max size you have in mind? What is the best way to get it to you?

Nice. Also would be nice to put additional trigger before the Delay to ensure that there is no such blast at the input of the plugin

I should have thought of that, sorry. Good suggestion.

1 Like

Okay, it really seems that LSP Artistic Delay is generating some garbage.

I’ve created related GitHub issue here:

I’ll try to reproduce the problem soon.

I have this problem only if I do not perform a fresh start of Ardour. This only happens if I close one project and open another without completely shutting down Ardour.
But this is an very old problem in Ardour. Close + Open almost never works here.

I tried to create an empty session, put there Artistic Delay on a bus, save session, close Ardour and load it again. Nothing was generated. @TonyBKDE I think I need more reproducible case.
Also I need more detailed information about your system configuration. What audio driver do you use, what’s your audio buffer size and CPU model (this can be obtained by command cat /proc/cpuinfo)?

Hmm, I’ve inspected the code and found that delay buffer was not cleaned up when the delay line was allocated. That can be the problem if there is a garbage in the delay buffer. I already fixed this in the development branch @TonyBKDE @werner.back are you available to build and test the plugin from the devel branch?

1 Like

/proc/cpuinfo appended below for the first of 8 cores. If the rest would be helpful please let me know. The machine has 32G of real memory and plenty of disk, dual boot Win10+Ubuntu Studio from separate HDDs.

Concerning the test case, I used the archive facility in Ardour but the session archive is still 37 MB because the full audio files are still in the interchange folder. I’m thinking of trying to export just the stems needed to create the issue (about 15 seconds worth), deleting the existing audio tracks, and importing the short stems … Not sure if that will work.

cat /proc/cpuinfo
processor       : 0
vendor_id       : GenuineIntel
cpu family      : 6
model           : 60
model name      : Intel(R) Core(TM) i7-4790 CPU @ 3.60GHz
stepping        : 3
microcode       : 0x28
cpu MHz         : 3606.980
cache size      : 8192 KB
physical id     : 0
siblings        : 8
core id         : 0
cpu cores       : 4
apicid          : 0
initial apicid  : 0
fpu             : yes
fpu_exception   : yes
cpuid level     : 13
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx pdpe1gb rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc cpuid aperfmperf pni pclmulqdq dtes64 monitor ds_cpl vmx smx est tm2 ssse3 sdbg fma cx16 xtpr pdcm pcid sse4_1 sse4_2 x2apic movbe popcnt tsc_deadline_timer aes xsave avx f16c rdrand lahf_lm abm cpuid_fault epb invpcid_single pti ssbd ibrs ibpb stibp tpr_shadow vnmi flexpriority ept vpid ept_ad fsgsbase tsc_adjust bmi1 avx2 smep bmi2 erms invpcid xsaveopt dtherm ida arat pln pts md_clear flush_l1d
vmx flags       : vnmi preemption_timer invvpid ept_x_only ept_ad ept_1gb flexpriority tsc_offset vtpr mtf vapic ept vpid unrestricted_guest ple shadow_vmcs
bugs            : cpu_meltdown spectre_v1 spectre_v2 spec_store_bypass l1tf mds swapgs itlb_multihit srbds mmio_unknown
bogomips        : 7183.79
clflush size    : 64
cache_alignment : 64
address sizes   : 39 bits physical, 48 bits virtual
power management:

Hah, I’ll take a look and see if I can remember how to do that. The last time I tried something like this it was years ago and I chose to attempt to build KDE from source. It didn’t go well … as I recall PulseAudio was a big issue.

I’ve created an Ardour archive containing 15-20 seconds of audio. It’s 4.5 MB. How to get it to you?