Jack Sync in Ardour-6.8?

There used to be an option to use jack transport to sync with other programs (e.g. Rosegarden). What happened to that? I can’t seem to find it anywhere.

You can toggle the “Int[ernal]” / “JACK” via the button top left in the main toolbar under the transport controls.

If the default isn’t set to use JACK, have a look at the following post, that also applies to Rosegarden and explains it step by step in detail:

The menu “sync” from Preferences does not show here. Neither does the Int/Jack switch.

image

image

That switches between Int. and M-C1k. No JACK there.
There might be something wrong with my JACK server, do I have to enable the transport somewhere in qjackctl?

So it seems you’ve used Ardour without JACK in the past which changed the setting to MCLK (MIDI Clock), since JACK was not available.

In that case visit Menu > Window > Transport Masters and pick JACK.

or simply right-click on the “Int” “Mclk” button which opens that window.

I was also having this same problem after upgrading to a new version of Ubuntu Studio (20.04) and installing the latest Ardour version.

The solution is to start by having the transport set to “Int.” From there, right click “Int.” or open Menu > Window > Transport Masters. With Ardour set to “Int.” you should be able to select the other “external” timesources, such as JACK, MTC, LTC, or MIDI Clock (default). If you have “M-Clk” selected when you bring up these controls, these options will be faded out and you will not be able to switch between them.

I hope this helps.

2 Likes

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.