I'm getting no audio signal from Scarlett 2i4 into Ardour 6 on Ubuntu Studio 20.04

I recently installed Ardour 6.0.0 (as a download from the Ardour website) in Ubuntu Studio 20.04. I also have Mixbux32C-6.0.0 and Ardour 5.12 running. Using a Scarlett 2i4, I can easily get an audio signal into Ardour 5.12. However, though I can see the Scarlett in the Mixer setup, I do not get any response in either Ardour 6 or Mixbus32C-6. I checked the routing in both of the latter applications to be sure that I was actually connected to the Scarlett, and it appears that I am. Both Mixbus and Ardour 6 work fine otherwise. How can I fix this?

There must be some confusion here. Ardour 5 and 6 are not significantly different in how they interact with audio hardware. It’s not really clear from what you’ve said here precisely what you’re doing.

  1. Which audio/MIDI backend are you using ? JACK or ALSA ?
  2. If you use JACK, how do you start JACK? Ardour itself, or something else (e.g. qjackctl)?
  3. Are you sure that chose the correct device for whatever backend you’re using?
  4. What do you mean by “I can see the Scarlett in the Mixer setup” ?
  1. I tried both ALSA and JACK, and had the same results.
  2. I started JACK using Ubuntu Studio Controls, then chose JACK in the Audio/MIDI set up screen.
  3. I am sure that I chose the correct device. I had only the Scarlett 2i4 attached, and it appeared as such in the Input Device and Output Device selection boxes.
  4. I thought the the Audio/MIDI setup screen was called the Mixer - I was incorrect. I can see the 2i4 in the Audio/MIDI setup as described in (3) above.

I have successfully used this device with Ardour 5.12 for years, which is why I was surprised that it did not work with Ardour 6. I used the same selections for both Ardour 5 and Ardour 6, as far as I could tell.

@paul One more piece of information. I just tried the Scarlett on Kubuntu, to see if anything in Ubuntu Studio interfered. I saw the same results. I can see the Scarlett with lsusb, and when the Scarlett is attached I get a message that it is attached. However, still no signal. I will be happy to test any fixes that you implement. Should I fill out a bug report?

I am afraid that issues with audio hardware are not Ardour’s domain. There have been many reports of different interfaces breaking with specific kernel versions, or even with specific distribution builds. Ardour plays no role in this - we just open the device and use the device driver to read/write data. There may be some Scarlett (or Ubuntu) users who have some suggestions - but it’s not feasible or time efficient for myself or other developers to go tracking down these system-specific issues that are outside of Ardour’s domain.

You should try a distro like AVLinux or MXLinux to see if you get the same issues. Ubuntu Studio vs Kubuntu doesn’t sound like a fair test given they share the same codebase.

@paul Thanks. I understand. It seems to be a difference in something between Ardour and Ubuntu 20.04. I just tested another USB interface and got the same results. I’m guessing there are some library? version differences between Ubuntu and Ardour. I just read another thread where apparently gcc differences caused problems. I’ll continue checking around to see what I can find to fix it. However, it does not seem to be an ardour problem. One question though, if you don’t mind. I found /etc/ardour5/ but not etc/ardour6/ after installing ardour 6 and while keeping the settings for ardour5. Is this expected? Thanks again for your response.

I think ardour official is installed in /opt

I agree that there won’t be much difference between Kubuntu and Ubuntu Studio. My reason for doing this comparison was to see if it was an Ubuntu Studio problem or a generic Ubuntu problem. It seems to be a generic Ubuntu problem. I think I’ll try MXLinux and see if the Ubuntu Studio controls works in this distribution. The controls allow one to use multiple USB interfaces at the same time, which, from my reading, usually presents synchronization problems. Thanks for the suggestion for other distros. AVLinux now has been suggested at least twice now.

I’m having a slightly analogous problem with Ardour 6 and the Behringer UMC404 interface, which also has midi. No problems initially, starting off with the 4 audio inputs from the Behringer. Midi input from the Behringer also works, once a2jmidid is turned on (in Ubuntu Studio Controls, though it may be necessary to restart Ardour). HOWEVER, once you do that, the audio inputs get “lost” and the Behringer is no longer visible as hardware. Not only that, but to get the audio back again you have to restart Ardour entirely, without a2jmidid, thus without midi, and also recalibrate the latency. Is this a problem with the Behringer, or does Ardour deliberately not combine audio and midi from the same interface?

You got farther than I did. I’ve spent the last two days trying to get any signal at all into Ardour 6 in Ubuntu 20.04. I tested both Scarlett 2i4 and Behringer UMC404. I tried connecting directly, through JACK using qjackctl, and through JACK through Carla. I tried Kubuntu, Kubuntu with Ubuntu Studio ppa added, and authentic Ubuntu Studio 20.04. I installed Ardour 6 from the website, as well as with the Ubuntu Studio ppa. I tried setting the sound card in alsamixer to Scarlett, as well as the other sound cards. I can see (in pulse audio) that the signal is getting into the computer, but it is not making it’s way to Ardour 6. I am lost as to what to do next.

That’s really odd. I don’t think selecting soundcards in Alsamixer would make a difference. As long as you can see the device when you enter the Ardour audio/midi setup page you should be fine. I really do recommend you try either AVLinux or MXLinux just to check it isn’t an Ubuntu issue. If I get a chance later, I’m intrigued enough to install Ubuntu Studio 20.04 on a spare computer to see what happens with Ardour 6 and my own UMC404HD. I will report back.

OK, everything works as expected. Here are the steps I took:

  1. Install Ubuntu Studio 20.04 (amd64) with no further tweaks or installs
  2. Downloaded Ardour 6 from Ardour.org and installed
  3. Ran through Ardour initial setup dialog sticking with defaults

Plugging in the UMC404HD before starting Ardour enables me to see and select it on the audio/midi setup window as an ALSA device. Device correctly monitors either with zero latency with mix dial all the way on “IN” or with small latency with dial all the way at “PB”. Recording works as expected as does playback of the recorded region. It sounds like you are good with all this given you are able to get sound on Ardour 5.12. It also works in JACK mode (be sure to check that the output of Ardour is being routed to the system playback outputs).

In any case, I can’t see any problems with default Ubuntu Studio install followed by Ardour 6 default install. Any problems seem to be from tweaks/installs that you might have personally done since initial install of Ubuntu Studio…

Thanks for the input. I’ll have to try the UMC404HD again. I’ve been doing most of my testing with the Scarlett; there may be a problem with the Scarlett. I have a laptop wit Ubuntu Studio where I did not do any tweaks at all. I’ll test that.

Ardour will use jack midi if the backend is jack for audio as well. If adding a2jmidid is loosing audio, that sounds like either jack is choking (does controls show jack is still running?) or the device alsa driver is not working right or the device itself is doing something funny. The best way to check this is to run Ardour with alsa instead of jack and see if connecting the midi ports to a channel in Ardour still make the audio device have trouble. For this I would start with a fresh Ardour session, add one audio track, make sure audio from this device is showing meter activity in that channel. Then if all is ok so far, add a midi track which will probably auto connect to your midi device, I would make sure the right device is connected in any case. Now, does the audio track still show meter activity with audio input to your device? if so, this seems like a jack problem, either jack’s code (it is a new version) or ubuntu’s version of jack. It could also be a problem with a2jmidid but I don’t think the code for that has changed in some time. (though I guess the libs it is built with may have)
I have personally not had problems with using both midi and audio with jack on the latest ubuntu’s but then I am not using a USB device, both my audio (delta66) and my midi (AudioPCI game plug), are PCI cards from decades ago. However, that would still seem to indicate that the problem is alsa, kernel or device based.
So when the audio goes, do get an error from jack_lsp or does it list the lack ports?

Thanks Len for this suggestion. Doing what you say does indeed work: 1) run Ardour with ALSA, 2) connect an audio track (works), 3) connect a midi track (also works, though not automatically, USB device needs to be selected). So perhaps the answer is not to use jack. Does that have any disadvantages (sorry, that may be a naive question, but i don’t know the answer)?

The short answer is to not use jack. The long answer is that most uses of jack have been replaced by plugins that in the past were stand alone jack applications. Certainly with most windows/macos DAWs there is an all in one approach that works for most people just fine. I expect it should be possible to get jack to work as well but that would require the ability to trouble shoot on your end, with your devices. However, considering ALSA just works for you, why not just use it?

I can confirm:
Focusrite Scarlet 2i2 and 6i6 3rd Gen. both worked just fine with Ubuntu 20.04 LTS + low latency kernel + the usual audio group magic. Ardour 5.12 and Ardour 6.0 both worked out of the box with that interface. Multi track record & playback. I use >90% pure ALSA. But in 10% JACK also worked.

1 Like

What distro are you using? Also, did you use a guitar/mic as input for the 2i2 and 6i6?

If you’re asking me: Distro already mentioned: Ubuntu 20.04 LTS
Yes: I did record Git, Line-In and Mics