How to save X42 plugins presets?

Good afternoon
In Ardour 8.4.0 x42 plugins don’t seem to be saving presets:
This is what i did:

  • Insert x42 eq in channel strip
  • Adjust eq and save preset
  • Save session
  • Remove eq plugin from channel strip
  • Insert new instance of x42 eq
  • try to choose preset but none available
    Am i missing something?

On a side note, I made an animated gif from a screengrab movie to illustrate the issue. The gif file size is 1.7MB in thunar, but when i tried to insert it here I got a file to large, 4MB is max msg!
Must be a bad hair day

Does this work for other LV2 plugins?

Assuming you are using Linux, after saving the preset does it show up in $HOME/.lv2/ ?
There should be a folder ~/.lv2/x42-eq_-_YOUR-PRESET-NAME.lv2/.

If not, could it be that you have set a custom LV2_PATH without a user-writable part?

I just tried ace expander and got the same problem. Theres no x42 folder in ~/.lv2
Heres a screenshot of my .lv2 folder. Im using AVL21.3 and have made no special paths (to my knowledge; I don’t know how to lol)
Many thanks

Side question, what theme are you using for your desktop? And what icon theme?

Well, I don’t know where to start…

  • There are not supposed to be any files in ~/.lv2 only folders (plugin bundles).
    Somehow you managed to have a lot of .ttl files there, which seem to originate from LSP plugins.

  • I have tested the official binary and that can correctly save presets. So the most likely explanation is indeed that some custom LV2 path environment variable is set.

Please check in a terminal window if the following command prints some output:

env | grep LV2

and if this produces output, copy/paste it here.

Since it is AVLinux, it’s likely their custom version of GTK’s “Die Hard” theme. They also provided a matching theme for Ardour: see "Diehard" Colors theme - #11 by GMaq

1 Like

env | grep LV2 and env | grep lv2 produce nothing.
I have never knowingly set any custom paths. I probably installed the lsp
update that came out a while ago. Maybe @SadKo knows why these manifest?
files are here?

the theme is Skeuos-DIEHARD-Dark
The icon theme is Flat-Remix-Orange-Dark
Thats the default for this distro

1 Like

@GMaq Since OP uses AVLinux, can you do a quick test if saving LV2 presets works?

Does AVLinux ship an official Ardour build or does it use debian’s package (with system-wide liblilv)?

ace expander is a-exp.lv2? If that’s the one that comes with the Ardour, then that’s in /opt/Ardour-8.4.0/lib/LV2 (probably).

I think Glen puts things in /lib/lv2. Both should break.

LV2 Presets are saved in the user specific portion of LV2_PATH [1].
By default that is $HOME/.lv2/ (regardless of where the plugin itself is installed).

In the past there were issues when someone set LV2_PATH environment variable and forgot to include a user writable path. But this is apparently not the case here.

Next step would be to find out if there is a general problem with AVLinux, or something specific to @merryl0 's system, which is why I ping’ed @GMaq.

Since it’s not actually Ardour that creates the preset, but liblilv (LV2 library) another test would be to try to use another host (jalv, qtractor) to get a 2nd opinion.

[1] LV2 Filesystem Hierarchy Standard

PS. Could it be that on AVLInux the Ardour start script /usr/bin/ardour8 sets a custom LV2 Path?

@x42 @merryl0

Sorry have been busy offline lately…

For the record Ardour in AV Linux is always the official Ardour binary (on rare occasion a nightly build if a known bug has been fixed) however it is extracted from the original bundle, wrapped in a custom Deb package that installs to /opt because the AV Linux ISO is assembled from Debian Packages. There is no intentional modification of any LV2 paths by me…

If this issue has appeared with Ardour 8.4 I have not Packaged Ardour 8.4 because I only package Ardour for AVL ISO releases and am intending and hoping Users will seek the in-between Ardour releases directly from to support the project.

It appears that @merry10 is using the previous AV Linux 21.3 and I currently don’t have a working install of 21.3 to test with, I can set up a test VM if needed. LV2 Plugins provided in AV Linux are installed system-wide to /usr/lib/lv2…

First, thanks everybody whose chipping in. Qtractor has saved a lv2 preset.
What should i try now?

hi Glen
I am still on 21.3 because i wasn’t sure if all the pipewire work is finalised. Is it now completely ready (as can be)? If it is, I have a brand new SSD drive ready to be set up with the new version.

I have had some problems using Ardour and wanted to get these all sorted out before moving on, in case of new issues adding to my confusion. :exploding_head:
Many thanks

I installed ardour 8.4.0 on debian 12 and the lv2 presets saved. Also on that computer the ~/.lv2 contains only folders and no loose files.

Is there a command I can write on my AVL machine to fix the path?
Many thanks

FWIW, I’m running AVLinux MX-21, Ardour 8.4.0 (official), and I successfully saved x42-eq settings:

$ ls -l .lv2/x42-eq*
total 8
-rw-r--r-- 1 aaron1 aaron1  487 Feb 26 07:17 manifest.ttl
-rw-r--r-- 1 aaron1 aaron1 2477 Feb 26 07:17 MyHiMid.ttl

total 8
-rw-r--r-- 1 aaron1 aaron1  487 Feb 26 07:17 manifest.ttl
-rw-r--r-- 1 aaron1 aaron1 2477 Feb 26 07:17 MyLoMid.ttl

EDIT: I went the extra mile as well, removed the eq, saved, exited, came back in, re-added the eq, and the presets were available.

EDIT2: And I’m just trying to help debug it :slight_smile:


Thanks for the info! Is it possible to test an LSP Plugin (if you still have them installed?)


Pipewire on AVL 23 is as complete as I can make it and in the MX 23 Test Repo are the latest versions of PipeWire if people want the very latest. There are mixed reviews on the new AVL Enlightenment Desktop Environment and I hope to release an updated ISO in the next couple of weeks to help smooth the transition with feedback I have gotten since the new version was released.

AVL 21 is still a viable release to use if you are happy with everything else, PipeWire is a concession to the current state of Linux Audio, not necessarily a progressive leap forward for Pro Audio work. I exclusively use Ardour with ALSA backend so I see no benefits at all personally…

I don’t know whats happened to my .lv2 folder
I’m sure I wouldn’t have gone in it and started deleted many subfolders, or putting in a whole set of loose manifest files.

Thanks Glen
I like AVL21 and am happy to keep it
I just did a test with lsp lv2 compressor and it seems to save/export its files by default to the desktop with a .cfg suffix, which then can be reloaded.
This seems very different from other lv2s on my system and I never normally save anything on the desktop

I have LSP 1.2.10.

I am able to save presets, although the LSP “save” option confused me for a second.

$ ls -l .lv2/LSP*
total 12
-rw-r--r-- 1 aaron1 aaron1 4158 Feb 26 07:59 16DoubleHi.ttl
-rw-r--r-- 1 aaron1 aaron1  513 Feb 26 07:59 manifest.ttl

total 12
-rw-r--r-- 1 aaron1 aaron1 4153 Feb 26 08:00 16HiLo.ttl
-rw-r--r-- 1 aaron1 aaron1  505 Feb 26 08:00 manifest.ttl

EDIT: And I see merryIO got confused on that as well :slight_smile: merry is using the LSP “save” option, not the little plus box on the top.