How to install ardour 5

i just downloaded ardour 5.4.0 64, i am running ubuntu 16.04 the file downloaded into my downloads file, it wan’ts to open in (gedit) i don,t know what gedit is and the file extension is .run…whats going on?


The terminal just stays still. Here is what I get,

Without parentheses

I did put in the parenthesis, check the screenshot

Thanks telover, just needed to remove the <,> signs.

I just downloaded Ardour 5.6 and followed the install instructions on I get “permission denied” when I try to run the file. I’m new to linux and I’m new to having to use a terminal to initiate an executable. Why is that even necessary! Help.
linux Mint 17. Strangely in the linux mint software center there is an Ardour version 1.4.6 that downloads fine, without the terminal. Ugh

The instructions in the first time linux do actually explain this:

Because Linux is a secure operating system in general, files you download are not automatically runnable as programs.

You are apparently not following the instructions, which tell you to run the command inside a shell: /bin/sh ./<DOWNLOADED_FILENAME>.run

The “permission denied” message occurs when you try to run the file directly, which Linux (and other sane Unix-based operating systems) will deny for security reasons.

Ok, I’ll try to “run the command inside a shell”. I suppose the understanding of shells and bins and UNIX syntax is supposed to come to us non-programmers in a dream we missed. :0
Thanks for the quick response.

No, you’re not supposed or required to understand it. The security of modern computer systems relies on such simple things as “the user cannot execute programs downloaded from the internet without them taking some extra steps to show that they deliberately intend to do that”. Nobody expects you to know how to use a Unix shell, which is why we give you the commands to you to make it work. The way that users would understandably like this to work - download, double click to execute, maybe be shown a warning - has been implemented on OS X / MacOS, which is also a Unix system, but that has not been done yet for Linux, which generally remains more suspicious of downloads than OS X is.

To be honest the syntax shown was confusing such as; "is that the entire path? Should /bin/sh/ be proceeded with home or oem, or more? And why is there a suspicious space between /sh ./. Likely an error I presume. And why couldn’t Ardour accommodate the executable similarly as “mintinstall” cues me for my password when I enter the software center? And thirdly if security of permissions is so damn important (undoubtedly it is) then why can’t a user ascertain what level they are at at any given time via a “VISUAL CUE”. for instance… “You Are Here” sort of thing. And if a user gets a message that says “permission denied” or I can’t run the executable, then why couldn’t the brilliant Linux programmers of yore expounded on the problem with more informative warning boxes? Is there a limit on word count? A warning box with ten words instead of two solemn words, “Permission Denied”. For example “Permission denied” BECAUSE you are not a super-user or in or out of a bin or, some additional information that is informative? By the way I’m giving you a freebie glimpse into the mind of a non linux user who considers the parlance maddening and unfamiliar and the presumption from so many tekkies that if they speak Swahili then everyone should understand Swahili is equally maddening. I’ve learned that Linux fixes are easy to find via a quick search but invariably the solutions on forums are provided by the Swahili speakers themselves and the solutions are spoken in short, geekspeak sentences and involves the terminal and the anal UNIX parlance. I can’t help but wonder if the Linux universe is forever cursed into a constricted and terminal market, a curse that is self-imposed by the members themselves. I want Ardour to work I don’t want to go back to Windows and Abelton Live. This is an experiment and I’m certain there are many more like me. Whew… Thanks for getting this far, I realize this is not the venue to vent like this but, there you go…

Linux, to the extent that it can be talked about as a monolithic entity, decided long ago that it wasn’t going to get involved with the kind of high level user interaction that happens on OS X when you double click on a downloaded application. So there’s no chance that anything that like will be common to all Linux systems.

The problem with Linux is that a user’s system is not defined by the Linux kernel, but by the user-level decisions made by the particular distribution that the user has chose to use. So, yes, there are things we could do that will work nicely on Ubuntu. But they wouldn’t work on Arch Linux, or some others. And vice versa naturally. As developers of Ardour, we have almost zero interest in trying to formulate per-distribution solutions, so we do the best we can to come up with that work across every variety of a Linux system.

This necessarily tends to lean towards the one thing common across Linux systems: the shell. Yes, this tends to be more confusing to non-technical users. But then we (or at least) I have a whole separate philosophical rant about that, which isn’t particularly relevant to this context. As an aside: if you moved to a country where they spoke Swahili, then insisting that everything should work for you even though insist on only speaking English might be viewed as slightly odd by many people. Linux isn’t “cursed into a constricted and terminal market”, but asking it to abandon the things that have made it so powerful for the existing users seems … strange. I totally understand that someone who wants to use a DAW on Linux sees no reason why they need to deal with shell syntax, but the reality is that your life on Linux is going to be improved if you can embrace the idea that the command line is your friend and not you enemy.

marty85901: I understand your frustration, I can still remember my first times trying out Linux years ago. However when you start to use a new system there is always some learning involved. Graphical applications on Linux behave much like on any other platform, but the commandline is a different kind of beast and it takes some effort to understand why and how things work there like they do.

The reason you have a version of Ardour available in Mint repository and another one here on is that Ardour source code has been licensed so that anybody can take it and build a version of Ardour with it and distribute it. That is exactly what Linux Mint has done (or Ubuntu since Mint uses software packages made by Ubuntu). Ardour depends on many libraries and their exact version and you never know what Mint folks used while building. The version of Ardour you get from is built by Ardour developers and is guaranteed to be built with the right dependencies. Only the version from is supported by Ardour developers.

I wish to help you on your journey to Linux so here are a couple of other things you need to know:

  • Realtime audio requires that some operating system settings are configured correctly, generic Linux distros like Mint or Ubuntu don’t do these optimizations. So when you are through testing Ardour and decide to do some real work with it, you probably want to download a Linux distro that is specifically built for realtime audio. The most popular ones are KX Studio and AVLinux.

  • The commandline (terminal) is quite frustrating when you begin to use it, since it doesn’t give you any hints about how to use it. I suggest you spend some time learning it and here is one quite good guide for it:

The only thing I don’t agree with the tutorial author is his choice of text based text editor. He talks about a program called vi, but that is a bit too hard core for a beginner and I suggest you learn a program called nano instead. Guide for it here:

On Linux the fastest and sometimes easiest way to do some things is with the terminal that’s why we still use it. It also allows one to automate different tasks on the computer in a way that is never possible with graphical applications, this is another reason terminal refuses to die.

I hope you can be patient while learning Linux, give it some time and effort and you won’t regret it. Don’t hesitate to ask if you have questions :slight_smile:


To run the Ardour bundles without using a terminal 2 conditions must be met:

  1. That permissions thing, giving permission for the Ardour ‘.run’ file to be executed. In most file managers when you right-click on a file and select ‘Properties’ you should encounter some sort of multi-tabbed dialog (it varies with different File Managers) that has a ‘Permissions’ tab, this tab should have some sort of tick box when you can ‘execute file as a program’ or something similar. So if you don’t want to set execute permissions in a shell go to ‘Properties’–>‘Permissions’ in your File Manager and do it there…

  2. Some File Managers are set by default to not allow just clicking on a shell script and letting it run for the safety reasons Paul elaborated upon, however for other File Managers they either allow executing shell scripts by default when you double-click on them (once the permissions for the file are set in step 1.) or they can be changed in their preferences to allow this. To have this ‘just work’ in the future Google “how to execute shell scripts in {INSERT NAME OF YOUR FILE MANAGER HERE}” and you should find instructions on how to achieve this.

Once you’ve done these prerequisite steps you will no longer need to use the terminal to install/update Ardour bundles, simply download, right-click on downloaded file to set execute permissions in the File Manager, then double click on the downloaded ‘’ file to run the install.

Wow, three awesome, helpful responses. I thought I might get blasted. Mhartzel I am going to get right on vetting the best distro. I chose Mint for newbie reasons but if KXStudio or AV Linux function better for sound production then I need to make the change quickly before wasting time. What I’m building is intended to be a music machine first and foremost. I did notice that the version of Ardour I downloaded a while back from the Mint repository came with Jack yet I read on that Jack is “recommended”. Does that mean that Jack is not bundled in this Ardour 5.6 download I just received from
Thanks again Gents, Paul GMaq and Mhartzel.


JACK is not included in the Ardour bundle, it is a separate package handled by your distribution. JACK is ‘recommended’ because it offers the ability to connect other JACK-aware programs to and from Ardour. If you plan on running Ardour monolithically (ie Just using Ardour itself with the plugins it hosts internally) then JACK is not necessary and Ardour will run quite happily using it’s ALSA backend.

I am also the maintainer of AV Linux, you can download it and burn the ISO to a bootable USB key to try it with your computer without making any changes, AV Linux is very performance oriented and specifically tailored for Audio and Video work, but it is not as newb friendly as Ubuntu and Mint, to mitigate that somewhat I’ve written an extensive User Manual which may be helpful generally for getting started with Linux Audio. KXStudio is a great choice also and is something that can be added to and existing Ubuntu, Mint, or Debian distro so you may find you don’t need to leave what you are comfortable with to get an improved Audio experience.

Some Resources:
AV Linux Manual:
KXStudio Repositories:
LibreMusicProduction, great tutorials!:–-beginners-guide-getting-started-jack

I’ve tried racking up all dependencies for the Ardor 5.12 installation.
I test in a clean installation of Lubuntu 17.10 and it worked very well without any errors.


  1. Create a folder in your [home]. In my case, I created a [Programs] folder inside my [home] folder and then unzipped the files inside another folder [Ardour5]. In short, it looks like this:
    [/home/MyUser/Programs/Ardor5/], but you do as you want.

  2. Download the Ardor 5.12 Source Code and unzip it into the Ardor 5 folder.

  3. Download the file here at this URL

  4. Copy this file into the [Ardor5] folder with others Ardour files.

  5. Open the terminal pointing to the folder and execute:
    [sudo chmod + x ./] and then [sudo ./].
    It will take a while, depending on the speed of your internet connection and will probably work fine.

I hope I’ve helped.

sorry for my bad english

When i write the command, a message appears saying like " syntax error near the sign << ( >> "

Hey there,
im another noob, trying to get ardour 5 started.
I dont know linux very vell, nor did i ever really manage the terminal stuff…

So, i downloaded the ardour installation file.
When i try to start it, it says sth like:
too many arguments
I tryed a lot of different spellings and stuff, but i cant figure out my fault…
Sorry for my stupidity and thanks for help =)


/bin/sh ~/Downloads/