how to instal Jamin under OSX

I discover possibility, how to install Jamin under OSX. It sounds very promissing, so I want to try it, but I find no way, how to install. Can anybody help me?

I want to use it with Ardour; or is possible to use it as “standalone”?



I’ve been running Jamin, Ardour, JACK and LADSPA on OS X pretty regularly over the past year. There are DMG installers for JackOSX and Ardour on their respective websites. Hidden somewhere on the Ardour site are also some DMGes for most of the LADSPA plugins as well.

JAMin is the only one that you need to be a bit nerdy to install. However, once you get it installed it runs fine. The only bug is that you can’t send preset change messages from Ardour to it. I was writing to Jesse Chappel about fixing it, and he worked on it for a night with me but we didn’t resolve the problem yet. My suggestion is this:

  1. Make sure you have X11 and all the Apple Developer tools installed already. You might need this XCode stuff too, I’m not sure.

  2. Download and install Fink and the Fink Commander app:

  3. Use Fink to install the following (if there aren’t there already):

Please note that not all of these might be needed, but there are the ones I noticed that I have installed while cross-checking the JAMin installer notes for it’s dependencies. The whole install process should be fairly simple with Fink Commander. If you get errors later on, it might be necessary to tell Fink Commander to use “unstable” or “testing” packages. At least that is what I did on my system, so you might start by doing that and save yourself headache later :wink:

  1. Install the package for the SWH plugins:
    I’m hoping that you don’t need the actual source code and headers for it, but if you do you’ll have to download the source and try to compile that as well:
    tar -xvzf swh-plugins-0.4.15.tar.gz
    cd swh-plugins-0.4.15
    make install

  2. You 'll need to have the JACK sourcecode and headers installed. Download the latest version here:
    Then, as root in the terminal:
    tar -xvzf jack-audio-connection-kit*.tar.gz (for the "", use the TAB key to autocomplete)
    cd jack-audio-connection-kit

    make install

  3. Download the JAMin source code:

  4. Here’s where the fun really starts. Make sure you are root first. Then, in the terminal:
    tar -xvzf jamin-.tar.gz
    cd jamin-

    make install

Now, if I or you have forgotten anything, you’ll get errors at any one of these stages. Read the messages carefully. Sometimes you might need to add some lines to ./configure to help it find the dependencies (i.e. one of the apps were installed to get this far). If there is still something missing after “./configure”, then “make” will give an error. If it does, first try to see if it’s a missing package you can install with Fink. If that doesn’t work, copy the line into Google and let it do some magic for you.

Two problems I ran into helping someone else install Jamin on OSX were these:

  1. PKG_CONFIG_PATH: pkg-config was having a hard time finding JACK. The solution for us was typing this in the terminal before compiling Jamin (it’s all one line!):

export PKG_CONFIG_PATH=/sw/lib/pkgconfig:/usr/lib/pkgconfig:/usr/local/lib/pkgconfig:/usr/X11R6/lib/pkgconfig

  1. LADSPA_PATH: getting Jamin to find the LADSPA directory was also a pain. It seems that the X11 shell doesn’t take PATH variables from any standard place that I could find, so the only solution for my friend was to make the following script:

Start by typing the following:


and in that file, enter:

#! /bin/bash
export LADSPA_PATH=/Library/Audio/Plug-Ins/LADSPA/

Then save and exit. You may need to adjust the location of jamin in the last line of the script if you installed jamin someplace else. Also, notice that in this case, the person didn’t compile his own LADSPA plugins, but was using them from a DMG file from the site. Your PATH to the LADSPA plugins may be different. Mine is /usr/local/lib/ladspa, for example. Use “locate ladspa” in the terminal to find out where your plugins are hiding.

After saving this script, type the following to make it executable:

chmod +x

And whenever you want to start Jamin, type:


If someone has a more elegant solution to this problem, espc if they know where the X11 takes its PATH settings from, please let me know! Incidentally, on the system where I compiled and installed my own LADSPA plugins, I did not have to use this workaround.

You might also send an email to JAMin dev list, although I just checked and nobody there seems to know much about OSX:

Good luck!

I am not used to the terminal nor programmation. I used in the seventies to program on hard cards when I was a student… I then started Personal Computing mid eighties on a Macintosh Plus, forgetting the archaic lines of code of DOS. I am testing ARDOUR 2 beta 8 on my G4 1,3 Ghz. I would like to try JAMIN linked to ARDOUR for editing/mastering purpose. However, I cannot trace any OS X binary. Would any member of the Ardour community issue one day a JAMIN 0.95.0 OS X universal binary dmg?

JAMIN OSX Univ Binaries when?

Maybe you should talk to the Jamin team. They are different people not on the Ardour team.

Just had a look at the code relating to the plugin directory. The relevant bits are in src/plugin.c

plugin_path = “/usr/local/lib/ladspa:/usr/lib/ladspa”;

I guess if you change that to:

plugin_path = “/usr/local/lib/ladspa:/usr/lib/ladspa:/Library/Audio/Plug-Ins/LADSPA/”;

before you compile, you could avoid the shell script.


I have a Universal Binary of Jamin on my hard drive… Don’t know where the hell i found it. :wink:
I can upload it on a server if you want. I think it’s allowed ?

Please do! I could use really use it.

I am fairly new to unix and tryed to install jamin to my mac . But it always come up with this error :
tar (child): jamin-*.tar.gz: Cannot open: No such file or directory
tar (child): Error is not recoverable: exiting now
tar: Child returned status 2
tar: Error exit delayed from previous errors

I don’t realy understand, I followed all the instruction and this happen . Can somone enlighten me .

I didn’t compile that, but i think that the the * in jamin-*.tar.gz means the version.

did you do a

tar xvzf jamin-*.tar.gz


in this case, you could try

tar xvzf jamin-0.95.0.tar.gz

Cheers for that , unfortunatly it didn’t work either , I am to sure what to do . Maybe it is because I didn’t root properly, I have "su root " . If anyone has any idea , please let me , cheers.
Do I have to start any apps for it to launch ? thanks .

That will be great , let us know where to find it ,
thanks a lot

It’s here :

So I even don’t have to upload it anywhere.
Please excuse me for answering soooo late…

Thanks Willy2406 I tryed it it seem to work .

Installed like a charme - but I can’t see any text - i just see blocks- otherwise it seems to work.

Any idea what I’m doing wrong ?

BTW I’m using OSX 10.3

I am having the same prob as gastric, I am running 10.4

It works well on my macbook on 10.4

What does a
into the terminal ?

this is the output of the program starting: (I’ve cut the errors on the end - looks like every element is showing the same warning when rendered)

2008-01-06 11:45:17.267 defaults[408]
The domain/default pair of (.GlobalPreferences, AppleCollationOrder) does not exist
jamin 0.95.08
© 2003-2005 J. Depner, S. Harris, J. O’Quin, R. Parker and P. Shirkey
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details.
jackd 0.101.3
Copyright 2001-2005 Paul Davis and others.
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details

JACK compiled with POSIX SHM support.
loading driver …
jamin: JACK server started
theme_init() called from internal clearlooks engine

(jamin:375): Pango-WARNING **: No builtin or dynamically
loaded modules were found. Pango will not work correctly.
This probably means there was an error in the creation of:
You should create this file by running pango-querymodules.

(jamin:375): Pango-WARNING **: pango_shape called with bad font, expect ugly output

(jamin:375): Pango-WARNING **: pango_font_get_glyph_extents called with bad font, expect ugly output

(jamin:375): Pango-WARNING **: pango_font_get_metrics called with bad font, expect ugly output

(jamin:375): Pango-WARNING **: pango_font_get_font_map called with bad font, expect ugly output

(jamin:375): Pango-CRITICAL **: _pango_cairo_font_map_get_renderer: assertion `PANGO_IS_CAIRO_FONT_MAP (fontmap)’ failed

(jamin:375): Pango-WARNING **: _pango_cairo_font_install called with bad font, expect ugly output

gastric_bass, you don’t have pango (one of the dependencies for JAMin) installed.

I’ve already installed the following pango packages with fink (after the installation and experiencing the problems):
pango1 1.2.1-25
pango1-dev 1.2.1-25
pango1-shlibs 1.2.1-25
pango1-xft2 1.6.1-1
pango1-xft2-dev 1.6.1-1
pango1-xft2-shlibs 1.6.1-1

But that didn’t help either - any ideas ?