high resolution displays

Because of Ardour I was finally able to ditch os x and I migrated over to debian but I ran into some technical difficulties when setting up Ardour.

I did an apt-get install ardour and it seems to be version 2.8.16 and it’s not scaling well on low my device screen. I have a 15" macbook pro from last year.

How can I grab the latest versions? Can I add and updated repo or something like that?

I always buy and download Ardour directly from ardour.org. It’s the best way to get the best version. :slight_smile:

I am a supporter and I can download the version from this site as well. I guess i’ll just do that, although I did read that if you keep updating ardour they will install alongside each other. Like version 4.0 and version 4.2 and version 4.4 can all live on the same machine.

Since ardour is a .run file that I chmod to install, i’ll just have to use the same run script to uninstall but running ./Ardour_xxx.run --help I don’t see any uninstall commands. How do I remove an older version when updating?


Ardour’s own bundles from ardour.org install to the ‘/opt’ filesystem folder, there should be an uninstall script in /opt for each version you have installed… Debian Ardour packages would install/uninstall using the usual Debian packaging tools. If you are using Debian (Jessie or Testing) for audio I very strongly suggest adding and using the KXStudio repos for up to date Ardour and plugin versions.


Hi again,

*added note. For the best support I would recommend using the builds from ardour.org and if you subscribe better yet! But the KXStudio repos are also an invaluable resource :wink:

Scalability for HighDPI Displays started with Arodur 4.1; some details there are still work in progress, but this mainly concerns initial scaling on some systems before the user gets to manually adjust things using the preferences.

Debian is in the transition. Soon “ardour” will refer refer to the latest version (it already is for debian/testing): https://packages.debian.org/search?keywords=ardour
For now on debian/stable you can install “ardour3” package, that’s still rather old though. Ardour4 was released shortly after the freeze for debian/jessie, bad timing.
Still debian packagers do a great job, it’s usually less than a day from a release until ardour enters debian/sid and most desktop systems run testing so 5-6 days. They also properly triage bugs: If you use debian’s package, please report bugs to debian, we cannot take responsibility for those; particularly if you combine it with plugins.

KXStudio ships official upstream binaries, so bug reports can go directly to tracker.ardour.org

I installed ardour 4.4 from this website download. KXStudio has a lot of nice tools for audio but I didn’t add their repo yet.

Right now I am looking into setting up pinning so I can pull from testing/ experimental w/o totally destroying my install… I’ve done that once already.

On to the real question. With 4.4 where exactly is the scaling info? Trying to look at the ardour window it’s uper tiny maybe 8 inches diagonally when I launch it, I’m basically going from memory to create a project but I can’t really find any settings related to dpi.

Edit > Preferences > GUI > GUI and Font scaling

Ardour scales all of its elements relative to the default desktop font size. The assumption is that default font on HiDPI systems is larger (but that’s not true for all systems).

No problem, here’s some screenshots: http://imgur.com/a/5Et6P

You can see the second to last image the size of the piano roll and the size of the mouse pointer when hanging out on the timeline.

The last picture is a screenshot of the display resolution.

ahh yes, the pianoroll is not yet scaled, I think step-entry keyboard is not yet as well.

“to the max” wow. that must be an UltraHiDPI screen :slight_smile: Would you mind taking a screenshot? That will be helpful to see which parts are not yet scaled.

I am using debian 8 Jessie with gnome 3.14, everything else looks fine. I found the HiDPI setting, put it up to max, the UI looks a lot better but the piano roll looks a bit awkward when you maximize the midi track. For now that’s not a big deal though, thanks for the help.