Help! Crash on session load after syncing with Hydrogen

Using Ardour 7.2.0 on Debian GNU/Linux 11 (bullseye) (AVLinux)

I followed these instructions to run Hydrogen along with Ardour.

I successfully recorded some drum tracks. Then suddenly my session crashed. Now when I try to open it, it freezes during load. I get to the editor, but the tracks won’t load and then the program crashes. These are my Jack logs:

JackFreewheelDriver::ProcessSync: SuspendRefNum error
JackAudioDriver::ProcessGraphSync: ProcessWriteSlaves error, engine may now behave abnormally!!
JackPosixProcessSync::LockedTimedWait error usec = 426660 err = Connection timed out
JackEngine::ClientDeactivate wait error ref = 7 name = ardour
JackEngine::ClientKill ref = 7 cannot be removed from the graph !!
JackAudioDriver::ProcessGraphSync: SuspendRefNum error, engine may now behave abnormally!!
Cannot write socket fd = 38 err = Broken pipe
CheckRes error
Could not write notification
ClientNotify fails name = ardour notification = 10 val1 = 19 val2 = 0
Cannot write socket fd = 38 err = Broken pipe

I opened other sessions and they work fine, so my guess is it has to do with the configuration changes I made to work with Hydrogen.

Alas JACK logs are not useful.

If Ardour is crashing, please read

Thank you Paul.
I followed the instructions from the article, everything worked as expected except for

Once Ardour crashes the GUI will not disappear, but it will freeze and stop redrawing itself

My system freezes, then Ardour crashes and the GUI dissapears. Only then I can interact with the terminal again. This is the output that was printed in my terminal by gdb

Starting program: /opt/ARDOUR-7/bin/ardour-7.2.0 
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/".
Ardour7.2.0 (built using 7.2 and GCC version 6.3.0 20170516)
[New Thread 0x7ffff61eb700 (LWP 12071)]
Ardour: [INFO]: Your system is configured to limit Ardour to 4096 open files
Ardour: [INFO]: Loading system configuration file /opt/ARDOUR-7/etc/system_config
Ardour: [INFO]: Loading user configuration file /home/nevinson/.config/ardour7/config
[New Thread 0x7fffe25ff700 (LWP 12072)]
Ardour: [INFO]: CPU vendor: GenuineIntel
Ardour: [INFO]: AVX-capable processor
Ardour: [INFO]: AVX with FMA capable processor
Ardour: [INFO]: CPU brand: Intel(R) Core(TM) i5-8250U CPU @ 1.60GHz
Ardour: [INFO]: Using AVX and FMA optimized routines
[New Thread 0x7fffe1dfe700 (LWP 12073)]
[New Thread 0x7fffe15fd700 (LWP 12074)]
[New Thread 0x7fffe0dfc700 (LWP 12075)]
Ardour: [INFO]: Loading plugin meta data file /opt/ARDOUR-7/share/plugin_metadata/plugin_tags
Ardour: [INFO]: Loading plugin statistics file /home/nevinson/.config/ardour7/plugin_metadata/plugin_stats
[New Thread 0x7fffcabff700 (LWP 12076)]
[Thread 0x7fffcabff700 (LWP 12076) exited]
[New Thread 0x7fffcabff700 (LWP 12077)]
[New Thread 0x7fffc6bff700 (LWP 12078)]
[New Thread 0x7fffc4fff700 (LWP 12079)]
Cannot xinstall SIGPIPE error handler
Ardour: [INFO]: Loading default ui configuration file /opt/ARDOUR-7/etc/default_ui_config
Ardour: [INFO]: Loading user ui configuration file /home/nevinson/.config/ardour7/ui_config
Ardour: [INFO]: Loading 454 MIDI patches from /opt/ARDOUR-7/share/patchfiles
Ardour: [INFO]: Loading color file /opt/ARDOUR-7/share/themes/xcolors-ardour.colors
Ardour: [INFO]: Loading ui configuration file /opt/ARDOUR-7/etc/clearlooks.rc
Ardour: [INFO]: Loading bindings from /opt/ARDOUR-7/etc/ardour.keys
Loading ui configuration file /opt/ARDOUR-7/etc/clearlooks.rc
[New Thread 0x7ffff41ff700 (LWP 12080)]
[New Thread 0x7fffb7fff700 (LWP 12081)]
[Thread 0x7fffb7fff700 (LWP 12081) exited]
[New Thread 0x7fffb7fff700 (LWP 12082)]
[New Thread 0x7fffb6fff700 (LWP 12083)]
[New Thread 0x7fffb67fe700 (LWP 12084)]
[New Thread 0x7fffb5ffd700 (LWP 12085)]
[New Thread 0x7fffb57fc700 (LWP 12086)]
[New Thread 0x7fffb4ffb700 (LWP 12087)]
[New Thread 0x7fff9bfff700 (LWP 12088)]
[New Thread 0x7fff9b7fe700 (LWP 12089)]
[New Thread 0x7fff9affd700 (LWP 12090)]
[New Thread 0x7fff9a7fc700 (LWP 12091)]
[New Thread 0x7fff99ffb700 (LWP 12092)]
Found nothing along /home/nevinson/.config/ardour7/templates:/opt/ARDOUR-7/share/templates
Announcement is: Version 7.5 has been released. Update at
[Thread 0x7ffff41ff700 (LWP 12080) exited]
[Thread 0x7fff9affd700 (LWP 12090) exited]
[Thread 0x7fffb4ffb700 (LWP 12087) exited]
[Thread 0x7fffb57fc700 (LWP 12086) exited]
[Thread 0x7fffb67fe700 (LWP 12084) exited]
[Thread 0x7fff9bfff700 (LWP 12088) exited]
[Thread 0x7fff99ffb700 (LWP 12092) exited]
[Thread 0x7fff9b7fe700 (LWP 12089) exited]
[Thread 0x7fff9a7fc700 (LWP 12091) exited]
[Thread 0x7fffb6fff700 (LWP 12083) exited]
[Thread 0x7fffc4fff700 (LWP 12079) exited]
[New Thread 0x7fffb6fff700 (LWP 12093)]
[New Thread 0x7fff9a7fc700 (LWP 12094)]
[Thread 0x7fffb5ffd700 (LWP 12085) exited]
[Thread 0x7fffb6fff700 (LWP 12093) exited]
[New Thread 0x7fffb6fff700 (LWP 12095)]
[New Thread 0x7fffb5ffd700 (LWP 12096)]
[New Thread 0x7ffff3d45940 (LWP 12097)]
[Thread 0x7fffb6fff700 (LWP 12095) exited]
VST3 not a valid bundle: '/usr/lib/vst3/AuburnSounds/Auburn Sounds Lens.vst3/Contents/x86_64-linux/Auburn Sounds'
[New Thread 0x7fffb6fff700 (LWP 12099)]
[New Thread 0x7fff9b7fe700 (LWP 12100)]
[New Thread 0x7fff99ffb700 (LWP 12101)]
[Detaching after vfork from child process 12102]
[New Thread 0x7fffb67fe700 (LWP 12103)]
[Thread 0x7fffb67fe700 (LWP 12103) exited]
[Thread 0x7fff9b7fe700 (LWP 12100) exited]
[Thread 0x7fffb6fff700 (LWP 12099) exited]
[Thread 0x7fff9a7fc700 (LWP 12094) exited]
[Detaching after vfork from child process 12109]
[New Thread 0x7fff9a7fc700 (LWP 12110)]
[Thread 0x7fff9a7fc700 (LWP 12110) exited]
Set cursor set to default
[New Thread 0x7fff9a7fc700 (LWP 12111)]
[New Thread 0x7ffff39fe940 (LWP 12112)]
[New Thread 0x7ffff397a940 (LWP 12113)]
[New Thread 0x7ffff35fe940 (LWP 12114)]
[New Thread 0x7ffff357a940 (LWP 12115)]
[New Thread 0x7ffff31fe940 (LWP 12116)]
[New Thread 0x7ffff317a940 (LWP 12117)]
[New Thread 0x7ffff30f6940 (LWP 12118)]
[New Thread 0x7ffff34f7700 (LWP 12119)]
[New Thread 0x7fffb67fe700 (LWP 12120)]
[Thread 0x7fff99ffb700 (LWP 12101) exited]
[New Thread 0x7fff99ffb700 (LWP 12121)]
[New Thread 0x7fffb6fff700 (LWP 12122)]
[New Thread 0x7fff9b7fe700 (LWP 12123)]
[New Thread 0x7fff5ffff700 (LWP 12124)]
[New Thread 0x7fff65e30700 (LWP 12125)]
[Thread 0x7fff9a7fc700 (LWP 12111) exited]
[Thread 0x7fff65e30700 (LWP 12125) exited]
[Thread 0x7fff5ffff700 (LWP 12124) exited]
[Thread 0x7fff9b7fe700 (LWP 12123) exited]
[Thread 0x7fffb6fff700 (LWP 12122) exited]
[Thread 0x7fff99ffb700 (LWP 12121) exited]
[Thread 0x7fffb67fe700 (LWP 12120) exited]
[Thread 0x7ffff34f7700 (LWP 12119) exited]
[Thread 0x7ffff30f6940 (LWP 12118) exited]
[Thread 0x7ffff317a940 (LWP 12117) exited]
[Thread 0x7ffff31fe940 (LWP 12116) exited]
[Thread 0x7ffff357a940 (LWP 12115) exited]
[Thread 0x7ffff35fe940 (LWP 12114) exited]
[Thread 0x7ffff397a940 (LWP 12113) exited]
[Thread 0x7ffff39fe940 (LWP 12112) exited]
[Thread 0x7ffff3d45940 (LWP 12097) exited]
[Thread 0x7fffb5ffd700 (LWP 12096) exited]
[Thread 0x7fffb7fff700 (LWP 12082) exited]
[Thread 0x7fffc6bff700 (LWP 12078) exited]
[Thread 0x7fffcabff700 (LWP 12077) exited]
[Thread 0x7fffe0dfc700 (LWP 12075) exited]
[Thread 0x7fffe15fd700 (LWP 12074) exited]
[Thread 0x7fffe1dfe700 (LWP 12073) exited]
[Thread 0x7fffe25ff700 (LWP 12072) exited]
[Thread 0x7ffff61eb700 (LWP 12071) exited]
--Type <RET> for more, q to quit, c to continue without paging--

Then I tried tried typing <RET> , c and also with thread apply all bt. In either case the output was

Program terminated with signal SIGKILL, Killed.
The program no longer exists.

Typing q produced

(gdb) Quit
Couldn't get registers: No such process.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.