Help! Crash on load - Can't load my session anymore

Using Ardour 6.0.0 on Ubuntu 20.04 LTS. With ALSA drivers (No Jack).
Worked on this session for several days. It survived multiple opens/closes.
Neither Sound nor MIDI setup changed in theses days.

Now loading my session gives me this:
image

In the console I see this:

wok@thinkpad:~$ Ardour6
Ardour6.0.0 (built using 6.0 and GCC version 6.3.0 20170516)
Ardour: [INFO]: Your system is configured to limit Ardour to 1048576 open files
Ardour: [INFO]: Loading system configuration file /opt/Ardour-6.0.0/etc/system_config
Ardour: [INFO]: Loading user configuration file /home/wok/.config/ardour6/config
Ardour: [INFO]: CPU vendor: GenuineIntel
Ardour: [INFO]: AVX-capable processor
Ardour: [INFO]: CPU brand: Intel(R) Core(TM) i7-6600U CPU @ 2.60GHz
Ardour: [INFO]: Using SSE optimized routines
Ardour: [INFO]: Loading plugin meta data file /opt/Ardour-6.0.0/share/plugin_metadata/plugin_tags
Ardour: [INFO]: Loading plugin meta data file /home/wok/.config/ardour6/plugin_metadata/plugin_tags
Cannot xinstall SIGPIPE error handler
Ardour: [INFO]: Loading default ui configuration file /opt/Ardour-6.0.0/etc/default_ui_config
Ardour: [INFO]: Loading user ui configuration file /home/wok/.config/ardour6/ui_config
Ardour: [INFO]: Loading 449 MIDI patches from /opt/Ardour-6.0.0/share/patchfiles
Gtk-Message: Failed to load module "canberra-gtk-module"
Ardour: [INFO]: Loading color file /opt/Ardour-6.0.0/share/themes/dark-ardour.colors
Ardour: [INFO]: Loading ui configuration file /opt/Ardour-6.0.0/etc/clearlooks.rc
Ardour: [INFO]: Loading bindings from /home/wok/.config/ardour6/ardour.keys
Loading ui configuration file /opt/Ardour-6.0.0/etc/clearlooks.rc
Found nothing along /home/wok/.config/ardour6/templates:/opt/Ardour-6.0.0/share/templates
Scanning folders for bundled LV2s: /opt/Ardour-6.0.0/lib/LV2
Set cursor set to default
 loading from ... templ  is_new 0 bp 0
Butler drops pool trash

Log Messages:
INFO: AlsaAudioBackend: adjusted output channel count to match device.
INFO: AlsaAudioBackend: adjusted input channel count to match device.
INFO: harvid version: 803
INFO: Loading menus from /opt/Ardour-6.0.0/etc/ardour.menus
ERROR: Unexpected exception during session setup: tr1::bad_weak_ptr

Then Ardour closes…

I tried:

  • Check other sessions. OK: All my other stored project’s sessions load great without a hic-up. Some more complex, some less complex as this one…
  • I rebooted. No help
  • I unpluged all devices. Then replugged all devices. At no avail…
  • I tried to load the session “Safe Mode: Disable all plugins”
  • I tried to create a new session: OK, works

I know: I might file a bug… (and I will do if encouraged)…

My current short-term desire is just to load my project.

Any hints how I can workaround?

WOK

PS.: the other message I posted here


(I exchanged my audio interface) might imply that the story over there is related to the crash story above. But the change of the audio interface actually happened almost 3 weeks ago. The crashing session was created after that date. And loaded fine including yesterday. Just starting today the session keeps crashing on load.
:frowning:

If not, create an issue on Mantis (tracker.ardour.org) and post a link to this thread/describe your problem, and post your session file.

  Seablade

@derwok You should be able to change audio interfaces in the middle of a project without problems. It might require some rerouting thought. I think you might have hit a bug.

I routinely record jams with my friend with Behringer UMC1820 and mix those sessions with Alesis IO4. This works with no problems on Ardour 5.12.

OK. I filed a bug.
Let’s see if devs can rescue my lost work…
https://tracker.ardour.org/view.php?id=8227

Make sure you keep an eye on there, it looks like Robin/x42 has already identified the issue and posted a working version of the session for you to continue using, please test and provide feedback on the tracker, and thanks for the bug report!

      Seablade

Yes! ROBIN RULEZ!
It loads again. Sigh!

Root cause seemed to be a “MIDI learned” pitch bend that did not even work after assigning.
But anyhow got saved in the session and then caused trouble during loading.

WOW! I would call that premium service!
On top of my 6.0-release donation ($60 sic!) I will now happily also opt-in to a subscription.