Font changed to ugly serif-mono

I’ve just installed Kubuntu, then Ubuntustudio packages, and finally KXStudio repositories and meta-packages.
After upgrading Ardour to KX version, or for some reason, I’m not sure, font turned to mono, which is very hard to read.
I can’t change within Ardour. Anybody experienced same issue?

Hi rafael,

maybe have a look at ~/.config/ui_config. You can try to change fonts by changing the value fields in these lines. BUT if it simply says “italic” there and you get a monospaced font then maybe this has been changed somewhere in the system settings. Have you looked at KDEs Control Center?

thank you,
I don’t have ui_config. I also tried in the control center, but no success. Ardour AFAIK is the only soft having this issue.

any idea? It’s very hard to work in these conditions.
Also, I have to wait more than 1 minute to get session-manager, I don’t know if it’s related.

It could be an issue with the packaging of Ardour for your distribution. Have you tried uninstalling Ardour from the KX repositories and installing the demo version from this site to see if the problem is present in the official binary?

I tried, but still have my serif-mono. Then I uninstalled by the script, reinstalled from repo, purged all, reinstalled, but didn’t change the font.
(I didn’t reinstalled ardour-data, which comes from ubuntu repo and is not required by ardour package from KX)

Maybe a distribution issue? In system configuration, all system font are listed and no one is like that.

And still 30’ to get the session window

Do not install Ardour from KX repo: it’s outdated and now unmantained. Reinstall the package from Ubuntu repo instead (use a variant of the latest Ubuntu LTS, 18.04).

BTW: you likely have an outdated version of the KX repos configured. Check here:

1 Like

Just because it seems relevant, I had the same issue when I was using the KX repo version of Ardour, so seems likely to be the cause.

1 Like

It is obviously caused by some corruption in the aforementioned ~/.config/ardour5/ui_config. Open it in an editor, find the “Canvas” section and check the Option name=“font” values. They all must be like “ArdourMono 7”, “bold ArdourMono 11”, “italic ArdourMono 14.5”, etc. If they are just like " 7" or “bold 11” you’ll have weird fonts.

It seems ok, I post it, maybe you can check:
<Canvas> <Option name="small font" value=" 7"/> <Option name="smaller font" value=" 6"/> <Option name="normal font" value=" 8"/> <Option name="big font" value=" 11"/> <Option name="large font" value=" 14.5"/> <Option name="larger font" value=" 19"/> <Option name="huger font" value=" 27"/> <Option name="massive font" value=" 48"/> <Option name="small bold font" value="bold 7"/> <Option name="smaller bold font" value="bold 6"/> <Option name="normal bold font" value="bold 8"/> <Option name="big bold font" value="bold 11"/> <Option name="large bold font" value="bold 14.5"/> <Option name="larger bold font" value="bold 19"/> <Option name="huger bold font" value="bold 27"/> <Option name="massive bold font" value="bold 48"/> <Option name="small italic font" value="italic 7"/> <Option name="smaller italic font" value="italic 6"/> <Option name="normal italic font" value="italic 8"/> <Option name="big italic font" value="italic 11"/> <Option name="large italic font" value="italic 14.5"/> <Option name="larger italic font" value="italic 19"/> <Option name="huger italic font" value="italic 27"/> <Option name="massive italic font" value="italic 48"/> <Option name="small monospace font" value="ArdourMono 7"/> <Option name="smaller monospace font" value="ArdourMono 6"/> <Option name="normal monospace font" value="ArdourMono 8"/> <Option name="big monospace font" value="ArdourMono 11"/> <Option name="large monospace font" value="ArdourMono 14.5"/> <Option name="larger monospace font" value="ArdourMono 19"/> <Option name="huger monospace font" value="ArdourMono 27"/> <Option name="massive monospace font" value="ArdourMono 48"/> <Option name="small bold monospace font" value="bold ArdourMono 7"/> <Option name="smaller bold monospace font" value="bold ArdourMono 6"/> <Option name="normal bold monospace font" value="bold ArdourMono 8"/> <Option name="big bold monospace font" value="bold ArdourMono 11"/> <Option name="large bold monospace font" value="bold ArdourMono 14.5"/> <Option name="larger bold monospace font" value="bold ArdourMono 19"/> <Option name="huger bold monospace font" value="bold ArdourMono 27"/> <Option name="massive bold monospace font" value="bold ArdourMono 48"/> </Canvas>

I have the repositories from .deb on KX site. I get an error when opening muon, that I have to “validate” something. I’ll check further…

FalkTX started again maintaining KX repos:

I had the same issue. Just rename the (at /opt/ardour/lib/) to


:thinking: Could it be related to this post? You can try running Ardour from terminal to see if that’s the problem.

I tried this and it works very well; thank you for sharing! :smiley: So it might be related to that conflict with fontconfig.

1 Like

Great, it works! thank you. And it also solved the launch delay issue.

About KX repo: with apt-get update, it gave me an error about repo name changed, that I have to “fully accept”. I made “sudo apt update”, then it asked me y/n. Solved… (but how to mark it?)

1 Like