extracted the ardour-2.8.tar.bz2 file, now what....? What file should i run?

How do I run the program after I extracted it?

just cd to it in a terminal and run “scons” (run scons --help to see aditional options)
after a little while of compiling :slight_smile:
run “scons install” as root or sudo

Hello it’s good to know there are communties that still help each other like this.

but through all the tutorials and how-to’s I can not get passed the ./configure step.

I have it all unpacked in a folder on the Desktop

[root@localhost ardour-2.8]# scons --prefix=/usr -j3
bash: scons: command not found

[root@localhost ardour-2.8]# scons --prefix=/usr -root
bash: scons: command not found

[root@localhost ardour-2.8]# scons–prefix=/usr -root
bash: scons–prefix=/usr: No such file or directory

[root@localhost ardour-2.8]# ./SConstruct
bash: ./SConstruct: Permission denied

[root@localhost ardour-2.8]# SConstruct --prefix=/usr -j3
bash: SConstruct: command not found

[root@localhost ardour-2.8]# sudo SConstruct install
sudo: SConstruct: command not found

[root@localhost ardour-2.8]# ./scons
bash: ./scons: No such file or directory

[root@localhost ardour-2.8]# .sconstruct
bash: .sconstruct: command not found

[root@localhost ardour-2.8]# ./sconstruct
bash: ./sconstruct: No such file or directory

[root@localhost ardour-2.8]# ./SConstruct
bash: ./SConstruct: Permission denied

There is no file name configure, install, or scons there is a SConstruct file and when i looked inside of it, it begins with python and when i installed this distro of ydl 6.1 i made sure the dev tools were installed.

I’m sure you linux gurus are laughing at this poor rookie, I did give it 2 days worth of effort lol

btw I am running YDL6.1 KDE Desktop enviroment on a PS3 so i don’t even know if the program will function correctly due to the PPC64 Cell proc. instructions and x86, but i really wanna try cause i have’nt been able to get Reason to run correctly.

thanks for any info, i’ll keep looking.

[root@localhost ardour-2.8]# scons–help
-bash: scons–help: command not found
[root@localhost ardour-2.8]# scons --help
-bash: scons: command not found

Am i missing a dev package or something?

and if i am i’m kinda sol

cause my package manager utility is not working normally and under the browse tab nothing comes up just under the list tab.

is there other way to manage packages other than this add/remove programs app.

you are going to have a lot of package installation to do…
remember to install also the aditional -dev packages

It seems like you are missing the package scons itself. Search for that one in your package manager.

What you downloaded is the raw source code, you will have to compile it yourself to run. Not a hard task but an extremely tedious one. If you are new to linux, you might want to look in the repositories of your linux distro if they have an ardour package there for you, that will be the simplest and safest way to go, although it can be a bit older and maybe with some few bugs.

Or, to answer your question:
Open a terminal and do the following:
go to the directory where you extracted the .tar.bz2 file:

cd /home/alfdavid/ardour-2.8 (enter the correct path)
scons --prefix=/usr -j3
sudo scons install

this will build ardour (the second step, it can take very long, go grab coffee)
then it will install it (the sudo scons install step) it will ask you for a password.
you can also install “checkinstall”, which can be found in synaptic. If you have checkinstall, you can do the last step like this:
sudo checkinstall scons install

this will create a package, which you can manage with synaptic.


@roaldz: Not the whole linux word uses ubuntu/debian…
What if he’s on Mandriva, openSUSE, Fedora or (heaven forbid :wink: Slackware?
And the dependencies?

With that kind of question I think it’s better to start with using a precompiled package rather than directly entering the grim netherworlds of compiling.

If he used slackware, would he be asking the question?

Maybe he asked on the Slackware forum: “I got this DVD, now what…?” :wink:

I’m sorry for my debian-centric point of view, but you have to admit, the chances are big he’s using Debian-like OS. Wanna bet? haha


so i went to get scons and i found out I did’nt have python either so i got it, and install scons, but i have to go back to support page here cause i don’t have the right dependecies.

Making some headway.

I got pretty far on all the dependencies now i have hit a road block

looking at my dl load in firefox
i had to get the following

those i got install completely i think, i do all the steps and then i cpoy the .pc file into the usr/share/pkgconfig directory., that has seemed to work so far but i dowonload the libfftw3-dev file i can’t install it, and the fact that it has 2 options i386 and amd64 makes me worried that i will not work on this system.

thanks for help so far i know fell safe in compiling and installing from source.

I got all the libaries and i guess i did not extract to the right place and i failed again. More difficult than i thought and i guess this Distro of linux is very lacking and I’m not bright enough to use yum the right way i guess.

libs/ardour/audio_library.cc:137: error: ‘lrdf_statement’ was not declared in this scope
libs/ardour/audio_library.cc:137: error: ‘head’ was not declared in this scope
libs/ardour/audio_library.cc:138: error: ‘pattern’ was not declared in this scope
libs/ardour/audio_library.cc:139: error: ‘old’ was not declared in this scope
libs/ardour/audio_library.cc:144: error: expected type-specifier before ‘lrdf_statement’
libs/ardour/audio_library.cc:144: error: expected `;’ before ‘lrdf_statement’
libs/ardour/audio_library.cc:154: error: ‘lrdf_uris’ was not declared in this scope
libs/ardour/audio_library.cc:154: error: ‘ulist’ was not declared in this scope
libs/ardour/audio_library.cc:154: error: ‘lrdf_match_multi’ was not declared in this scope
libs/ardour/audio_library.cc:159: error: ‘lrdf_free_uris’ was not declared in this scope
libs/ardour/audio_library.cc:171: error: type ‘’ argument given to ‘delete’, expected pointer
scons: *** [libs/ardour/audio_library.os] Error 1
scons: building terminated because of errors.

Now I’m truly lost.

Ok. Before we go any further, what distro of linux are you using and the version please?

Yellow Dog Linux 6.1 on a PS3

I redid all the dependcies through yum because i learned how to add more repos to my list. So I did everything completely except aubio that does’nt seem to work and i believe i only have fftw3 not the -f precision. well i went to build ardour again and this is what i got.

scons: *** [libs/fst/fst.o] Error 127
scons: building terminated because of errors.
[root@localhost ardour-2.8]#

looked it up said it was related to my python version which is currently

Python 2.6.2 (r262:71600, May 18 2009, 08:17:07)
[GCC 4.1.2 20071124 (Red Hat 4.1.2-42)] on linux2

So I’m Lost again. almost there, still not bad for a complete rookie on linux.

makes me miss windows and it’s double click to install lol.

do you have python-dev package installed?
Remeber you not only install the main packages required to run but you also need to install all the same packages to for development, they all end usually with -dev

Here’s a list of packages needed to compile ardour, some are extras, but don’t hurt to install, most are ardour-jack specific, don’t worry about the letters in parenthesis, just try to look for the same name, and closest version (the list is extracted from my ubuntu OS), try to install as many as possible and see what happens:

libasound2-dev (1.0.15-3ubuntu4)
caps (0.4.2-1)
jack (3.1.1+cvs20050801-21)
jack-tools (0.0.2-4.1ubuntu1)
jackd (0.109.2-1ubuntu1)
libasound2-plugins (1.0.15-1ubuntu3)
libsdl-image1.2 (1.2.6-3)
meterbridge (0.9.2-6ubuntu2)
python-cddb (1.4-5.1build1)
python-eyed3 (0.6.14-1)
python-pyogg (1.3-1.1ubuntu4)
python-pyvorbis (1.3-1.2ubuntu2)
qjackctl (0.3.2-1ubuntu1)
tap-plugins (0.7.0-2)
vorbis-tools (1.1.1-15ubuntu0.1)
autotools-dev (20070725.1)
comerr-dev (2.1-1.40.8-2ubuntu2)
g++ (4:4.2.3-1ubuntu6)
g+±4.2 (4.2.3-2ubuntu7)
ladspa-sdk (1.1-6)
libart-2.0-dev (2.3.20-1)
libatk1.0-dev (1.22.0-0ubuntu1)
libboost-dev (1.34.1-4ubuntu3)
libcairo2-dev (1.6.0-0ubuntu1)
libcurl4-openssl-dev (7.18.0-1ubuntu2)
libexpat1-dev (2.0.1-0ubuntu1)
libfftw3-dev (3.1.2-3ubuntu1)
libfontconfig1-dev (2.5.0-2ubuntu3)
libfreetype6-dev (2.3.5-1ubuntu4)
libgail-dev (1.22.1-0ubuntu1)
libglib2.0-dev (2.16.3-1ubuntu3)
libgnomecanvas2-dev (
libgtk2.0-dev (2.12.9-3ubuntu4)
libice-dev (2:1.0.4-1)
libidn11-dev (1.1-1)
libjack-dev (0.109.2-1ubuntu1)
libjack0.100.0-dev (0.109.2-1ubuntu1)
libkadm55 (1.6.dfsg.3~beta1-2ubuntu1)
libkrb5-dev (1.6.dfsg.3~beta1-2ubuntu1)
libldap2-dev (2.4.9-0ubuntu0.8.04)
liblo0 (0.23-2.1build1)
liblo0-dev (0.23-2.1build1)
liblrdf0-dev (0.4.0-1build1)
libpango1.0-dev (1.20.1-1)
libpixman-1-dev (0.10.0-0ubuntu1)
libpng12-dev (1.2.15~beta5-3)
libraptor1-dev (1.4.16-1)
libsamplerate0-dev (0.1.2-5ubuntu1)
libsm-dev (2:1.0.3-1)
libssl-dev (0.9.8g-4ubuntu3.3)
libstdc++6-4.2-dev (4.2.3-2ubuntu7)
libtool (1.5.26-1ubuntu1)
libxcomposite-dev (1:0.4.0-1)
libxcursor-dev (1:1.1.9-1)
libxdamage-dev (1:1.1.1-3)
libxext-dev (2:1.0.3-2build1)
libxfixes-dev (1:4.0.3-2)
libxft-dev (2.1.12-2ubuntu5)
libxi-dev (2:1.1.3-1)
libxinerama-dev (2:1.0.2-1build1)
libxml2-dev (2.6.31.dfsg-2ubuntu1)
libxrandr-dev (2:1.2.2-1)
libxrender-dev (1:0.9.4-1)
libxslt1-dev (1.1.22-1ubuntu1)
python2.5-dev (2.5.2-2ubuntu4)
scons (0.97.0d20071203-1ubuntu1)
x11proto-composite-dev (1:0.4-2)
x11proto-damage-dev (1:1.1.0-2build1)
x11proto-fixes-dev (1:4.0-2ubuntu1)
x11proto-randr-dev (1.2.1-2)
x11proto-render-dev (2:0.9.3-2)
x11proto-xext-dev (7.0.2-5ubuntu1)
x11proto-xinerama-dev (1.1.2-4ubuntu1)
xml2 (0.3-1.1)
zlib1g-dev (1:
aubio-tools (0.3.2-2ubuntu1)
libaubio-dev (0.3.2-2ubuntu1)
libaubio2 (0.3.2-2ubuntu1)
python-aubio (0.3.2-2ubuntu1)

If you really are a rookie I’m impressed you got this far.

Have you checked if YDL maybe have Ardour packaged already? Then it’d be as easy or even easier than Windows to install it.

Re: python, you don’t need python-dev but Ardour is somewhat picky about scons/python versions. On Ubuntu 1.2.0/2.6.2 seems to work and IIRC 1.1.0/2.5.2 on openSUSE worked as well.
Here’s some info from other YDL users : http://ardour.org/node/2336 , http://ardour.org/node/1668