Dragonfly Reverb

Hi all, many of you have already heard about this elsewhere, but in case you haven’t…

Dragonfly Reverb is a free concert hall style reverb. It is mainly intended for acoustic instruments and vocals, but I would certainly love to hear if anybody likes how it sounds for other types of music. For anybody who has used Hibiki Reverb, this is built on the same algorithms, so much to the extent that you can consider it almost the same plugin, but with a new user interface that is hopefully much easier to use.

I’m just about ready to make an official v1.0.0 release, I just need some folks to test it on a variety of platforms and to let me know if they experience any bugs. Please find the release candidate here:



I’m sorry @Michael_Willis, I can’t do that. No issues so far. It works just fine (Linux 64bit), is very robust and nice sounding too! Thanks also to @rghvdberg.

1 Like

Works, builds etc, with ubuntu 18.04. Sounds clean and one could forget it is there… I am guessing that is the idea :slight_smile:
Re: the readme says one of the deps was libgl1-mesa-dev (scratch all that, I found it. searching for libgl1* doesn’t get it searching for mesa did)

Nice reverb with well-chosen presets and controls. Just tried it on heavy rock drums and it sounds pretty good. (Linux 64bit on Debian 9 amd64).

Currently my favorite reverb. Pretty versatile. Love the presets. Works like charm here:
[root@arch ~]# uname -a
Linux arch 4.18.16-arch1-1-ARCH #1 SMP PREEMPT Sat Oct 20 22:06:45 UTC 2018 x86_64 GNU/Linux

I just made a slight update:

Dragonfly Reverb 1.0.0-RC2

In this version, the presets don’t control the dry/early/late sliders. I had some folks tell me that they prefer to have a 100% wet reverb bus that gets mixed into the dry signal elsewhere. They found it a pain that they would set the dry to 0% and set the early and late to taste, only to have the dry pop back up and the early/late drop back down when they picked another preset.

This also changes the way that the early reflections algorithm is parameterized, hopefully the early reflections can be mixed in at a higher level now without sounding too harsh.

Let me know what you think!

I notice that the 1.0.0 tarball does not have a configure or waf command, just a Makefile. I get this when trying to build on Fedora 29, and from the package names in the README file it appears that this was primarily based on a Debian derived system. Any guess what is happening here?
]$ make
Makefile:7: dpf/Makefile.base.mk: No such file or directory
make: *** No rule to make target ‘dpf/Makefile.base.mk’. Stop.

So I look in dpf to see why the make include file is not there:
$ ls dpf

Hmmm…did I not untar correctly?
$ tar -tzf 1.0.0.tar.gz | grep dpf

Does not seem to be any files included in dpf directory in tarball.
Should I be using 1.0.0-rc3 instead of 1.0.0? Pull from master instead of using 1.0.0 tarball?

DPF is git submodule. Those are not included in auto-generated snapshots by github. The easiest way it to just clone the repo and get the submodules from there:

git clone --recursive git://github.com/michaelwillis/dragonfly-reverb.git

And yes, there is no configuration step required, just make.

x42 is correct, the source archive that Github auto generates does not include the submodule. I don’t understand the reasoning for this, but I did create a source package that includes the dpf project:


Building it for Linux should just be make

Thanks for following up on that so quickly. I’m not at my machine at the moment, but I was able to grab the new source and build remotely, looking forward to getting back to my desk so I can hear it.
Do I understand correctly from looking at the build output that there is a standalone executable, a linux vst plugin, and an LV2 plugin? Or is the DragonflyReverb file something other than a stand along application?
This looks like fun, I like zita-rev1 well enough but I’ve been looking for something with a different character to try out. Now I just need to win a large game of chance so I can quit the day job to play with reverbs and ardour development builds every day…

Do I understand correctly from looking at the build output that there is a standalone executable, a linux vst plugin, and an LV2 plugin? Or is the DragonflyReverb file something other than a stand along application?

Yes, that is correct, the Linux build results in LV2, VST, and a stand-alone app that you can wire up to other stuff with JACK.

Now I just need to win a large game of chance so I can quit the day job to play with reverbs and ardour development builds every day…

Ha! You and me both! I actually have spent some time daydreaming about whether I could make a decent living out of audio dev.


The late tail in Dragonfly is actually a derivative of zita. If I remember right, the freeverb3 library refers to it as “zita2”. It has some additional parameters added that can either smooth out the tail, or make it shimmer.

Just a remark that the jack standalone app is primarily there for debug reasons. When developing with dpf it circumvents the need for a plugin host.

A new experimental feature has been released:

This introduces a new dial that controls the decay time independent of the room size.

1 Like

Dragonfly works just great on Manjaro KDE 5.14.3. Really great plugin and good job :smile:

1 Like

Has anyone tried version 1.1.4 in Ardour 5.12 yet? I am trying to load the plugin after compiling and get an error dialog with the message “The plugin “Dragonfly Reverb” could not be loaded. See the Log window for more details (maybe)”
The Ardour log gets no new entries at that time.

I’m using the latest dragonfly in Ardour 5.12. Please let me know more details: CPU, OS, whether you are trying to run the VST or LV2, and whether you downloaded the binary or compiled from source. I’ll see what I can do.

OK, I will dig into more details. I compiled from source, downloaded the 1.1.4 zip file from the github repository server, added the latest DPF files also from github ( DPF-150c099e1b6e8c184e39be08776e34be1aa0db3f copied into dpf sub-directory of the dragonfly-1.1.4 source) and ran make. Using gcc (GCC) 8.2.1 20181215 on Fedora 29 (64 bit on several years old Xeon processors). First try was on Fedora compiled Ardour 5.12, will also try on my pre-6.0 build, and ardour.org build of 5.12 later. Using KDE as desktop environment, Radeon graphics card.

The stand alone jack version works, sounds very nice, so I suspect there is just some incompatibility in my compiled lv2 version for some reason. I just copied the DragonflyReverb.lv2 directory from the bin directory into /usr/local/lib64/lv2, it is detected there but
Is there any other component other than DPF which is involved in the lv2 build?

I will also check the VST version, hopefully I will get time later tonight. I didn’t think to try that yesterday, I was having fun playing with the jack version then had to go do something else, I just wanted to check to make sure there wasn’t some known issue in 1.1.4 which was going to be addressed in a follow up.
Depending on what I find with the VST I’ll follow up with what I can figure out about my LV2 problem.

Started same version of Ardour tonight, and the same Dragonfly LV2 file loaded with no problems. The only thing I can think is that something about logging out last night and logging in again tonight setup a path or environment variable which did not get updated right after I had compiled the plugin and copied it to my local/lib64/lv2 directory. All’s well that ends well, I guess, but it bugs me a little that it wasn’t obvious why it would not load before.

It is just perfect for an acoustic recording I was trying to touch up. An old recording of acoustic guitar, electric guitar, acoustic drums and voice in a pretty small room. Just a touch of “small clear hall” preset gave it a little extra depth and cohesion that it was missing before, so thanks for that.

That’s weird, I’m not sure of any environmental dependencies that would cause the plugin to fall like that and then work after reboot. At least it’s good to hear that you got it working. I’m curious about this guitar/drums/vocal arrangement, if you’re willing I would like to hear the before and after.

I didn’t even reboot, I just logged out of the graphical desktop environment and logged back in the next day.