Creative X-fi USB card input setup

Hi All,

I am trying hard to connect the X-fi card to Jack so that Ardour can find it but am not having much luck.

Jack (using qjackcrl) settings shows the device Hw2.0 and I set that to input, reset the jack server but all Ardour sees is the default capture1/capture2 devices of my laptop …

How do I get it to see the device

I have a screen shot of Jack but I don’t know how to post it…


I dont use qjackrl, cadence is much easier to use (kx studio repos or kx studio distro) but are you sure that hw2.0 is your x-fi card?

Also how many inputs does it have? the inputs and outputs to my knowledge are always called playback x and capture x regardless of what interface you are using.

its hard to debug without any information

Not to worry, I worked it out. Seems that setting input to the device does not help, you have to have the interface set to the device.
Also, re-starting the Jack server was not enough, you had to restart Ardour.

On another issue, being new to Ardour I find the use of regions confusing. If I just want to record a section and listen back to it, my natural impulse is to drag the
red bar back to the start of the region, but it just bounces back to where it was … huh? How the heck do I play what I have recorded?

I just can’t get it? It’s so complicated, I have read and re-read the manual and I can’t see how to do the simple task of playing a region just after I have recorded it.
I have tried selecting the region and setting it as the loop, and all I get when I do a loop play is the red bar/cursor continue. No matter what I do I can’t get
the red cursor back to the start … so frustrating … why is it so hard.

@ebike what you are describing is symptomatic of a bug in Jack IIRC, I would suspect you are on Jack2, whereas Jack1 generally tends to be better behaved.

Jack and Ardour are separate but closely intertwined. The next version of Ardour will be less so, but the best performance will likely still come from a proper working Jack as well, though I am not sure any tests have been done. At any rate that is why you need to exit Ardour AND Jack in order for those changes to take effect. It is posisble to do it with only stopping Jack by using various options in Ardour, but probably best you become familiar with Jack before doing that.


@seablade Thanks for that. Do you have any comments for how to play back regions as above? I am still having problems.
Also, recordings show a red box instead of the waveform while recording even though the VU meter is reading quite low … are these bugs too?

Anyone? … this is ridiculous, how can this be so hard …

One way to move the playhead is to move the mouse cursor to where you want the playhead and hit ‘p’ on your keyboard.
But there are lots of settings for how the user interface works, like mouse modes and the definition of the edit point, and it may be that you have Ardour in some mode you’re not expecting. Look at for a start, but maybe look around there in adjacent sections of the manual too.

The red box is normal while recording. There should be some waveform appearing in the box as well. If it’s just a thin horizontal line your recording level is bit too low!

ardour wont let you change the playhead position if your still recording.

Stop transport. then up near the top where all the markers are it says timecode. click where you want the playback to start from and then press play.

Also as ahahata said p will move playhead to mouse location.

if you want to loop a selection, change mouse mode to range selection and now you can drag across the region to select the part you want to loop, right click it then select loop range. it will loop till you stop it.

Bellow the playback buttons is the mouse mode buttons, hover over them and it will tell you what each one is and what there shortcut key is. rangemode should be ‘r’ key.

I still cannot move the playhead reliably to the start of the region. Sometimes if I put the cursor to the start of the region and hold the P key down, it will eventually stay there after flashing back and forth. If I just hot P once, it just flashes then stays put at the end of the recording.

Highlighting the region with the mouse and trying to play loop does not work … the playhead just stubbornly plays from the end …

Do I have an issue with my copy of Ardour? it is version 2.8.12

… also while recording the VU meter is showing correct level of peaking at 0VU, but the recoding trace shows on red, no waveform, not even a line …

Short version, this suggests multiple issues…

One> 2.8.12 is out of date, even for the 2.x branch which is up to 2.8.16 I believe.
Two> The fact you are out of date suggests you may have gotten it from a distro repository, Ubuntu perhaps? I would strongly suggest the binary on this website.
Three> I would strongly suggest using the 3.x series, or even a nightly build these days, there is a huge difference and MANY MANY issues fixed, we are almost up to Ardour 4 at this point, there are literally thousands of changes.


Thanks Seablade …

So I tried building the latest from git and got stuck on the configure stage not finding alsa … which is most definetely installed …

The error is in the log:

/usr/bin/pkg-config alsa --cflags --libs
Package alsa was not found in the pkg-config search path.
Perhaps you should add the directory containing `alsa.pc’
to the PKG_CONFIG_PATH environment variable
No package ‘alsa’ found

there is no alsa.pc on my platform … (elementary OS built on Ubuntu 12.04 base)


Thanks, that version works much better. Can finally play a region I record without issues.

I do notice that soon as I add a track the built-in microphone is routed straight to my speakers and I get massive feedback. Why is this the default? and
how do I get monitoring to stop.

And also go to Preferences > Audio and set monitoring to “hardware monitoring”.

Your audio interface is configured incorrectly to allow Ardour to do monitoring, because it has a feedback loop set up inside (typically caused by setting the capture source to be the playback output). Neither Ardour nor JACK change the hardware settings of your device(s) in this regard - to fix it you need to use a device control utility app. For generic PCI audio interfaces, alsamixer (command line, in a terminal) or gamix or qamix (both GUI) are options. For other types of of audio interfaces, you need to use a device specific application.

I am totally confused!! I have my Sound gui settings (which I believe uses Pulseaudio) then I can run alsamixer and setup alsa, then I have all the monitoring options in Ardour … someone tell me what I should do? I have all capture sources turned down.

Now I am in a position that I have no playback when I hit play, yet the microphone still feedbacks when I turn it up … arrrrhh

Thanks for your patience … I would really like to get this package useable …

In my experience, the best fix for any sound problems where Pulseaudio is involved is to uninstall Pulseaudio.
At least while you are looking for a solution to your problem, because it could be adding confusion, but consider removing it permanently where you’re using Ardour, because it is tricky to get Pulseaudio and Jack working well together.

It is not necessary to remove PulseAudio.

It is necessary to understand that on many Linux distributions, using both PulseAudio and JACK often causes problems. If you do not want to grapple with this, then you need to use a Linux distribution that gets this right. Otherwise, you need to understand what your distribution has done wrong and fix it. This is especially true if you only plan to use the single builtin audio device present on your computer, because by default PulseAudio is going to “own” it. In theory, when JACK asks to use it, PulseAudio will release the device and switch its output to JACK. But on many distributions this still does not work, 7 years after the design was first implemented.

FYI folks, I don’t think the issue is Pulseaudio in this case, from the description he HAS audio working, he is just trying to prevent feedback when enabling recording on his mic.


I would strongly suggest getting on IRC (Help>Chat in Ardour or the links at the bottom of any page on this website) so that you can chat in realtime and explain what you are experiencing. It is most busy daytime EST, but there are people on across the globe, just log in, describe your situation and ask your question, then wait for a response which could take minutes or hours before someone that can try to tackle that sees it, so if it isn’t answered relatively quickly I recommend keeping the IRC window open in the background and checking it regularly.

My suspicion is that you are running into some of the newer monitoring options in A3 and it is confusing you a bit and oyu just need it explained, but I am not sure, and an IRC discussion could sort this out far faster than forums.