Connecting Hydrogen and Guitarix to Ardour

I am using a Behringer audio interface, i connected the interface to my laptop, connected hydrogen via a2j to ardour, and guitarix head amp to ardour. Ardour is recognising the input, i am getting a feedback, but when i start recordng, it still gives feedback, and recognises the input but records nothing.
Am i missing something?

One thing to note is that Hydrogen supports JACK. You can change the “Audio System” in the preferences.

Perhaps you didn’t understand my querry. Guitarix ‘is’ connected to ardour. I have got the feedback sound. but as i click the record button and run, i still get the sound i created on guitarix, the master track shows audio connection and feedback. but it records nothing!

Can you please walk me through how to make the connections properly?
Like how would you proceed if you had to record your guitar from scratch.

Thank you

Are you making sure to arm the individual track for recording (and not just press the master record button towards the top of the screen)? You will need to arm that track in order for it to record any of the input it’s receiving. See https://manual.ardour.org/ardours-interface/audio-midi-mixer-strips/

Follow up on the above…after you record-arm the individual track, THEN you can press the master record button towards the top of the screen. It’s a 2-step process.

Yes i did that! Still nothing!

Hi @Abhigya. I was referencing the a2j comment which I assumed was ALSA to JACK, but I’m wrong about that, sorry.

Back to the question at hand. It would be helpful so see some screenshots of your Ardour project and your JACK routing. QjackCtl can display this for you.

Also, by “feedback” are you referring to Audio feedback, or simply that there is a visual indication on the meter that audio is being routed to that channel?

the audio tracks are more important and should be the place to look for input signals, not the master track… though you can take the master level as a sign that there is a signal input going somewhere, you still need to check the pin-connections at the track-level.

“feedback” is actually not good and should be avoided. If you are referring to being able to hearing “routed audio” to your system speakers, then you shouldn’t be referring to this as feedback.

When the “feedback” red led blinks(screenshot), it presents a source providing a signal back onto itself — (essentially it is just “looped audio”)

When you work with the transport and are working with hydrogen, which one is doing sync for the timecode?–> in other words, if you have the transport set correctly for both applications, does the “playhead” in ardour actually “move” when you are recording?

does the “playhead” (in ardour) move after you arm both track and transport?

Hydrogen can share the same Jack transport as Ardour… you’ll need to make sure that the Jack setting looks like this,

On the right side of the “Auto-Return” button(which gets disabled), it would say either “INT/JACK” or “JACK”, the transport becomes an “external” Jack source after you manually click on the “Jack” button on the left side.

This confuses users, so I made a post about it over here,
Setup RoseGarden for Jack-transport (+ step-time input for midi-record things)

The thing with “Hydrogen”, is that it appears to me it acts like the Jack master for the transport, so you will not see a “Jack transport” setting, but intrinsically it already provides this as part of its jack capabilities – as long as Ardour has its setting to “external” Jack as presented, then its playhead will move together with Hydrogen.

The settings for JACK in Hydrogen are very minimal, but it will still act as the Jack transport master which is fine.

here tested: you can play/stop in either Ardour or Hydrogen and the playhead will move in both applications simultaneously. If your setup is not doing this, then you should correct this – though technically I think you can get away with it in not setting this up, it only makes things easier later.

note: if the playhead in Ardour is not moving then it will not record <<< likely you do know this, but in case you don’t here someone is telling you.

– if I’m wrong, someone can correct me where it is seeming out of place…

hope this helps

1 Like

Hi @robsco, i am talking about the visual indication on the meter and the processed sound that i can hear when i play my guitar.

thank you @ahms, i got the feedback point, and i have corrected my configuration. i head previously selected guitarix as both input and output. but it’s still the same problem!
I am unable to record anything, please help.

Have you double-checked that you are not routing the Guitarix amp output to the master bus? It should go to the individual track that you want to record on, not the master.

yes @lordbullingdon i checked that, i have no idea what’s wrong!

Assuming you are on Linux (Or OS X this is possible as well) past the output of:

jack_lsp -c

as preformatted text here please with your Hydrogen session and your Ardour session open and running (With Jack also running obviously)?

     Seablade