Connect Midi controller to Ardour ??

Ardour3 not showimg up in jack in the alsa tab only the audio tab.

My Akai MPK mini midi is in the alsa tab,so the too are not under the same tab.

All other audio programs like Qtractor and such show in the alsa tab.

So How do I connet my controller to Ardour??

1 Like

Google keyword: a2jmidid

and look at “a2jmidi_bridge”

http://manual.ardour.org/setting-up-your-system/midi-on-linux/

Ok I installed it and now ajsmidid and ardour show in the midi tab, but I still cannot get my controller to work in ardour.

When I add a plugin, Calf-MonoSynth on a midi track , ardour does not respond to my controller–Akai MPK mini.

After following the manual my midi controller is not showing up in Jack, just a2j, is this normal???
It used to show up under the alsa tab, but the manual says to disable alsa seq.

Having a real hard time setting up midi in Ardour 3, this was pretty easy to do in earlier versions.
Could use some advice.

Maybe you might succeed if you try to take the two steps I had to take when I experimented with Ardour 3 Beta4 and 5 and controller Mackie MCU Pro.

First I had to connect Ardour 3’s MIDI port with my controller: Connect your controller with your PC and switch the controller “on”. Then run a2jmidid in a Terminal.
Jack’s MIDI connections window now might look like on this screenshot - so you can manually connect a2jmidid / your controller with Ardour (I’m sorry, it’s a German language version of Jack):

http://forum2.magnetofon.de/bildupload/Bildschirmfoto%20vom%202012-08-03%2019%3A10%3A53.png

The second step was to “wake” Ardour up so that it recongnises the controller. On my PC today the final version of Ardour 3 uses to do this automatically, but just yesterday I had to do it manually again: Go to Edit > Preferences and to “User Interaction”. There you can enable your control surface:

Now double-click on the blue line which belongs to your control surface. A new window opens:

Now I click on “Discover Mackie devices” - and the faders start to fly immediately :slight_smile:

Michael

Thanks for the help, but unfortunatly that doesn’t work.
I noticed that on the midi tab of Jack, a2jmidid just lists midi thru nothing else.
I dont think my akai is compatible with ardour, which is a shame cause akai makes good shit :(.

Anybody else having problems setting up an akai mpk min or other akai controllers??

Which manual tells to disable alsa-seq? Your device needs to show up in the ALSA tab. Then a2jmidi can route it into JACK’s MIDI tab.

@johmue: you misread that - its not about disabling the ALSA sequencer. It is about NOT using the “ALSA seq” option for a MIDI bridge within JACK.

Says so right here:
http://manual.ardour.org/setting-up-your-system/midi-on-linux/

First you should be sure that there is no ALSA sequencer support enabled in jack. To do that open qjackctl’s Setup window.

In the Settings tab set the MIDI Driver drop down to the none option.

Then go to the Misc tab and uncheck the Enable ALSA Sequencer support option.

BTW there isn’t any ‘none’ option in the drop down menu, but there is a ‘dummy’

@acidblue: this comment is still needlessly misleading. QJackctl does indeed include “None” for the “MIDI Driver” combo selector.

So should I be using the ‘dummy’ one ?

acidblue: dummy has NOTHING to do with the MIDI driver. it is a choice for the backend that JACK will use to interact with an audio interface. You are looking at the wrong combo box selector. MIDI driver is in the lower left of the setup dialog

DOH!
Thanks for pointng that out.
I dont think the problem is with Ardour per se, I think it’s a2jmidid.
Like I said before (I think), only midi thru is being shown under the midi tab, no IN, OUT, or what ever for my midi controller.
In fact qjackctl doesn’t show my Akai at all just says a2j.
I’ll try and get a screen shot of what I mean.

Screen shot:
http://www.flickr.com/photos/40092645@N06/8576844376/in/photostream/lightbox/

Not sure how to post links correctly

Using a2jmidid -e gives one more:

http://flic.kr/p/e4USd5

Still haven’t figured out the link thing.

Have you already tried to connect Ardour’s MIDI in/out with the a2j “MPK mini” ports instead of the MIDI through ports? (I could imagine that connections to MIDI through won’t work…)
Maybe it helps to take a screenshot with a full size Jack MIDI connections window (so that the complete names of a2j’s ports can be read)…

Michael

once you have a2jmidid -e exposing the MIDI ports to jack… using the new ardour MIDI connections manager is easier than trying to work it out in qjackctl…

Ok here is a a full size screen shot:

http://flic.kr/p/e58E4o

once you have a2jmidid -e exposing the MIDI ports to jack.. using the new ardour MIDI connections manager is easier than trying to work it out in qjackctl...,

I tried that as well, but not sure what should be connecting to what.