Can't record into an ardour file I closed then opened again


I finished my podcast episode, exported and shut down ardour, but a few days later I realized I need to do a couple of edits, but when I re-open I can’t get my (previously working) audio input from my usb mic to register any input in ardour (I checked its still working on the system).

Ardour is (as far as I can tell) still set up like in my previous topic: [Recording directly into ardour (for noobies) - do I need to buy an interface? - #6 by vasakq]

Can anyone help?

Which OS are you using and which version or Ardour are you using (Menu > Help > About)

Check Menu > Window > Audio/MIDI Setup – What Audio-System and Device is set there?

Linux Mint 19 Cinnamon kernel 4.15.0-135-generic
Ardour Ardour 5.12.0

ALSA, Input and output device show my Samsung Q2U microphone , same as before

I have a master file I work from for each episode (has the intro music etc) and that is working as normal, I don’t think I’ve ever exported that tho…currently “export” is the only thing I can think of that is different between the 2 files.

UPDATE: I kind of had to get this done as soon as possible so I managed to get my edits done by copy-and-pasting from other sections, but I would really like to know how to solve this for next time!

Make sure that you plug your USB mic before you start Ardour. Set your USB mic as I/O device and check the routing. I hope this picture helps:

Thanks for the reply!

Um, I’m not really getting anywhere tho…

In desperation I’ve tried updating my system, unplugging and replugging the usbs, and restarting the system (in various combinations…)

It seems upon starting Ardour (opening up my master recording file) I’m getting either:
A: can record but can’t hear any sound on playback, OR
B: can neither record nor hear playback
(it seems to be flipflopping between the two, with a preference for A)

In my system I/O I seem to lose the abilty to even hear the test sounds (“front left” “front right”) when ardour is open. However input seems to register.

Attached are a couple of screenshots.

I’d like to emphasis that everything has been working perfectly for weeks, and I didn’t go change anything, but as of yesterday I’m getting these problems.

Thanks for any help!!

Screenshot from 2021-03-06 06-21-28|690x388

Screenshot from 2021-03-06 05-12-40
(this says “stopped” because I took the screenshot on startup)

It’s hard to tell for sure, but it appears that your track outputs are not connected to the master bus inputs.

thanks, does this screenshot help any?

Yes, that confirms it.

Sorry to be so noobish, but can you give me any instructions on how to fix this?

EDIT: a bit of fishing around and I have playback again, yaaay!Screenshot from 2021-03-06 06-59-01

Still no recording tho…

Well, similarly, your track inputs are all disconnected. You can use the same approach you just did to reconnect them (you can also click on the input button near the top of each mixer strip currently labelled “-”).

Ardour does not do this by default so something happened here.

ok, I’ve got something to work with there, for a minute I’d fixed it but looks like I broke it again…and I seem to have added 5 input channels where i only want one, is there a way to remove those?
Screenshot from 2021-03-06 07-22-10

However, I’m done for the morning (head hurting from staring at screen scratching head…) but I’ll come back to this later, thanks for the help!

UPDATE: help! Um, I’ve just spent a fruitless 2 hours trying to get ardour to record and playback, I have no idea why it won’t, it was doing it fine for weeks…I’m tempted to go back to Audacity but the destructive editing was fairly unpleasant…

I’ve got a podcast episode to record and edit and currently nothing but Audacity to do it on, so if anyone can help I’d be very grateful…

(alternatively, it is possible that ardour is overkill/not for a novice like me…if you think I’d be better off looking elsewhere feel free to say so.)

Anyway, sorry for the noobishness, thanks for any help!

Never mind, problem solved, a night’s sleep and some prodding around while following along with this got my recording working again, phew…not sure why I didn’t manage this yesterday, I think I may have just gotten a bit tired and frustrated…

Have screenshotted the routing settings as a note-to-self, hopefully if it goes pear-shaped again I’ll be a bit better placed to fix it…

In the meantime, all is right with the world again, (well, the bit of it that I use for a podcast, anyway…) thanks for reading and your patience.

It seems I lose mic input whenever I close then re-open an ardour file. No amount of fiddling within Ardour seems to do anything, the trick to getting it back seems to be simply to restart my computer. Possibly a bug?? Anyway I’m posting this in case anyone else experiences similar…

What settings do you have in Signal Flow under Edit->Preferences?

hi, thanks for jumping in, here are my settings:

Thought the issue might have been with your Track and Bus Connections but they look fine to me. Do you lose your inputs right after you open an existing file but not if you close a file and then create a new one?

I have a master file and when I open that and save as my new episode I have no problems recording. And I have no problems doing the same thing again next week.

However if I close the new episode file, when I open it again I have no audio input - but I can get it back by restarting my computer.

Ok, a little off topic, but… What font is that?

which font?? in the screenshots?

Yes! But from @Baal screen…

And about your problem… Did you think about upgrade Ardour to a newer version?