Can't load ACE Fluidsynth in Ardour 8.4

  1. Setting the language did not help
  2. temporarily renaming ~/.local/share/icons/hicolor did the trick

So now at least I know it’s in my local icons, not in the system icons. Will take some time to debug, folder contains 16 k icons

Thanks for your guidance so far.

If I’m able to identify the bad guy I will post it here. (or in the tracker? don’t have a tracker account - yet)

1 Like

Good to know.

Just do it in halves; start by removing half of the icons and see whether it works or not and then add or remove subsequent halves. Repeat until the guilty one appears.

1 Like

It would help significantly if you find the icon and upload it so we can reproduce the bug.

It is likely a „sound“ symbol (for wav files)

  • Brand new day
  • fresh reboot
  • physically remove my local icons (~/.local/share/icons)
  • create a fresh test session with 8.4 (even using language settings for US_en)
  • add a midi track with ACE fluidsynth
  • open the GUI of ACE plugin
  • click on file browser
  • BUMMM !!

Now I’m quite desperate :frowning:

  • Are the icons cached somewhere?
  • And why does it work in 8.2?

At least I can hack the state.ttl file with a path name for the SF2, setting up all the links for the sound font file manually like I saw in one of my projects and I can get sound

@prefix atom: <> .
@prefix lv2: <> .
@prefix pset: <> .
@prefix rdf: <> .
@prefix rdfs: <> .
@prefix state: <> .
@prefix xsd: <> .

	a pset:Preset ;
	lv2:appliesTo <urn:ardour:a-fluidsynth> ;
	state:state [
		<urn:ardour:a-fluidsynth:sf2file> <Fingered-1%20Bass.sf2>
	] .

This might help:
When browsing for a file there’s this icon of musical notes (16th) for wav and midi-files (in previous versions of Ardour visible). I guess this is the little devil that’s causing this.
Now this icon is in most styles like Adwaita and Breeze etc. But not in Oxygen (and maybe others). So when I change my icons to Oxygen all works fine.
I haven’t found the name of this icon yet, search continues.

Edit: there’s more icon-themes that are ok, like high contrast, gnome, elementary xfce, desert cameo.
When having the Ardour-import window pointing to a wav file, and at the same time changing the icon-settings of your system you can see the wav (or midi, or sfz) icon change. If you do this in 8.4, the moment you switch to fi Adwaita… booom!

This is the one
maybe audio-x-generic.svg or audio-x-generic-symbolic.svg ?

1 Like

Could you please send me a pointer to where I can read something about changing icon themes. I’m not familiar with this subject, always try to avoid tweaking my system. I use the latest Ubuntustudio LT without any major modifications.

Btw it crashes ~1 sec after i click on the browser

Found it in the settings, set to Breeze.
Oxygen is not loaded, I seem to have GNOME, ePapirs-*, Humanity
Will check them

Coming closer.

  • Setting icon theme to GNOME
  • new session
  • added midi track, ACE Fluidsynth
  • selected SF2
  • can play sound
  • close
  • re-open session
  • change SF
  • plays fine
  • close, open …

So far ok

Then I will use GNOME fonts from now on.

cross my fingers that this will be stable

Still: can anybody tell me why it works with 8.2

8.4 uses a version of GTK that is now part of our own source tree, and has been stripped of certain components. 8.2 uses an external “full” version of GTK.

We did this because GTK 2 has been “end-of-life’d” on many Linux distros, and we want users on those distros to still be able to build Ardour easily if they wish or need to.

Yes, I saw this in many postings and it oerfectly makes sense.
And I will never understand in my whole life what exactly has been stripped. And I assume everything that is required for Ardour has been transfered, so a missing component cannot be the cause for this issue.

That’s certainly what we believed. But apparently some themes on some Linux distros contain icon files that cannot be read with what is left behind after the “stripping”. Figuring out what those files are is the first step to fixing this, and neither myself nor @x42 have systems where this is a problem.

Some themes on some Linux distros, …ehmm…, Ubuntu Studio being one of them.
The latest install of Ubunto Studio hasn’t any icon-theme to divert to, so basically impossible to use Ardour 8.4 without trying to add some unaffected icon-themes.
Now I was not happy at all when Ubuntu Studio decided to drop xfce in favor of Plasma.
Maybe this Ardour-issue is a final push for me to leave Studio behind.

I guess you have Virtual Machines to test/investigate a system where this is a problem?

1 Like

Agree, I’m not here for fancy desktop stuff, I want my music (and video) stuff get done.

So, I might be moving away from UbuntuStudio and looking into AV Linux …

What configs are others using?


In fairness to Ubuntu Studio this is a current Ardour issue and Users should be able to use common popular icon themes on any Distro they choose and expect that Ardour will work… As far as AV Linux, I can’t confirm personally that it is immune because I have not tested Ardour 8.4 (perhaps others have?). The most recent AVL release has Ardour 8.2 on the ISO so it will work but I am working on fixing a couple of issues that appeared in the last AV Linux ISO release and I’m waiting to see what happens with this issue as well…

On a side note although I only use one or two of the Calf Plugins in my own productions the one I do use regularly (Bass Enhancer, it’s great on Kick drums) has become a go-to and is in almost all of my sessions. I am in a bit of a predicament as well as the provider of a long term platform that has provided both Calf and Ardour knowing that Ardour 8.4 will break not only my own sessions but also those of AVL Users that use Calf…

I understand Ardour’s move with GTK2 completely and I understand that Plugins with GTK2 UIs were never a good idea… It appears in other threads that the “pixbuf” part being removed from Ardours GTK2 implementation is what affects the Calf UIs, is it possible that it is also responsible for the current Icon problem?


I did a workaround which works for me now.

On an xubuntu system, I noticed a difference in the icons there. It had an audio-x-generic.png file in the Adwaita 512x512/mimetypes folder which isn’t on my Ubuntu-Studio computer.
I copied this file to the same folder on my Ubuntu-Studio machine and no crash anymore for Adwaita icons (haven’t tested the other themes but I will)
It uses this png and not the scalable audio-x-generic-symbolic.svg file

NB I had to update the icon-cache first
NB Maybe not all icon-themes have the not-scalability options, the filetrees per theme looks very different.

1 Like

I see the Oxygen theme uses PNG icons, but the Breeze theme uses SVG icons.
Any reason to think that SVG would be a problem for the stripped GTK implementation?

Just in case, I would be happy to test any modifications of Ardour w.r.t. this issue on my system.

The problem is the ABI. If you were to compile Calf with the GTK version that Ardour uses, the plugin UI would show.


This should be fixed since 8.4.118 (available from
Please test.

1 Like

Quick check with 8.4.121 debug, and font Papirus: seem to be ok now
(Cross-check 8.4: still crash)

will do more testing later

Thanks for fixing

1 Like