Can't load ACE Fluidsynth in Ardour 8.4

I’m trying to load the ACE Fluidsynth plugin in Ardour 8.4 but for some reason it doesn’t seem to work. I tried opening Ardour via terminal to try to catch some error message but nothing is logged. Adding the plugin to a track freezes Ardour.

I’m using it on Ubuntu 22.04 with Pipewire. If it helps, I was using Calf Fluidsynth over Ardour 7.0 until yesterday on the same computer.

Debug log

I tried running Ardour with the --gdb flag but no interesting additional output was shown. Only these lines:

[Thread 0x7fff8bfff640 (LWP 12216) exited]
[New Thread 0x7fff8bfff640 (LWP 12328)]

This occurs when clicking “Insert Plugin” in the “Plugin Selector”.

Can you add the plugin directly when creating a new MIDI track?

Could it be that there is a popup dialog “Replace existing synth”?

Can you add the plugin directly when creating a new MIDI track?

No. Same thing happens: Ardour freezes. I just checked that the same issue occurs if I try adding the ACE Reasonable Synth instead. Also, I just checked that Ardour is using the correct version of the plugin (the one bundled with Ardour 8.4).

Adding MIDI tracks without any plugin works fine.

Ok, it seems like I can’t add any MIDI plugin. The same issue happens with other plugins like Podolski and Triple Cheese (from U-he). But the same plugins work from Carla or even Ardour 7.0.

I just found that if I set Ardour to work via ALSA, it seems to work properly. I was setting it up to work via Jack. :sweat_smile:

Ah. there was a pipewire bug that causes this. Though that was fixed 10 months ago:

Which version of pipewire are you using?

1 Like

I’m using 0.3.48.

# $ pipewire --version
Compiled with libpipewire 0.3.48
Linked with libpipewire 0.3.48

Wow that pipewire version is ancient, and not usable for pro-audio.

So until you get pipewire 1.0 I suggest to stay with Ardour’s ALSA backend.

Not using pipewire (I hope).
Yesterday I also could not invoke the Gui of Ace fluidsynth. Also one time I had Ardour crashing when I doubke clicked the plugin.
Temporarily switched back to 8.2 to keep going.
Will recheck when I’m at the machine.

Apparently it will be bundled with Ubuntu 24.04 so maybe next month I’ll be able to upgrade. :heart:


Ardour 8.4 crashing again. Reproducible

Selected ALSA back-end.

Not sure if pipewire is running somewhere under the hood, a process “pipewire” exists.
How do I know for sure what’s going on?
Is there an easy way to get rid off it? Should I upgrade (don’t want to mess up the system)
Also version currently

The symptom
I have a midi track. ACE fluid synth instantiated.
Now I open the plugin, open the file browser to select a sf2 file and … crash

Maybe it has something to do with the file browser
I installed Fluida as a work around, but Ardour 8.4 also crashes when I try to open the file browser and select a SF2 file

How to reproduce (on my system)

  • create a new session
  • add a midi track with ACE Fluidsynth
  • open Plugin GUI
  • click on file select
  • crash
fluidsynth: warning: No preset found on channel 0 [bank=0 prog=34]
fluidsynth: warning: No preset found on channel 9 [bank=128 prog=0]
fluidsynth: warning: No preset found on channel 9 [bank=128 prog=0]
start clocking
lilv_state_new_from_instance(): error: Error saving plugin state: Missing property
lilv_state_new_from_instance(): error: Error saving plugin state: Missing property
lilv_state_new_from_instance(): error: Error saving plugin state: Missing property
Segmentation fault (core dumped)
(base) peter@SpiderStudioOne:~$ ardour-request-device: watched PID no longer exists - releasing device.

Back to 8.2 now

This is a known problem caused by an icon file somewhere on your system.

So far nobody has put in the time or been successful in determining which file is the problem.

Ok, could I find out what the annoying icon file could be?

Any other workaround except going back to 8.2 loading the SF2 file,
opening with 8.4?
Editing a file in the plugins directory?

DaD does not work, cause the plugin GUI disappears when I go to Dolphin

Just read the ticket history. from that I assume there’s not a lot I can help to debug.
If I can please let me know. For me loading SF2 files is kind of essential :wink:

because it works in 8.2 and it does not in 8.4, does it have something to do with the gtk2?

No issue at all on openSUSE TW.

Hello everyone.

I have the same problem with version 8.4, I can no longer use Ace FluidSynth, IR LV2, Invada…

I unfortunately deleted the installation file for version 8.2, does anyone have it?

Thank you for your feedback.


Possibly. Does the File import dialog work (Session > Import …) and allow you to select audio or MIDI files?

Along with EQ10Q and Calf those plugins are end of life and no longer supported. Please see Ardour 8.4 Calf plugins [ERROR]: failed to instantiate LV2 GUI - #4 by x42

(unrelated to the ACE Fluidsynth issue)

Getting strange and weird now:

  • create new session, Ardour 8.4, empty template
  • adding a single audio track
  • click on Session → Import
  • crash

BTW: Import PT does not crash, I can traverse the directories (but of course do not have a PT session)

Any other occurrences of file import I could check?

Famous last words:

start clocking
Setting time domain
start clocking
Segmentation fault (core dumped)
ardour-request-device: watched PID no longer exists - releasing device.

No errors in log (except for one missing manifest.ttl in a ~/.lv2 sub-directory

even more weird and strange

  • adding a midi track with the Fluida plugin
  • with the plugins browser I can select a sound fount file (plays fine)
  • save and close session
  • re-open session
  • Ardour crashes when trying to open the main window

What’s going on.?

Opening any old session done with 8.2 and simply clicking on the ACE Fluidsynth slot in the mixer channel (edit view) Ardour crashes

This is almost certainly the icon-file-on-your-system-causes crash

It’s probably not the same issue, especially if Paul has concluded that it is an icon error, but the Hydrogen drum machine had a similar crash-on-opening-file-browser and that was due to some translations being to long for the size of the buttons they were attached to.

If your system is set up for something other than English, try starting Ardour from the command line with
LANGUAGE="en_US" LANG="en_US" /path/to/your/Ardour
and see if it makes any difference