Can't get guitar direct input into system

Hi All
I have scoured the forums to try and find a similar problem and not finding it makes me think there is something really obvious that I can’t see for whatever reason. I am trying to get an electric guitar to direct input to guitarix in Ardour and while it all seems to be working no sound is coming through. I can see that audio is coming in by the meters jumping on th pulseaduio mixer. The sound card is a Berhinger UMC202HD. By all accounts this should work out of the box on linux. Could there be some Jack module that I haven’t installed? I have been puzzling over this for a week now and I just can’t see where I am going wrong. Could somebody who has done this successfully kindly guide me through their process?

I have been a user of the umc202hd card and it works perfectly on GNU/linux.

I would start by testing if the sound comes from the umc202 to the PC, leaving Guitarix aside.
Try to see if the sound comes from the card to an Ardour track (without Guitarix).
If you use Guitarix in plugin format, try to use the ALSA audio system instead of JACK.

1 Like

What backend are you using? What is the audio configuration in Ardour? Stand alone guitarix app, or plugin?

Is recording enabled on the track? In the mixer window if recording, is the “in” button lighted? Not the disk button. Are the plugins on the track enabled?
Is anything muted anywhere ?
The guitarix app needs jack to run not sure about the plug-in.

If all else fails download avlinux it will work on it try it with a live usb.

I have tried this and I think my problem is happening before Guitarix or Ardour. The weird thing is that when I open Audio Mixer or Volume control I can see that signal is getting to the machine. But no sound out of the speakers. I think I have Jack configured properly because everything else was working and still is.

I have tried both standalone and as a plugin. I don’t know what you mean by backend. Sorry.

Tried and checked all that but haven’t tried a different distro. I am using Arch Linux. I will try avlinux.


That means that pulseaudio is using the soundcard, so Ardour cannot.

I will check that. I am beginning to think my problem is more fundamental than that. I can’t seem to get the guitar audio into the computer even though it seems like some signal is going through.

btw, thank you everyone who is trying to help me with this. I appreciate it might be a little frustrating with my lack of knowledge, which may the underlying problem!. I was hoping somebody might have just come across this and know a trap for young players. Cheers.

Be sure to read the manual that comes with it…it will tell you how to set things up right.

Backend means the audio system used by Ardour, which on Linux would be JACK, ALSA, or PulseAudio. Pulse is a special case and is not generally recommended.
If jackd is not running you get asked to select when starting Ardour. If jackd is already running then Ardour will connect to jackd server when started.

The recommendation if you do not need routing between applications is to use the ALSA backend to avoid the added complication of configuring jackd properly.

The ALSA backend is usable if you are using plugins for all your processing. If using a separate application for processing, like the guitarix stand alone app, then you have to use JACK to route audio between the separate applications.

Thanks Chris. I am using JACK.

I am using JACK.

As Robin pointed out you can’t run JACK on the same device that pulseaudio uses.
There’s a PA module called pulseaudio-jack bridge, to allow both to run at the same time using the same audio device and make PA apps appear in JACK connection graph, and kxstudio’s Cadence is a graphical frontend to JACK that makes it easy to configure and run this correctly.
Without this, either get a second soundcard and run both systems in parallel, each on its own device, or disable pulseaudio before you start JACK.
Pipewire is making all this much easier, and has evolved a lot recently, to the point where several distros have switched and default to it.

Not at the same time, but PulseAudio should gracefully give up access to the audio device when jackd starts.

The usual “start from the beginning” type of information to help figure out JACK problems would be:

  • command line or configuration options used to start jackd
  • output log messages from jackd to determine if it started correctly
  • snapshot of your audio connections window to verify that the audio routing really does what you expect

By default jackd does not connect any audio signal to any audio device. Ardour will connect audio inputs to track inputs, but that is configurable, you may have turned it off. Depending on the signal flow you are trying to achieve you may not want that, you may want your guitar to go directly to guitarix, or you may want your guitar to go to an Ardour track and treat guitarix like an external effects device using an external send and receive port.

Thank you everyone for your guidance, and importantly your patience. Through a lot of clues that you were dropping while trying to decipher my poor communication of a mysterious problem, I was able to realise that I hadn’t configured JACK properly. I have done that now and everything is working as it should. My fundamental rookie error was not realising that you had to restart JACK whenever you made configuration changes. So I had probably been hitting on the correct configuration and not knowing because I failed to restart JACK and so nothing seemed to change no matter what I did. I hope this has not been too frustrating for you all and again really appreciate the help. While I am only just scratching the surface of what’s possible I am totally in love with Ardour and can’t wait to see V7.
All the best and Thanks again.

Quick final question: I have been starting JACK (or jackd) through Cadence. Should I be doing it on the CLI?

Using one of the control applications is the most common way (either Cadence or QJackControl), no real need to use CLI unless you just want to get more familiar with what is going on behind the scenes of the GUI control application.

You could also try using the Linux driver stack directly (ALSA) with Ardour, so without JACK.

This is soooo true for Ardour but not guitarix it needs jack. Not sure if the plugins do most likely not.