Can´t open General Preferences

Hi There,
I´m just trying Ardour for the first time and want to mainly use it as a PlugIn Host. But it doesn´t find my vst-Plugs on startup. So I tried to manually scan for them but couldn´t, because it doesn´t open the “General Preferences” Window.
Tried it on two different Macs, osx 10.7.5. and OSX 10.8.5 Same Problem.

Anyone knows a trick, please tell me what I do wrong. I like the rest of the programm very much, but that would be a killer.

Benni Thalia Theater Hamburg Germany

Does ardour for Mac support VST now? I thought it was AU only on Mac (Ardour4 -> Preferences should get you to the preferences)

You would be the first person I know of that can’t get it to open the preferences window. However as Mike mentioned, Ardour on OS X only supports AU, not VST. Where did you get your version of Ardour? What version is it?


This is believed fixed.

Dear Paul, where ist the fix? I just intalled Ardour (4.7.13) on a Mac (Macbook i5 OS 10.10.5). The menue is: Ardour4, Global Preferences. But if I choose it, nothing happenes. First I updated Java to the last version and reinstalled Ardour, but i can´t still open the GP Panel.
I would thank you for the answer, where I can find the fix.

@Denkmal Java has nothing to do with Ardour at all, nothing you do with it should affect Ardour.


@Denkmal Also try one of the nightly builds and see if it works there for you?


Thank you for your comments. I tried the nightly builds…now Ardour crashes on startup…no chance to see if there is even a change. It crashes while loading the busses. Empty project did not help.

Nightly builds are a snapshot of work in progress. We offer no guarantees that they work from day to day. They are just a way for people who do not build Ardour themselves to get a snapshot of current development, between releases. The fix is in the nightlies, but you will just need to try again until one of them works for you, or wait for the next release.

I got the same problem on OSX 10.7 with my old mac pro. :frowning:
First time i tried Ardour, just for trying it out. LOVING it, except i can’t open the preferences. (sadface)
Any ideas? Manually editing the config file as a workaround maybe?


Did you try a nightly build and it is still happening? I don’t believe an actual release has been made yet as there is a LOT of work going on behind the scenes right now and I suspect Paul et. al. is trying to get the new features merged in and stable before doing another release.


thebeep: as noted earlier, this has already been fixed. There is no workaround if you are using the last release other than using English. The error is a problem with the German translation (it may exist for other languages as well).

@paul thanks!! the problem is: i can’t switch the language if i can’t open the preferences panel, right? :frowning: can i manually edit some settings for that?

Ha, i am an idiot :slight_smile: Of course i can set the language in OSX and it works fine now! WOHOOO!!
Guess i will become a subscriber now. Thanks yall!!

@thebeep: glad you got that working. While you’re in english mode, go to Preferences > User Interaction and turn off “Use Translation”. Then you can switch your OS X system back to your preferred language, and for now Ardour will continue to be in english. Once the next release comes out, you can then turn Ardour’s translations back on and things will work even better. Can I confirm that you normally work in German?


this is my first posting here.
Just have a fresh installed El Capitan OS with only the latest Ardour 4.73 installed and added some Audio Units plug ins and I can not open too the Preference Box, neither from menu or via short cut.
I like to discover which path Ardour is using for its plug ins, because I can not find any via plug in manager, except this Retro-organ-synth.
The Log file showed that he discovered all Audio Unit plug ins.
Now I am confused.

For AudioUnit plugins, there is no search path. Plugins are discovered by the operating system. The OS looks in ~/Library/Audio/Plug-Ins and /Library/Audio/Plug-Ins

If you use a language other than English, then the Preferences dialog in Ardour 4.7 and earlier will not open. This is described in the thread above. Please read it carefully.

The bug that causes this has been fixed, but there has not been a new release yet - the next release will be 5.0.

Thank you very much for your fast answer.
Changed system language to english and was able to open the Preferences Box.
There I could enable the auto automatic search for Audio Unit plug ins and they all appeared on the Plug In Manager and those worked.
Changed system language back to german.
Became surprised when opening Ardor again to see on the Audio/Midi Box that Core Audio is not anymore running and have to start it mechanically.
It is not a so big deal to have a 2nd click on the start but before I need`t to do it.

@ohmnoise: you have to make a choice because we build Ardour with support for both the CoreAudio backend and the JACK backend. We store the settings you used last time, but we do not automatically make the choice every time you start the program. The only case where you are not asked which one to use is if you used JACK last time, and JACK is already running.

Thank you very much.
I am using CoreAudio.
I was able to succesful integrating third-parties plug ins and to record a miditrack with an instrument.
For recording an audio track I can not find any connection possibilities like it is descrpited on the Ardour tutorial, see please this pix
Now I am more confused.