Can´t open General Preferences


What audio interface were you using? Can you take a screenshot of the audio setup dialog (Can’t remember the exact name of it right now)? For whatever reason you don’t seem to be using any audio hardware with inputs, usually this points to incorrect settings in the audio setup for Ardour.


@ seablade - thank you very much for fast response

I am using a Behringer UMA25 Audio-Midi-Controller and Midi works, also of course the audio-output.
I tried to record with Audacity and it works too.
Screenshot of set-up

Screenshot of standard session set up when creating a new project

Please forget last url, this is the right location

That is the “New Session Dialog”, which has nothing to do with the choice of audio+MIDI backends. You should see the Audio+MIDI Setup dialog right after you define the session you want to use.

Sorry for the confusion.
Here is screenshot of Ardour Preference Box and Audio/Midi Setup Box
The second link directs to the New Session Dialog

Hmm that is an odd one, I suspect something odd with that controller. What are your options under audio input? And you are trying to record from the L/R Line In (Or Mic In) on the controller? And your speakers are connected to the L/R Line Out (Or Headphone Out) on the controller?


@ Seablade

I used this interface to record with Audacity succesful and under OS System Settings Audio it is selected as a USB Audio Codec.

What’s odd about it? I see nothing wrong, and I don’t read anything “wrong” up-thread other than @ohmnoise having to start the CoreAudio backend …

I just changed at the start in the Audio/Midi Setup Box the input to Inbuilt Mic and I was immediately able to record the room noise with the iMacs stereomicrophone by just hitting the Record Arm in the audio track as expected.
Went back to set the Audio Device to USB Audio CODEC and again I can not record anything.
Same behavoir, instead of controlling the audio input grid the “mouse over message” says “INPUT to Audio Disconnected”.
When opening Audio Connection Manager I do not find Hardware on the Source Section.
Like I say before on Audacity it works well and I have there the same settings like CoreAudio and USB Audio CODEC for the source.

I tried the Calibrate Audio in the Audio/Midi Setup, with USB Audio CODEC as in- and output and got that massage
“Your selected audio configuration is playback- or capture-only.
Latency calibration requires playback and capture”
I can record also via Inbuild Line In and playback via USB Audio CODEC, but that is less fine solution.


ohmnoise’s most recent screenshot of the audio routing matrix showed no hardware audio inputs to record from.


Recording in Audacity and Recording in a DAW are two different things. Audacity will allow you to use two non-sync’d interfaces, or parts of interfaces easily. Some interfaces have multiple ‘devices’ that show up under OS X, I haven’t run across it with anything other than the built in hardware and how Apple treats it, requiring the use of an aggregate device under the jack engine, or setting the audio input and output to two seperate devices under the coreaudio engine, but that might be one possible explanation here, however isn’t usually my first goto. That being said, I have to point you back to my questions above, the answers to them will shed some light and confirm a few things about what you are doing.


PS Calibrate Audio has NOTHING to do with this, you can safely ignore this, however the error message it puts up again points to a possible issue with the OS treating your audio interface as two different devices.