Best Linux distro for PreSonus FireStudio?

Hello all. I know everyone hates “what’s the best distro” threads, and this question is not about Ardour specifically, but I don’t know who else to ask.

I’ve used Ubuntu Studio, Kubuntu, and A/V Linux. I am dual-booting on a 2012 Mac Mini.

My issue is that audio crackles and pops every few seconds during playback on Linux, no matter what program I’m running. I have a PreSonus FireStudio, and a DigiMax plugged into the FireStudio via ADAT optical for a total of 16 analog ins and outs, plus MIDI in and out.

I have tried asking Ardour to directly connect to ALSA, and I tried having Jack connect to the FireStudio, and then asked Ardour to connect to Jack. The audio sounds bad either way. It sounds like a clocking error or something.

If I boot into Mac OS, Ardour (and audio in general) sounds perfect. I realize I could just keep using MacOS, but I want out of that ecosystem. Apple will drop support for my Mini sooner rather than later, and I want to be a 100% Linux user before that happens.

The only way I’ve been able to get clean sound is to use my motherboard’s built-in audio ports… but I can’t record any instruments that way. Can anybody help?

1 Like

Have you tried to use it the old way, with JACK/ffado instead of ALSA?

I don’t have first hand experience, but there are reports that for some devices the newer ALSA driver is not yet up to par. So unload/blacklist the ALSA driver and start JACK with the ffado backend.

Perhaps https://linuxmusicians.com/viewtopic.php?t=19429 and a related forum thread here Focusrite Saffire Pro 26 I/O works in alsa but not Jack? Confused I is! can help.

1 Like

I will give that a shot tonight. The weird thing is, if I open the FFADO app in Ubuntu Studio, it says, “No device found,” even if it’s working.

Hi Brad,

You may check either your buffer size firstly (trying to run it to low? )
Second
What type of chipset is your Presonus Running? sometimes, if it contains the “snd_dice” chipeset you may need to blacklist it
Other things: Have you created the “50-raw-firewire.rules”
Have you appended the “raw1394” line to your /etc/modules file ?

There are more things to be done in order to FireWire Interfaces to work under Linux

I would read this before hand.

Hope I have helped

https://wiki.linuxaudio.org/wiki/system_configuration#using_firewire

I have a Focusrite Profire40
A RME Hammerfall
A M-Audio 2626

For my use at the University where I work and all of them work under Linux

Maybe it’s falling back to use ALSA instead?

There was a change a year of two ago when the default changed from FFADO (raw firewire I/O) to now prefer ALSA (kernel, built-in audio driver).

I definitely have not already tried any of the things you suggested. I’m a little lost. Although I’ve been using Linux since 2009 (mostly for movies and gaming), I feel like I know absolutely nothing about audio production under Linux. I had no idea where to start.

Thanks for the link. I will check that out and see if I can make sense of it.

To use either M-Audio 2626 or Pro40
I have to blacklist the snd_dice chipset for ALSA
Use the FFADO and JACK2FireWire
the Jacksync PulseAudio in order to listen youtube etc
If you don’t blacklist the chipset for ALSA (i.e. alsa mixer etc) Jack (even using the "FireWire Driver) won’t work Properly
You won’t get higher SR nor higher Buffer Sizes

No problem,
I hope I have helped. Let us know ok?

We’ll include all of these on the next revision of the music-daw.deb

1 Like

Okay. I’m afraid this is not going well. My FireStudio used to work, it just had some crackling. Now I have no audio whatsoever. Here’s what I did:
I added

raw1394

to /etc/modules

I added

KERNEL==“raw1394”, GROUP=“audio”

to /etc/udev/rules.d/50-raw-firewire.rules

and I added

blacklist snd_dice

/etc/modprobe.d/blacklist.conf

Then I ran

update-initramfs -u

and rebooted. Now I have no physical outputs whatsoever anymore. In Ubuntu Studio, if I click the speaker icon, there is nothing there. I used to have the Presonus, an HDMI out, and a headphone jack. Now there is nothing.

If I launch ffado-mixer, it forever says, “Bus reconfiguration in progress, please wait…” and it eventually crashes, and Ubuntu Studio asks me if I want to send an error report.

When I launch QJackCtl, and go to Setup, and choose the Firewire driver, only (default) is available under Interface.
If I switch Jack’s driver to ALSA, I see the PreSonus, but it’s called “hw:PCH,0 CS4206 Analog (hw:0,0)”
Jack will start, but the light on my FireStudio blinks, as if it’s not connected to a computer.

Ardour 6 now refuses to launch. No idea how that happened.
I installed Ardour 5, and it launches, but when I connect it to Jack, it crashes to desktop.
If I tell Ardour to connect directly to ALSA, it says “Failed to open audio device.”

To not put the burden of helping me fix this on anyone else, I am going to nuke & pave.

To reiterate, I don’t mind switching distros. I started this thread because developer Paul responded to a comment I made on an Unfa YouTube video. He mentioned that sometimes Ubuntu-based distros might not be the best with Firewire interfaces, so I thought I’d see what everyone else was doing.

I’ll still gladly take anyone’s suggestions. I am going to try the daily build of Ubuntu Studio “Groovy Gorilla,” to see if there’s anything new in there. If that doesn’t work, I’m tempted to look at Manjaro and Fedora.

If anyone thinks I should stick with Debian-based stuff, or Mint, or whatever, I’m open-minded. Please, tell me what I’m doing wrong. I’ve been using Linux over a decade, but you can treat me like I’m a n00b. Pretend I know nothing. I have no idea what to try or where to begin when it comes to troubleshooting audio interfaces. I’ve been in the land of “it just werks” for twenty years. I’m totally lost.

For whatever it’s worth, my daily driver on my gaming/HTPC and on my laptop for the last few years has been Kubuntu.

I have a Firestudio 2626 that was used with Debian 10. Ffado-mixer does not work with the interface. The ALSA drivers produce pops & clicks in the recording.

If you use the ffado drivers the device will work as expected with Jack1 & 2.

Thank you, Venn. This has been a nightmare. I nuked & paved three times this week.

I just looked at this post:
https://discourse.ardour.org/t/ardour-jack-settings-for-firewire-interface/103261/9

-and you told someone, “MIDI support with FFADO can be hit or miss… the Presonus Firestudio flat-out refuses to do anything unless using the ALSA driver.”

This is ultimately going to be the deal-breaker for the FireStudio for me. I want to record an electric Yamaha drum kit via MIDI while simultaneously recording DI bass and a mic on a guitar cab, possibly vocals. If the mic pres only clock properly with the FFADO driver, and the MIDI port will only work with the ALSA driver, I cannot record a full live band. That eliminates this device from the running.

I’m going to sell the FireStudio, and put what little cash I get for it toward a Focusrite Scarlett 18i20. It’s USB-based, so that’ll be the end of FFADO. It has the exact same I/O as the FireStudio (and I’d bet a dollar the mic pres sound a little better). Lots of Linux folks have been singing the Scarlett series’ praises, so I guess I’ll hop on the bandwagon and see what it’s all about.

Thank you to everyone who helped.

I wonder if it had worked on an older Linux distro. Firewire devices used to work fine, but I never owned one.

I wish I knew. I’ve owned the thing since around 2008, and although I’ve been using Linux as my daily driver for entertainment, gaming, and general laptop usage for quite a while, I’ve only used Windows XP, MacOS, and Vista for audio production over the last two decades.

I have been using Presonus FP10 (three of them in a chain) and after getting ffado and rtprio in order and having good firewire controller based on a working TI chip, things usually works really well.
I have not used my Firewire stuff a lot lately but I have at least one box running with a Focusrite Saffire PRO40 and it is working good. Unfortunately linux distros seem to abandon firewire just because the other operating systems no longer support them but in my opinion FW is still among the most reliable I/O busses for audio streaming. Ubuntu Studio recently dropped support for ffado/firewire in their Ubuntu Studio Control so there is a steady trend away from FW… sadly.

No problem, sorry you had to find out what worked the not so fun way.

I’m picking up firewire interfaces from ebay and reverb when time (and finances) allow. Trying to build a reliable database of what works and most importantly,does not.

1 Like