Focusrite Saffire Pro 26 I/O works in alsa but not Jack? Confused I is!

Hi there, I was fairly certain through reading various Linux audio forums etc that firewire interfaces such as my very recently acquired Pro 26 I/O required ffado and jackd to work. So here is my confusion…jackd bugs out and utterly refuses to start for me when I choose the FireWire interface, but when I try to use alsa and choose the Pro 26 I/O to start a new Ardour session…it works! I’ve made a few test recordings, and they sound great. I’m getting good latency (<6ms), but it seems installing ffado has made my system go from bulletproof to a bit unstable while trying to establish the interface connection - it can lock the entire PC, and I can’t even remote in from another PC - a hard power down is required. Once it connects though it seems to run perfectly, allowing me to change and save defaults with ffado-mixer, record, playback etc although there is a stream drop out and reconnect once every 1-2 hours (no xruns though). So I’m clearly able to run the interface without jackd. If I can get jackd running I wonder if the stability issues might vanish but for now I’m able to use the interface purely under alsa. Comments?

Regards, Chris W, New Zealand.

I haven’t looked into it in some time but I seem to recall FFADO being rolled into Alsa some time ago, so you shouldn’t need it separate anymore I do not believe, but I haven’t used a Firewire interface on Linux in some time so I could be wrong.

    Seablade

Cheers seablade, overall I’m finding most documentation on ffado to be out of date. But despite the instability I’m able to use the interface so I guess I should take the win? :slight_smile:

Since ALSA added support for firewire devices, it’s exclusive with FFADO directly accessing the soundcard.

You can still use FFADO, but in that case you have to blacklist the alsa/firewire module and instead load the raw1394 kernel module instead. – I think you need to add blacklist snd_dice to /etc/modprobe.d/blacklist.conf and reboot.

In some cases FFADO can still perform better, but I don’t have any first hand experience.

Thanks Robin, I’ve experimented with blacklisting snd_dice, removing FFADO etc, but between reboots I think an alsa update got installed and suddenly there was a mismatch between ffado-mixer and the alsa ffado code, so I cant adjust any of the software controls or volumes. Not the result I hoped for, and the stability is still twitchy - power down the unit can hard lock my computer.

A real shame that a nice interface that FFADO website says has “Full Support” can be so difficult to get working reliably, but this is Linux audio we’re talking which frankly has been a cluster&#$@ since 2000 when I first experienced it. :frowning: Sorry for negativity, but based on the words on the FFADO website I stumped up a bit more of my hard earned $$$ than I was comfortable with to get that interface, in the hope that I could just power the computer on, login, and start Ardour to do some recording… was that too much wishful thinking?

I thought you wrote above that you can start Ardour with the ALSA backend and everything works OK? Just remove FFADO and use ALSA. Or is there some feature which did not get ported from FFADO stack to ALSA?

Since ALSA incorporated the FFADO code, when you have ALSA drivers and FFADO drivers loading you are effectively loading two conflicting drivers simultaneously (or attempting to, perhaps it is a case of whichever loads first becomes active). You should either only use FFADO and blacklist the ALSA firewire drivers, or just use the ALSA drivers and remove FFADO. Removing FFADO will probably integrate more smoothly with the rest of the system since all linux audio software is capable of using ALSA, but only some packages work with FFADO.

Adding additional layers on top of an unstable foundation does not make the bottom layer more stable. Whatever problems are causing your system to lock up will still exist with jackd running.

Hi Chris, I’ve learned a bit more since my last message - the story so far - when I first received the interface I installed ffado and tried to access the interface through jack, but jackd couldn’t start due to an error - I then noticed by accident I could access the interface through alsa without needing jack (or ffado as it turns out), and although it seemed to be quite an act to get it to connect it at least worked fine once a stream was established. I could also open ffado-mixer and change settings volumes etc. A day later I did a system update, and I believe my alsa got updated - at that point ffado-mixer stopped working due to a version mismatch (it reports its version is 2.3.0, but ffado is 2.4.2 - I’m guessing the ffado 2.4.2 is the alsa baked-in one). I think ffado-mixer is absolutely critical to the whole thing - without it many of the settings on firewire interfaces just aren’t accessible. I therefore think it quite negligent of the alsa maintainers to not include the mixer alongside the firewire stack code because as this example has shown updates to alsa have created a mismatch with the available ffado-mixer version from PPA. At this point I think my best approach is to find a 2.4.x version of ffado so the mixer is at the same 2.4.x codebase as the baked in alsa version, but only 2.3.x exists in a PPA so it looks like I’ll need to compile one from source. As for system instability I’m no closer to resolving that, but the on/off switch on the front panel of the Saffire is a complete no-no - I do not touch that while the PC is running, even if connecting to the device is proving troublesome… :slight_smile: Of note is that the interface only seems to stay connected when applications talk to it, as soon as I close Ardour the stream disconnects - I wonder if getting the OS to establish a connection might help? Or would that block applications from using it? - who knows!

That’s where I’m at right now - I’ll keep plugging away at it, but frankly the “Full Support” status of the Saffire Pro 26 I/O on the ffado website is likely based on everything as it was probably when Ubuntu 12.04 was current 8 years ago, when jackd was a must have condition for getting one of these beasts running - now that alsa has incorporated the ffado code into a firewire stack, but left behind some critical pieces of the puzzle (i.e. the only mixer capable of seeing the freaking full range of controls!), then I think firewire audio in some ways has regressed. :frowning:

Glad you’re getting to the bottom of all this. As to your final line, however, I would correct it mildly by saying that Firewire audio is over. Nobody (AFAIK) makes these devices anymore. While Linux does have a generally better record of supporting “older” hardware, we never really got to 100% with Firewire audio while it was still in active production. It’s still possible that one or two hardy souls with a deep interest in getting it all “finished” despite the end of production might be able to move things along. However, Apple’s pulling the plugin on firewire in their devices dug the grave for these devices several years ago.

My take on the focusrite pro 26 that I specifically bought because of its linux compatibility and which is pushing me towards units that independently record because of such hassle.
Don’t use FFADO as it makes my Ubuntu unstable (killing a major demon of the system is not exactly a good approach)
Use ALSA to listen/stream to music
Use ALSA through jack server to record on Ardour.
My unit regularly crashes, sometimes it clicks. It also always generate Xruns randomly. I never found the source of it. What I am sure is that the unit has difficulty to synchronize with the clock of the computer. That’s probably the source of some crashes. It is a common crash that happens also without this interface and it is linked with the poorly made ALSA. I am really not impressed about the latency considering I have a really powerful computer. But it could be that it itself creates problems.
I have never really discovered what was wrong with this interface and it is certainly a combination of problems.

It seems this device is about 14 years old. It may be that the capacitors inside the unit are going bad and needs to be replaced.

This 2006 article mentions that the latency of the device was bad on a Mac back then.

https://www.soundonsound.com/reviews/focusrite-saffire-pro-26-io

1 Like

I have a Focusrite Saffire pro 26 on Debian Bullseye (testing of the upcoming version) Ryzen 12 cores 12 threads 3,7GHz. I go with the ffado driver, Kernel 5.6.10 realtime at the moment. Samplerate 48K, 64 Frames, 2 periods. No xruns. Latency 1.3 ms. I think it can be worth testing the firewire driver with the latest mainline kernel.

2 months ago, not yet upgraded to Bullseye, on Debian Buster and kernels 4.19 and alsa as driver, latency was really poor with xruns. 512 frames, 3 buffers. Hammering triplets at the keyboard sounded more like 6-tuplets as one could hear the clack when the keyboard hammers hit the sensor before the tones started to ring. No bigger difference using kernels 5.4, 5.5. With kernels 4.19 and 5.4, the system could freeze on shutdown requiring a hard reset after doing something with alsa and Ardour.

With the ffado driver and kernel 5.6 all of a sudden latency got excellent with no xruns. Hammering triplets sounds like triplets. But… Soloing the higher octaves made obvious aliasing 3 - 4 octaves down, bzzz bzzz bzzz. It has probably been there all the time as it drowns in the left hand comping and i haven’t recognized it. I will try Samplerate 96K. Maybe the aliasing will be below hearing range with 96K samplerate.

kernel 5.6 realtime works best for me. There is a couple of options that might not be compiled into the stock distro kernels. It can be worth to try compiling a custom kernel 5.6. There is a learning curve but not too complicated.

With the ffado driver you don’t need to disable pulseaudio. It is possible to have pulseaudio playing something to the internal soundcard while recording something with the Saffire pro 26.

1 Like